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AGYNAMIX Invoicer - User Manual
Version 1.3.0
Date: February 2026

About AGYNAMIX Invoicer
AGYNAMIX Invoicer is a professional desktop application for freelancers
and small businesses to create and manage quotes, invoices, and time
tracking. The software was speciÆcally developed for the requirements of
the Germanmarket and complies with all GoBD guidelines for audit-proof
archiving.

Key Features

• Sales Documents: Quotes, invoices, correction invoices, and pay-
ment reminders

• Time Tracking: Time sheets with direct invoicing
• Multi-Tenant: Manage multiple companies in one database
• GoBD-Compliant: Audit-proof archiving and audit log
• E-Invoicing: Support for ZUGFeRD and XRechnung
• OfÇine-Capable: No cloud connection required, all data remains lo-
cal

System Requirements
Operating System

• Windows: Windows 10 or higher
• macOS:macOS 11 (Big Sur) or higher
• Linux: Current distributions (Ubuntu 20.04+, Fedora 34+, etc.)

Hardware

• Processor: 64-bit processor
• Memory: Minimum 4 GB RAM (8 GB recommended)
• Hard Drive: 500 MB free space for application
• Additional: SufÆcient storage space for documents and backups

Software

• PDF Viewer: For document preview (e.g., Adobe Reader, Preview,
Evince)
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[i]Note: Java is bundled with the application — you do not need
to install anything separately.

About This Manual
Thismanual is aimed at freelancers and small businesses whowant to use
AGYNAMIX Invoicer to manage their invoicing. It assumes you already
havebasic experiencewith invoicing andare familiarwith typical business
processes.

Manual Structure

The manual is divided into thematic chapters, each covering a functional
area of the application:

1. Menu Bar - All menu functions in detail
2. Dashboard - Overview and key metrics
3. Documents - Create and manage quotes and invoices
4. Time Tracking - Record and bill time sheets
5. Tenants - Manage company data
6. Customers - Maintain customer master data
7. Products - Maintain product master data and reuse in documents
8. Text Snippets - Manage reusable texts
9. Settings - ConÆgure application

10. GoBD Compliance - Understand audit-proof archiving
11. Appendix - Glossary, troubleshooting, and additional information

Conventions in This Manual

Typographic Conventions: - Menu Item - UI elements such as buttons,
menus, and Æelds - Bold - Important terms and highlights - Italic - Empha-
sis and notes - Code - Paths, Ælenames, patterns

Symbols: - [»] EfÆciency Tip: Time-saving workÇows - [*] Best Practice:
Recommended procedures - [!] Important: Critical notes on data secu-
rity/compliance - [i] Trick: Lesser-known features - [~]WorkÇow Tip: Op-
timized processes

Screenshots: - Screenshots aremarked with [Screenshot: Title] and
caption - Numbering is automatic as Figure X
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Quick Start Guide
This quick start guide walks you through the Ærst steps with AGYNAMIX
Invoicer – from installation to your Ærst invoice.

[i] New here? Try demo data Ærst. Before entering your own
real data, you can load a ready-made demo database to explore
all features. See Step 0: Load Demo Data (Optional) below.

About GoBD: GoBD is the German tax authority’s set of rules
for electronic bookkeeping — it ensures invoices are stored in
a tamper-proof, auditable way. AGYNAMIX Invoicer handles all
of this automatically; you just need to know which actions are
permanent (like publishing an invoice).

Step 1: Installation

Takes about 2 minutes.

1. Download the installation Æle for your operating system:
• Windows: .msi or .exe installer
• macOS: .dmg disk image
• Linux: .deb, .rpm, or .AppImage

2. Run the installation:
• Windows: Double-click the installation Æle and follow the wiz-
ard

• macOS: Open the .dmg and drag the application to the Applica-
tions folder

• Linux: Install the package via your package manager or run the
.AppImage directly

3. Start the application:
• Via Start Menu (Windows), Launchpad (macOS), or Applications
Menu (Linux)

Figure 1: The welcome screen when Ærst starting AGYNAMIX Invoicer

Step 2: Create Your First Tenant

Takes about 5 minutes.
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A tenant is your company or business proÆle — think of it as a folder that
holds all your company details, bank account information, and invoice
numbering. Most people only need one tenant, but you can add more if
you manage multiple businesses.

A tenant represents your company or business. This is where all company
data, bank details, and invoice numbering schemes are managed.

1. On Ærst start, the dashboard shows the welcome area
2. Click Create your first tenant
3. Fill out the form with your company data:

Required Fields: - Company name - Complete address (street, postal code,
city, country) - Tax number and VAT ID - Phone and email - Bank details
(IBAN and BIC)

Invoice Numbering Schemes: - DeÆne patterns for invoice and quote
numbers - Example: RE-{year}-{doc_no} results inRE-2025-1 - Set the
starting number (e.g., 1 or 1000)

Figure 2: Form for creating a new tenant with all required Æelds

4. Optional: Upload your company logo (recommended for professional
appearance)

5. Enable Set as default tenant (especially important for the Ærst
tenant)

6. Click Save
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[!] Important: Invoice numbering schemes should be con-
Ægured correctly before the Ærst invoice, as they cannot be
changed after publication.

[i] Tip: Use the {year} variable in the numbering pattern to start a new
numbering scheme each year (e.g., RE-2025-1, RE-2026-1).

Step 3: Create Your First Customer

Takes about 2 minutes.

Customers are the invoice recipients. For each customer, you store ad-
dress, contact details, and billing information.

1. Click Create a customer on the dashboard
2. Or navigate via the sidebar to Customers→ Create New button
3. Fill out the customer form:

Required Fields: - Company name (or Ærst/last name for individuals) -
Complete address - VAT rate (default: 19%) - Currency (default: EUR) - Doc-
ument language (German or English)

Optional Fields: - VAT ID (important for intra-community supplies) -
Email and phone - E-invoice type (ZUGFeRD, XRechnung, or none)

Figure 3: Customer form with all relevant Æelds for invoicing

4. Click Save
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[*] Best Practice: Maintain your customers’ VAT IDs carefully – they are
important for correct tax calculation and VAT returns.

Step 4: Create Your First Invoice

Takes about 3 minutes once you have a tenant and customer.

Now you can create your Ærst invoice.

1. Navigate via the sidebar to Documents
2. Click Create New→ New Invoice
3. Fill out the invoice form:

Document Data: - Select the customer from the dropdown - Invoice date
(pre-Ælled with today) - Due date (default: 14 days after invoice date) - Cur-
rency is inherited from the customer

Add Invoice Items: 1. Click Add Item 2. Description of service/product 3.
Quantity 4. Unit price (net) 5. VAT rate (pre-Ælled fromcustomer) 6. Repeat
for all items

Figure 4: New invoice form with areas for customer data, items, and text snippets

Text Snippets (optional): - Introduction: Text before the invoice items
- Conclusion: Text after the invoice items (e.g., payment terms) - You can
select existing text snippets from the dropdown or enter directly
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Markdown Support: - Bold: **Text** - Italic: *Text* - Lists, headings,
etc. are supported

4. Click Save to save the invoice as a draft
5. Use Preview to check the result

[!] Important: Drafts only have a temporary draft number and
can still be edited.

Step 5: Publish and Export Invoice

Takes less than 1 minute.

When the invoice is ready, you must publish it to receive a Ænal invoice
number.

1. Check all information once more
2. Click Next Step→ Publish
3. The invoice now receives its Ænal invoice number (e.g., RE-2025-1)
4. The status changes from Draft to Published

Figure 5: A published invoice with Ænal invoice number and all action options

[!] Important: After publication, the invoice is immutable for
GoBD reasons. Corrections are only possible via correction in-
voices.

ExportPDF:1. Click thepreview icon (eye icon) or in themenuonPreview
2. The PDF is automatically saved in the conÆgured documents folder 3.
The Æle opens in your PDF viewer 4. You can now send the Æle via email or
print it

[i] Tip: ConÆgure the documents folder in the settings before exporting
your Ærst invoice. This way, all PDFs are automatically stored in the right
place.
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Step 6: Record Payment

Takes less than 1 minute.

When the customer has paid the invoice, record the payment:

1. Open the invoice by clicking Edit
2. Click Next Step→ Mark as paid
3. Enter the payment date
4. Optional: Record the actual amount received (for partial payments)
5. Click Record payment
6. The status changes to Fully paid

Figure 6: Dialog for recording a payment with date and amount

[*] Best Practice: Record payments promptly to keep track of outstanding
receivables. The dashboard shows you all open and overdue invoices.

Step 0: Load Demo Data (Optional)
If you want to explore AGYNAMIX Invoicer before entering your own data,
load the demo database Ærst. It takes about 30 seconds and gives you a
fully working environment with sample invoices, customers, and tenants
to click around in.

1. On the welcome screen of the dashboard: Click Load Demo Data
2. Or via the menu: Edit→ Load Demo Data (on Ærst start)
3. The database is Ælled with realistic sample data:

• 2 sample tenants (German companies)
• 100 sample customers
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• Approx. 300 documents (quotes, invoices, payment reminders)
• Time sheets with entries

[i] Tip: Demo data is ideal for exploring the application without
having to enter your own data. You can remove it anytime via
Edit→ Delete Demo Data, or simply continue setting up your
real data in parallel by switching databases.

Next Steps
After this quick start, you can:

1. Explore the dashboard: Get an overview of your key metrics
2. Create text snippets: Create reusable texts for introductionsandcon-

clusions
3. ConÆgure settings:

• Set up backup strategy
• ConÆgure document path with naming pattern
• Customize theme (light/dark)

4. Addmore customers: Build your customer base
5. Use time tracking: Record working hours and bill them directly
6. Understand GoBD compliance: Learn about the archiving features

[?] Continue reading: The following chapters of thismanual cover all func-
tions in detail. Use the table of contents to jump directly to the topics rele-
vant to you.

Help and Support
In the Application

• Guided Tour: Help→ Start guided tour for an interactive intro-
duction

• Documentation: Help → Documentation opens the online docu-
mentation

• Log: Help→ Show log for technical problems

Online Resources

• Website: https://www.agynamix.de
• Support Email: support@agynamix.de
• Updates: The application automatically checks for new versions
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Data Location

Your data is stored locally on your computer:

• Windows: %LOCALAPPDATA%\agynamix-
invoicer\invoicer_db.db

• macOS: ~/Library/Application Support/agynamix-
invoicer/invoicer_db.db

• Linux: ~/.local/share/agynamix-invoicer/invoicer_db.db
[!] Important: Create regular backups! ConÆgure automatic
backups in the settings to prevent data loss.

Copyright and License
Copyright © 2025 AGYNAMIX
All rights reserved.

AGYNAMIX Invoicer is proprietary software. Use is only permitted with a
valid license.

This manual may be copied for personal use. Distribution to third parties
or commercial use without express permission is not permitted.

Trademarks: - AGYNAMIX is a registered trademark of AGYNAMIXGmbH
- All other mentioned brands are the property of their respective owners

Disclaimer: The information in this manual was created with the greatest
care. Nevertheless, errors cannot be completely excluded. No liability is
assumed for damages resulting from errors in this manual.

Version History
Version 1.3.0 (February 2026)

• Updated manual for Invoicer v1.3.0
• Added documentation for encrypted backups (Chapter 9.4)
• Added S3 archive backend documentation (Chapter 9.5)
• Added auto-assign text blocks documentation (Chapter 8.15)
• Added enhanced full-text search documentation (Chapter 3.2)
• Added text-only line items documentation (Chapter 3.4)
• Added multiple payment proÆles and QR codes (Chapter 5.18)
• Added document template customization (Chapter 5.19)
• Added undo payment documentation (Chapter 3.8)
• Added related documents panel (Chapter 3.19)
• Added payment overview screen (Chapter 3.20)
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• Added tax rules and admin section (Chapter 9.15-9.16)
• Added number ranges documentation (Chapter 9.17)
• Added new Chapter 12: Operating Modes (Standalone / Host / Client)
• Added glossary terms for client-server mode
• Added FAQ section (Chapter 11)
• Added migrating to a new computer guide (Chapter 11)

Version 1.2.0 (January 12, 2026)

• Updated the manual for Invoicer v1.2.0
• Addeddocumentation for email settings (SMTP/IMAP) anddocument
email templates

• Added “send document via email” workÇow documentation
• Added user management documentation
• Extended customer/tenant chapters with additional Æelds and email
distinctions

Good luck with AGYNAMIX Invoicer!

Wewish you efÆcient work and clear invoicemanagement. If you have any
questions or suggestions, please feel free to contact us.

1. Menu Bar
Themenu bar is located at the top of the application window and provides
access to important functions that are not accessible via the sidebar. It con-
sists of threemainmenus (File,Edit,Help) aswell as the tenant selection
in the center.

Figure 7: The menu bar with all three menus and the central tenant selection
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1.1 File Menu
The File menu contains functions for data backup, restore, and GoBD-
compliant archiving.

Some actions are grouped in submenus: - File → Export → … - File →
Import→…

Figure 8: The opened File menu with all available options

Create Backup…

Creates a complete backup of your database.

Function: - Saves the complete database in a single Æle - Contains all
tenants, customers, documents, time sheets, and settings - Automati-
cally compressed (ZIP format) - Filenamecontains timestamp: invoicer-
{production|sandbox}-YYYY-MM-DD-HHMMSS.zip
Usage: 1. Click File → Create Backup... 2. Choose a destination di-
rectory in the dialog 3. The backup is created and saved in the selected
directory 4. A success message conÆrms the created backup
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Figure 9: Dialog for selecting the storage location for the database backup

When to create backups: - Before major changes (e.g., bulk editing, up-
dates) - Regularly (daily/weekly) - see automatic backups in settings - Be-
fore system maintenance or operating system updates - Before switching
to a new computer

[!] Important: Backups should be stored in a secure location
outside your computer (external harddrive, NAS, cloud storage).
In case of hard drive failure, local backups are not accessible.

[i] Tip: ConÆgure automatic backups in the settings so you never forget
to create a backup. The application automatically creates a backup when
closing.

Restore from Backup…

Restores a previously created backup.

Function: - Completely overwrites the current database - All current data
will be lost - Imports all tenants, customers, documents, and settings from
the backup

Usage: 1. Click File→ Restore from Backup... 2. Warning: A dialog
warnsyou that all currentdatawill beoverwritten3. ConÆrmwithRestore
or cancel with Cancel 4. Select the backup Æle (.zip) in the Æle selection
dialog 5. The application loads the backupand restarts 6. After restart, you
will see the data from the backup
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Figure 10: Warning dialog before overwriting the current database

Use Cases: - After data loss or corruption - When switching to a new com-
puter - After accidental deletion of important data - Duringmigration from
an old to a new installation

[!] Important: The restore cannot be undone. Create a backup
of the current database beforehand if you want to access it later.

[*]BestPractice: Regularly testwhether yourbackupsworkbyperforming
a restore in a test installation.

Verify Audit Log…

Checks the integrity of the internal audit log (transaction log).

Function: - VeriÆes the cryptographic hash chain of all audit log entries
- Ensures that no entries were subsequently changed or deleted - GoBD-
compliant veriÆcation of immutability - VeriÆcation is performed on a per-
tenant basis

Usage: 1. Click File → Verify Audit Log... 2. Select the tenant to
verify 3. Click Start Verification 4. The application checks all audit
log entries 5. The result is displayed: - Valid: All entries are unchanged -
Invalid: Manipulations were detected
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Figure 11: Success message after successful veriÆcation of the audit log

Result Details: - Total entries checked: Number of veriÆed log entries -
Sequence range: First and last sequence number - Chain status: Valid or
Invalid -Sequence gaps: Missing entries (should not occur) -Hasherrors:
List of entries with invalid hashes

Whentoverify: -During taxaudits (uponauditor’s request) -Afterunusual
systemevents -Regularly forquality assurance (e.g., annually) - Before sub-
mission to external archiving

[i] Trick: You can perform veriÆcation at any time – it doesn’t
change any data and only takes a few seconds.

Export Audit Log…

Exports the audit log to a GoBD-compliant archive.

Function: - Creates aZIParchivewithall audit log entries for a timeperiod -
Contains all associated PDF documents - Hash chain for verifying integrity
- Format complies with GoBD requirements for external archiving

Usage: 1. Click File → Export → Export Audit Log... 2. Select the
tenant 3. Select the time period: - Month and year (e.g., November 2025)
4. The export path is shown (automatically determined based on archive
root) 5. Click Start Export 6. Wait until the export is complete 7. The
successmessage shows the Æle path 8. Optional: Use “Copy To” to copy the
archive to an additional location
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Figure 12: Dialog for exporting the audit log with time period and tenant selection

Archive contents: - audit_log_YYYYMM-YYYYMM.csv - All audit
log entries in CSV format (UTF-8 with BOM) - audit_log_YYYYMM-
YYYYMM_verification.json - VeriÆcation metadata with hashes -
documents/ - Folder with all exported PDF documents - README.txt -
German instructions for archive structure

Filename: - Format: gobd_export_{tenant}_{startYYYYMM}-
{endYYYYMM}_{hash16}.zip -Example: gobd_export_my_company_202511-
202511_a1b2c3d4e5f6g7h8.zip - A sidecar .meta.txt Æle is also
created for integrity veriÆcation

When to export: -Monthly/Quarterly: For regular archiving - Annually:
At year-end - During tax audit: Upon request from the tax ofÆce - During
operational audit: For submission to auditor - Beforemajor changes: As
additional backup

[!] Important: GoBD requires audit logs to be retained for at
least 10 years. Archive the exports on a secure storagemedium
and create copies in different locations.

[~]WorkÇow Tip: At the end of the month, automatically export the audit
log and archive it together with the PDF invoices. This way you meet all
GoBD requirements.

Export Customers (CSV)…

Exports your customer master data as a CSV Æle.
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Usage: 1. Click File → Export → Export Customers (CSV)... 2. Se-
lect a destination folder 3. The application creates a customers-export-
...csv Æle in that folder

[?] Continue reading: Details onCSV import/export are described inChap-
ter 6 (Customers).

Export Products (CSV)…

Exports your product master data as a CSV Æle.

Usage: 1. Click File → Export → Export Products (CSV)... 2. Se-
lect a destination folder 3. The application creates a products-export-
...csv Æle in that folder

[?] Continue reading: Details onCSV import/export are described inChap-
ter 7 (Products).

Import & Verify Export…

Imports and veriÆes a previously exported audit log archive.

Function: - Reads in aGoBD export archive (.zip) - Checks the hash chain
of the audit log - VeriÆes all contained PDF documents - Shows detailed
veriÆcation results

Usage: 1. Click File→ Import→ Import & Verify Export... 2. Click
Select File3. Select apreviously exportedarchive (.zip) 4. ClickStart
Verification 5. Wait until veriÆcation is complete 6. Check the result
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Figure 13: Dialog for selecting and verifying an imported audit log archive

VeriÆcation Results:

Chain Integrity: - Total entries: Number of log entries in the archive -
Sequence range: First and last sequence number - Chain status: Valid
(✓) or Invalid ([x]) -Sequence gaps: Missing entries (normal for date range
exports) - Chain errors: List of entries with invalid hashes

Document VeriÆcation: - Documents in archive: Number of contained
PDFs - VeriÆed documents: Number of successfully checked PDFs - Doc-
ument errors: List of documents with veriÆcation errors

Figure 14: Successful veriÆcation of an archive with all details on chain integrity

33



Figure 15: VeriÆcation with detected errors – documents were subsequently modi-
Æed

Interpreting the Results:

[+] Valid Archive: - Chain status: Valid - No hash errors - All documents
veriÆed - → Archive is unchanged and legally secure

[!] Sequence Gaps in Date Range Export: - Normal when only a time pe-
riod was exported - Entries outside the time period are missing from the
sequence - Integrity of included entries remains veriÆable - Note text ex-
plains the gaps

❌ Invalid Archive: - Chain status: Invalid - Hash errors present - Docu-
ments were modiÆed - → Archive was tampered with or is corrupted

Use Cases: - During tax audit: Proof of immutability of archives - Af-
ter archiving: Check whether archiving was successful - Before sharing:
VeriÆcation before handover to accountant/auditor - After storage media
change: Check after migration to newmedia

[*]Best Practice: Verify audit log archives immediately after ex-
port and before sharing. This ensures that the archives were
created correctly and are immutable.

[i] Tip: Keep the original archive together with a veriÆcation protocol
(screenshot). In case of inquiries, you can prove that the archive was valid
at the time of creation.
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Import Customers (CSV)…

Imports customers from a CSV Æle.

Usage: 1. ClickFile→Import→Import Customers (CSV)... 2. Select
the CSV Æle 3. Review the mapping and preview 4. Start the import

[?] Continue reading: Details onCSV import/export are described inChap-
ter 6 (Customers).

Import Products (CSV)…

Imports products from a CSV Æle.

Usage: 1. Click File→ Import→ Import Products (CSV)... 2. Select
the CSV Æle 3. Review the mapping and preview 4. Start the import

[?] Continue reading: Details onCSV import/export are described inChap-
ter 7 (Products).

Export Data (Z3)…

Exports tax-relevant data (Z3/GDPdU) for audits.

Prerequisites: - The Archive Root is conÆgured in settings

Usage: 1. Click File → Export → Export Data (Z3)... 2. Select ten-
ant and time period/Æscal year (depending on the dialog) 3. Start export 4.
After completion, the storage location is shown

[?] Continue reading: Details on Z3 export are described in Chapter 10
(GoBD Compliance).

Export DATEV (Buchungsstapel)…

Creates a DATEV booking batch (EXTF) for accounting/tax advisory.

Function: - Exports relevant outgoing documents to the DATEV
EXTF format - Creates a ZIP Æle containing the export CSV
(EXTF_Buchungsstapel.csv) - Stores the export in the GoBD archive
(including integrity metadata)

Prerequisites: - The Archive Root is conÆgured in settings - The DATEV
Client number is set in settings (required)
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Important note about the period: - An export must not span across two
Æscal years. Choose a period within one Æscal year.

Usage: 1. ClickFile→Export→Export DATEV (Buchungsstapel)...
2. Select tenant and period 3. Check DATEV settings (advisor number,
client number, revenue account) 4. Start export 5. After completion you
can open the export folder in your Æle manager

[?] Continue reading: DATEV settings are described in Chapter 9 (Set-
tings).

Archive Browser

Opens the audit log view Æltered to archive exports.

Function: - Navigates to the audit log view - Automatically applies a Ælter
for archive exports (e.g., audit log exports, Z3 exports, DATEV exports) -
Useful for quickly looking up export events (and their timestamps)

Usage: 1. Click File → Archive Browser 2. The application switches
to the audit log view with a matching Ælter 3. Adjust Ælter/time range if
needed

Exit

Closes the application.

Function: - Terminates the application cleanly - Saves all open changes -
Automatically creates a backup (if conÆgured) - Performs cleanup tasks

Usage: - Click File→ Exit - Or close the window via the X symbol - Or use
the keyboard shortcut (if conÆgured)

Whenquitting: 1. Unsavedchanges: Dialogasks if youwant to save2. Au-
tomatic backup: If enabled in settings, a backup is created 3. Save win-
dow position: Size and position are saved for the next start 4. Sidebar
status: Collapsed/expanded is saved
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Figure 16: Dialog for unsaved changes before quitting

[!] Important: Always close the application viaFile→Exit and
not by terminating the process. Only this way will all data be
saved correctly and backups created.

[*] Best Practice: ConÆgure automatic backups when quitting in the set-
tings. This way you always have a current backup, even if you forget.

1.2 Edit Menu
The Edit menu provides access to the settings and demo/sandbox func-
tions.

Figure 17: The Edit menu with settings and demo/sandbox actions

Preferences

Opens the application’s settings area.
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Function: - Navigates to the settings page - Equivalent to clicking Set-
tings in the sidebar

Usage: - Click Edit→ Preferences - The sidebar automatically switches
to Settings - The main area shows the settings page

Settings Areas: - Appearance: Theme (light/dark), language - Backup:
ConÆgure automatic backups - Documents: Paths and naming patterns
for PDF export - Updates: Automatic update check - Email: SMTP/IMAP
conÆguration for sending emails - Document Emails: Templates for doc-
ument email subject/body - User Management: Users, roles, and permis-
sions (if enabled)

[i] Tip: Settings are also accessible via the sidebar. The menu
entry is a shortcut for users who prefer the menu bar.

[?] Continue reading: All settings are described in detail in Chapter 9 (Set-
tings).

Load Demo Data

Downloads a demo database and creates a sandbox so you can safely try
the application.

Function: - Downloads a demodatabase from the internet - Creates a sand-
box database (separate from your production data)

Usage: 1. Click Edit → Load Demo Data 2. ConÆrm the dialog (internet
connection required) 3. After download you can switch to the sandbox

Switch to Sandbox

Switches to the sandbox database (test environment).

Function: - Activates sandbox mode - All changes affect only the sandbox
database

Usage: - Click Edit→ Switch to Sandbox
Visibility: - Only available if a sandbox exists and you are currently in pro-
duction

Corrupted Sandbox Database

If the sandbox database is corrupted or empty, the application shows an
informational dialog.
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Dialog title: Corrupted Sandbox Database
What you can do: - The application offers to remove the sandbox (button:
Delete Corrupted Sandbox) - Your production data is not affected

Hint: - To create a new sandbox afterwards, use Edit→ Load Demo Data.

Sandbox Database Removed

If a corrupted/empty sandbox was removed automatically, the application
informs you about it.

Dialog title: Sandbox Database Removed
Important: - You are using the production database again - Your produc-
tion data is not affected

Switch to Production

Switches back to the production database.

Function: - Deactivates sandboxmode -Youworkwith your real data again

Usage: - Click Edit→ Switch to Production
Visibility: - Only available if you are currently in the sandbox

Delete Demo Data

Deletes the sandbox database (demo data).

Function: - Permanently removes demo/sandbox data - Production data is
not affected -Switchesback to theproductiondatabase (if youare currently
in the sandbox) - Only visible if a sandbox exists

Usage: 1. Click Edit → Delete Demo Data 2. Warning: Dialog asks for
conÆrmation 3. ConÆrm with Delete 4. The demo data is removed 5. You
start with an empty database
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Figure 23: Warning dialog before deleting demo data

[!] Important: This action cannot be undone. If you’ve already
entered your own data, it will also be deleted. Create a backup
Ærst!

[!] Important: This action cannot be undone. It affects the sand-
box/demo data. Create an additional backup of your production
data if needed.

[*]BestPractice: Usedemodata to test the application. When you’re ready
to work productively, delete the demo data and start with your own data.

1.3 Help Menu
The Helpmenu provides access to documentation, support functions, and
system information.

Figure 18: The opened Help menu with documentation and support options
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Quick Reference

Opens the quick reference in your browser.

Usage: - Click Help→ Quick Reference

Manual

Opens the full user manual in your browser.

Usage: - Click Help→ Manual

Download Compliance Agreement

Downloads the procedural documentation (Verfahrensdokumentation) as
a PDF.

Usage: - Click Help→ Download Compliance Agreement

Check for Updates

Manually checks if a new version is available.

Function: - Contacts the update server - Compares the installed version
with the available version - Shows a result (update available or not)

Usage: 1. Click Help→ Check for Updates 2. Wait while the check runs
3. No update available: Dialog informs you that you’re using the latest
version 4. Update available: Dialog shows the new version and changes 5.
Click Download to go to the download page
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Figure 19: Dialog with information about an available update
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Figure 20: Dialog conÆrming that the installed version is current

Automatic Updates: - In the settings, you can enable automatic update
checking on startup - The application then checks for new versions on ev-
ery start - You receive a notiÆcation when an update is available

[*] Best Practice: Enable automatic update checking in the set-
tings. This way you won’t miss important security updates or
new features.

Open Database Folder

Opens the folder where the database is stored.

Function: - Opens the database folder in your system’s Æle manager -
Shows the invoicer_db.db Æle - Useful for manual backup or migration

Usage: - Click Help→ Open Database Folder - Your Ælemanager opens
the folder (Finder on macOS, Explorer on Windows, Nautilus/Dolphin on
Linux)

Database Locations: - Windows: %LOCALAPPDATA%\agynamix-
invoicer\ - macOS: ~/Library/Application Support/agynamix-
invoicer/ - Linux: $XDG_DATA_HOME/agynamix-invoicer/ (typically
~/.local/share/agynamix-invoicer/)
What you’ll Ænd in the folder: - invoicer_db.db - The SQLite database
with all data - invoicer_db.db-wal - Write-Ahead-Log (temporary Æle
during operation) - invoicer_db.db-shm - Shared Memory (temporary
Æle during operation)

[!] Important: Don’t manually modify or delete the database
Æles while the application is running. This can lead to data loss
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or corruption.

[i] Tip: For a manual backup, copy the invoicer_db.db to a safe loca-
tionwhile the application is closed. However, preferably use the integrated
backup function.

Show Log

Displays the application log.

Function: - Opens the internal log window - Shows all application events,
warnings, and errors - Useful for troubleshooting and support requests

Usage: - Click Help→ Show Log - The log window opens in the main area
of the application - Scroll through the entries or use the search function

Figure 21: The log view with Æltered log entries

Understanding log entries: - INFO: Normal information (e.g., “Invoice
created”) - WARN: Warnings (e.g., “Backup folder not conÆgured”) - ER-
ROR: Errors (e.g., “File could not be saved”) - Each entry contains times-
tamp, level, and message

Filter log: - By level (INFO, WARN, ERROR) - By time period - By search
term
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Export log: - Click Export to save the log as a text Æle - Useful for support
requests

[i] Tip: In case of technical problems, check the log Ærst. Often
you’ll Ænd clues to the cause there (e.g., missing write permis-
sions, full disk).

[*]Best Practice: For support requests, export the log and attach it to your
email. This helps the support team solve your problem faster.

Start Guided Tour

Starts an interactive tour through the application.

Function: - Shows a step-by-step introduction - Highlights relevant UI el-
ements - Explains the most important functions - Ideal for new users

Usage: 1. ClickHelp→Start Guided Tour2. The tour begins andguides
you through the application 3. Follow the instructions and click Next 4.
You can exit the tour at any time with Cancel

Figure 22: The guided tour explains the dashboard and highlights relevant areas

Tour contents: - Dashboard and metrics - Sidebar navigation - Creat-
ing tenants and customers - Creating documents - Using text snippets -
Recording time sheets

[i] Tip: You can start the tour multiple times – ideal for training
colleagues or employees.
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License…

Opens the license dialog.

Visibility: - This menu item is not available in prerelease builds.

License Prefs Debug…

Opens a debug dialog for license preferences (development/support).

Visibility: - This menu item is only visible in devmode builds.

About

Shows information about the application.

Function: - Display of version number - Copyright information - License
information - List of used open-source libraries

Usage: - Click Help→ About - The About dialog opens

Figure 24: The About dialog with version information and credits

Information in the dialog: - AGYNAMIX Invoicer - Name and logo - Ver-
sion: e.g., 1.0.0 - Copyright: © 2025 AGYNAMIX - License: License type
and conditions - Libraries: List of used open-source components with li-
censes
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Used libraries (selection): - Kotlin &ComposeMultiplatform - SQLDelight
- Apache PDFBox - Mustangproject (ZUGFeRD) - Others (see complete list
in the dialog)

[i] Tip: The version number is important for support requests.
Always provide the version when you need help.

1.4 Tenant Selection
In the center of themenu bar is the tenant selection – a central element for
quick switching between different companies.

Figure 25: The tenant selection in the center of themenu bar withmultiple tenants

Function

Purpose: - Quick switch between tenants (companies) - Shows the cur-
rently selected tenant - Default tenant is marked with star symbol ([*])

Effect of selection: - Filters all lists by the selected tenant: - Dashboard
metrics - Document list - Customer list - Time sheets - New documents are
automatically assigned to the selected tenant - Invoice and quote numbers
use the tenant’s numbering scheme

Usage

Switch tenants: 1. Click on the tenant selection (dropdown) 2. The list of
all tenants opens 3. Click on the desired tenant 4. The application imme-
diately switches to the selected tenant 5. All views update automatically
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Figure 26: Opened tenant dropdown with default tenant marking

Default tenant: - Marked with a star symbol ([*]) - Automatically prese-
lected when starting the application - You can change the default tenant
in tenant management

If only one tenant exists: - The selection shows only this one tenant - A
dropdown is still present for future tenants

If no tenants exist: - The selection shows “Please create tenant” - Youmust
Ærst create a tenant (see quick start)

Multi-Company Management

The tenant selection enables managing multiple companies in one
database – ideal for:

Use Cases: - Multiple sole proprietorships: You operate multiple self-
employed activities - Different legal forms: GmbH and sole proprietor-
ship in parallel - Clients for accounting: As an accountant, you manage
multiple corporate clients -Different brands: You invoice under different
company names

Advantages: - Separate numbering schemes per tenant - Individual com-
pany data and logos - Separate bank details - Clear separation of docu-
ments - Easy switching between tenants

[~]WorkÇowTip: Create a separate tenant for each legally inde-
pendent company. This keeps invoices cleanly separated and
you avoid confusion.

[i] Tip: The default tenant is preselected on startup. Set the tenant you
work with most frequently as default.

[?] Continue reading: More on tenant management can be found in Chap-
ter 5 (Tenants).
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Summary
Themenu bar provides access to important high-level functions:

File Menu: - [+] Create and restore backups - [+] GoBD-compliant exports
(Audit Log, Z3, DATEV) - [+] Archive veriÆcation and archive browser - [+]
Exit application

Edit Menu: - [+] Quick access to settings

Help Menu: - [+] Quick reference/manual and support - [+] Check for up-
dates - [+] Show log - [+] Guided tour - [+] System information

Tenant Selection: - [+] Quick switching between companies - [+] Auto-
matic Æltering of all lists - [+] Multi-companymanagement in one database

[*] Best Practice: Use the menu bar for administrative tasks
(backups, exports, settings) and the sidebar for daily work with
documents and customers.

Next Steps: In the next chapter, you’ll learn all about the dashboard – the
central overview of your business activities.

2. Dashboard
The dashboard is the control center of AGYNAMIX Invoicer. It provides you
witha complete overviewof yourbusiness activities at a glance– fromopen
invoices to revenue trends to overdue payments.

Figure 27: The complete dashboard with hero area and all statistics cards
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2.1 Dashboard Structure
The dashboard consists of two main areas:

Hero Area (Header Section)

The upper area shows the most important metrics at a glance:

Published This Year: - Large number shows the total count of published
documents in the current year - Includes all document types (quotes, in-
voices, correction invoices) - Only published documents are counted (no
drafts)

Monthly Revenue (Chart): - Bar chart shows revenue development over
the last 12 months - Hover over a bar to see exact values - Shows paid in-
voices (not open receivables) - For multiple currencies: Separate display
per currency

Figure 28: The hero area with total documents and revenue trend chart

Metric Cards

Below are colored cardswith detailed statistics. Each card is clickable and
opens the Æltered document list.

2.2 Metrics in Detail
Published This Year

What is counted: - All documents published in the current calendar year -
Includes: Quotes, invoices, correction invoices, payment reminders - Only
status Published and higher (no drafts)
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Click action: - Opens document list Æltered by “Published this year” -
Shows all documents of the current year

Color: Primary blue

Figure 29: The metric card “Published This Year”

[i] Tip: This number gives you a quick overview of your business activity.
A decline compared to previous months may indicate declining order ac-
tivity.

Drafts

What is counted: - All documentswith status Draft - Across all document
types - UnÆltered by tenant (if a tenant is selected, only its drafts)

Click action: - Opens document list Æltered by status “Draft” - Shows all
non-Ænalized documents

Color: Tertiary (Light blue/gray)

Figure 30: Metric card with the number of open drafts

Why important: - Drafts are not yet Ænalized - They don’t have a Ænal num-
ber yet - They can still be edited or deleted - Too many drafts indicate un-
Ænished tasks
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[~] WorkÇow Tip: Regularly review your drafts and Ænalize or
delete them. This keeps you organized and avoids outdated doc-
uments.

Requires Attention

What is counted: - Documents that require your attention: - Open quotes
(published but not yet accepted/rejected) - Expired quotes (validity date
exceeded) - Unpublished documents (drafts that should be Ænalized) - Par-
tially paid invoices (remaining payment outstanding)

Click action: - Opens document list Æltered by “Requires attention” -
Shows all documents that need action

Color: Error red

Figure 31: Metric card for documents requiring action

Typical actions: - Open quotes: Mark as accepted/rejected or create in-
voice - Expired quotes: Follow up with customer or mark as rejected -
Drafts: Finalize and publish - Partial payments: Record remaining pay-
ment or create reminder

[*]Best Practice: Check this card daily. It shows you at a glance
where action is needed.

Payment Overdue

What is counted: - Invoices and correction invoices that are overdue - Sta-
tus: Published or Partially paid - Due date (Payment by) is in the
past - Remaining balance > 0

Click action: - Opens document list Æltered by “Overdue” - Shows only
overdue invoices

Color: Error container (Light red)

52



Figure 32: Metric card with number of overdue invoices

Why important: - Overdue invoices endanger your cash Çow - You should
act promptly (reminder, payment notice) - The longer invoices remain
open, the more difÆcult collection becomes

Typical actions: - Send payment reminder via email - Create reminder
(1st reminder→2nd reminder→3rd reminder) - Followupbyphone -Com-
mission collection agency (for repeated payment delays)

[!] Important: Overdue invoices should never be ignored. The
earlier you respond, the higher the success rate for collection.

[~] WorkÇow Tip: Automatically create reminders for overdue invoices.
The application helps you stay on top of things.

Total Revenue

What is counted: - Sum of all paid amounts from invoices and correction
invoices - Across all years (total revenue since inception) - Status: Par-
tially paid, Fully paid, Published (only paid amounts) - Grouped by
currency

Display: - Primary currency (largest sum) displayed large - Additional cur-
rencies as small chips below

Click action: - Opens document list Æltered by “Total revenue” - Shows all
invoices and correction invoices

Color: Secondary (Darker blue/gray)
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Figure 33: Metric card with total revenue, primary currency large, others as chips

Interpretation: - Shows realized revenue (only actually received pay-
ments) - Open receivables are NOT counted - Provides information about
total company income - Important for accountant and year-end closing

[i] Tip: Total revenue is particularly interesting at year-end. It shows you
howmuch revenue you actually generated (not just invoiced).

Revenue This Year

What is counted: - Sum of all paid amounts from invoices and correction
invoices - Only for the current calendar year - Status: Partially paid,
Fully paid, Published (only paid amounts) - Grouped by currency

Display: - Primary currency (largest sum) displayed large - Additional cur-
rencies as small chips below

Click action: - Opens document list Æltered by “Revenue this year” - Shows
all invoices and correction invoices of the current year

Color: Primary container (Light blue)
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Figure 34: Metric card with revenue for the current year

Interpretation: - Provides information about annual performance - Com-
parable with previous years - Important for VAT advance return - Shows
whether annual revenue targets are being met

Comparison with total revenue: - Total revenue: All years since incep-
tion - Revenue this year: Only current calendar year

[*]Best Practice: Set annual revenue targets and regularly com-
pare them with this metric. This shows you if you’re on track.

[i] Tip: Use the revenue chart in the hero area to analyze monthly devel-
opment. This helps you recognize seasonal Çuctuations and plan accord-
ingly.

Outstanding Amounts

What is counted: - Sum of all outstanding receivables from invoices
and correction invoices - Status: Published (completely unpaid) or Par-
tially paid (remaining amount) - Calculation: Total amount minus al-
ready received payments - Grouped by currency

Display: - Primary currency (largest sum) displayed large - Additional cur-
rencies as small chips below

Click action: - Opens document list Æltered by “Outstanding amounts” -
Shows all invoices with remaining balance

Color: Inverse primary (Contrast color)
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Figure 35: Metric card with the sum of all outstanding receivables

Interpretation: - Shows how much money you’re still owed - Important
for liquidity planning - High outstanding amounts = liquidity risk - Low
outstanding amounts = Good customer payment behavior

Typical actions: - Check and record payment receipts - Send payment re-
minders - Create reminders (when overdue) - Arrange payment plans with
customers

[!] Important: Outstanding amounts are not “revenue,” but
pending receivables. They only become revenue after payment
is received.

[~] WorkÇow Tip: Regularly check outstanding amounts and reconcile
them with your bank statements. Record payment receipts promptly to
maintain a realistic overview.

2.3 Navigation via Metrics
All metric cards are clickable – a click opens the document list with the
appropriate Ælter.

How it works:

1. Click onmetric card
• Click dashboard card (e.g., “Payment overdue”)

2. Document list opens
• The sidebar automatically switches to “Documents”
• The document list is already Æltered

3. Filter is preset
• Appropriate Ælters are active

56



• You only see relevant documents
4. Adjust or reset Ælter

• You can further adjust the Ælter
• Or reset all Ælters with “Clear Ælters”

Figure 36: The Æltered document list after clicking the “Payment overdue” card

Examples:

Payment overdue: - Filter: Document types = Invoice, Correction invoice
- Filter: Status = Published, Partially paid - Filter: Due payments = Active -
Result: Only overdue invoices

Drafts: - Filter: Status = Draft - Result: All documents in draft status

Revenue this year: - Filter: Document types = Invoice, Correction invoice -
Filter: Status = Partially paid, Fully paid, Published - Filter: Year = Current
year - Result: All invoices of the current year

[i]Tip: Navigation via dashboard cards is often faster thanman-
ual Æltering in the document list. Use it to jump directly to rele-
vant documents.

2.4Welcome Area (on First Start)
Whenyou start the application for the Ærst time or haven’t entered any data
yet, the dashboard shows awelcome area instead of metrics.
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Figure 37: The welcome area with step-by-step instructions for getting started

Welcome Actions:

Load Demo Data: - Fills the database with realistic sample data - Ideal
for exploring the application - Includes: 2 tenants, 100 customers, approx.
300 documents, time sheets - Can be deleted later

Restore fromBackup: - Restore existing data fromabackup -Usefulwhen
switching to a new computer - Overwrites the current (empty) database

CreateFirstTenant: - Click opens the tenant creation form-Required step
before you can create invoices

Create Customer: - Click opens the customer creation form - Required for
invoice and quote addressing

Create First Document: - Click opens the document creation form - Starts
your workÇow

Progress: - The welcome steps are checked off one by one - Once tenant,
customer, and document exist, the welcome area disappears - The dash-
board then shows the metrics
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Figure 38: Welcome area shows progress – tenant and customer already created

[*] Best Practice: Follow the steps in the welcome area one by
one. This ensures that all required master data is present.

[i]Tip: If youwant to test the application Ærst, load the demodatabase. You
can remove it anytime via Edit→ Delete Demo Data.

2.5 Empty Dashboard
If you’ve created tenants and customers but haven’t created any docu-
ments yet, the dashboard shows an empty state.

Figure 39: The dashboard in empty state – tenants and customers exist, but no
documents yet

Display: - Symbol (Insights icon) - Title: “Your workspace is ready” - Text:
“Once you create sales documents, you’ll see live insights here.”

What to do: - Navigate to Documents and create your Ærst invoice or quote
- Or use time tracking to record time sheets and bill them
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[i]Tip: The empty state shows you that basic conÆguration (ten-
ant, customer) is complete. Now you can start productive work.

2.6 Multiple Currencies
If you bill customers in different currencies, the dashboard displaysmul-
tiple currencies simultaneously.

Display:

Primary Currency: - Currency with the highest sum is displayed large -
Default position in metric card text

Additional Currencies: - As small, colored chips below themain number -
Example: USD 5,432.10, GBP 2,100.00 - Sorted by amount (descending)

Figure 40: Metric card shows EUR as primary currency and USD/GBP as chips

Currency Handling:

No Automatic Conversion: - The application does NOT automatically
convert - Each currency is summed and displayed separately - You see
amounts in original currencies

Why no conversion: - Exchange rates change daily - Conversions would
be incorrect at time of payment - You have control over currency exchange
- Accounting correct

Recommendation: - Bill primarily in one main currency (e.g., EUR) - Use
foreign currencies onlywhen the customer requires it - Consider exchange
rate risks in your pricing
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[*] Best Practice: If you regularly bill in foreign currencies,
manually add currencies with current exchange rates for inter-
nal evaluations. The dashboard shows you original amounts.

2.7 Monthly Revenue Chart
In the hero area of the dashboard is a bar chart showing revenue develop-
ment over the last 12 months.

Figure 41: Monthly revenue chart with tooltip on mouse-over

What is displayed:

Bar per Month: - Each bar represents a month - Height = Revenue of this
month (paid invoices) - Color: Gradient from primary color to background

Time Period: - Last 12 months - Rolling (current month + 11 previous
months) - Month names below bars

Tooltip: -Hoverover abarwith themouse -Tooltip shows: Month, revenue,
currency - Example: “Revenue in November: 12,345.67 EUR”

Interpretation:

Recognize Trends: - Rising trend =Growth - Falling trend =Decline - Fluc-
tuations = Seasonality

Seasonal Patterns: - Some industries have seasonal Çuctuations - Exam-
ple: Summer vacation = fewer orders - Plan with these patterns (liquidity,
vacation)

Year-to-Year Comparison: - Compare currentmonthwith previous year’s
month - Recognize long-termdevelopments - Determine growth or decline
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Figure 42: Revenue chart shows typical summer dip and year-end upswing

[i] Tip: Use the revenue chart to recognize trends early. A de-
cline over several months should be reason to intensify your ac-
quisition.

[~] WorkÇow Tip: Screenshot the revenue chart at year-end. This gives
you visual documentation of your business development for accountant or
business plan.

2.8 Dashboard and Tenant Selection
The dashboard responds to tenant selection in the menu bar.

Behavior:

Switch Tenant: - Select another tenant in the menu bar - The dashboard
reloads - All metrics are Æltered by the selected tenant

Only Selected Tenant: - Metrics showONLY data from the selected tenant
- Documents, customers, revenues of the selected tenant - Other tenants
are not considered

Default Tenant: - The default tenant is preselected on startup - You can
set the default tenant in tenant management

Figure 43: The dashboard shows metrics for the currently selected tenant
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Multi-Company Management: - If you manage multiple tenants, switch
regularly - Checkmetrics of each tenant - Keep track of all your companies

[*] Best Practice: If you have multiple tenants, schedule Æxed
times for each tenant (e.g., MondaysCompanyA, TuesdaysCom-
pany B). This avoids confusion.

2.9 Dashboard Refresh
The dashboard updates automatically in the following cases:

Automatic Refresh:

1. On Application Start
• Dashboard loads metrics when opening

2. On Tenant Switch
• Newmetrics are loaded

3. After Creating a Document
• Dashboard updates as soon as you navigate back
• New documents are included in metrics

4. After Recording Payment
• Revenue and outstanding amounts update

5. After Deleting a Document
• Metrics are recalculated

Manual Refresh:

Not Required: - The application keeps the dashboard automatically up-to-
date - There is no manual “Refresh” button - All changes are immediately
reÇected

In Case of Problems: - Ifmetrics don’t appear current, navigate to another
area and back - In rare case of errors: Restart application

[i] Tip: The dashboard is always current. You don’t need to
worry about refreshes.

2.10 Typical DashboardWorkÇows
Morning Routine: Get Overview

1. Start Application
• Dashboard opens automatically

2. Check Metrics
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• Check “Payment overdue” → Send reminders
• Check “Requires attention” → Follow up on open quotes
• Review “Drafts” → Finalize or delete

3. Perform Actions
• Click on cards to see details
• Edit documents, record payments

4. Analyze Revenue Chart
• Recognize trends
• Plan for coming months

[T] Time Required: 5-10 minutes daily

Weekly Financial Review

1. Check Revenue
• Compare “Revenue this year” with targets
• Monitor “Outstanding amounts”

2. Control Payment Receipts
• Reconcile bank statements with open invoices
• Record payments in application

3. Dunning Management
• Check “Payment overdue”
• Send payment reminders
• Create reminders

4. Quote Management
• Review “Requires attention”
• Follow up on open quotes
• Mark quotes as accepted/rejected

[T] Time Required: 15-30 minutes weekly

Month-End Closing

1. Record All Payment Receipts
• Completely reconcile bank statements
• Post payments to invoices

2. Document Metrics
• Screenshot of dashboard
• Revenue chart for archive

3. Clarify Open Items
• Analyze “Outstanding amounts”
• Create collection plan

4. Prepare VAT Advance Return
• Export “Revenue this year”
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• Filter document list by month
• Export all PDFs and audit log

[T] Time Required: 30-60 minutes monthly

Summary
The dashboard is your central hub for all important business metrics:

Metrics at a Glance: - [+] Published this year - [+] Drafts - [+] Requires at-
tention - [+] Payment overdue - [+] Total revenue - [+] Revenue this year -
[+] Outstanding amounts

Features: - [+] Clickable cards with automatic Æltering - [+] Monthly rev-
enue chart - [+] Multi-currency support - [+] Automatic refresh - [+] Tenant
Æltering

BeneÆts: - [+] Quick overview of business activities - [+] Early detection of
problems - [+] EfÆcient navigation to relevant documents - [+] Data-driven
decisions

[*] Best Practice: Start each workday with a look at the dash-
board. This keeps you informed and ensures you don’t miss im-
portant tasks.

Next Steps: In the next chapter, you’ll learn all about document manage-
ment – the heart of AGYNAMIX Invoicer.

3. Sales Documents (Documents)
TheDocuments section is the heart of AGYNAMIX Invoicer. Here youman-
age all your sales documents: quotes, invoices, correction invoices, and
payment reminders. The application guides you through the complete life-
cycle – from draft through publication to payment and archiving.
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Figure 44: The document list shows all sales documents with Ælter options and
status indicators

3.1 Document List and Navigation
The document list is your central workspace for all sales documents.

List Overview

The list shows you for each document:

• Document number: Unique number like RE-2024-001 (invoice) or
ANG-2024-005 (quote)

• Document type: Visual symbol for quote, invoice, correction, or re-
minder

• Status: Color-coded status (e.g., “Draft”, “Published”, “Paid”)
• Customer: Customer name
• Date: Creation or invoice date
• Amount: Invoice total in document currency
• Due date: When payment is due (for invoices) or when a quote ex-
pires
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Figure 45: Each entry shows all important information at a glance

Header

In the header you see:

• Number of documents: Total count and Æltered count when Ælters
are active (e.g., “Documents (12 of 45)”)

• Search Æeld: Search documents by number, customer name, or de-
scription

• Filter icon: Shows a blue badge when Ælters are active
• + Create New: Dropdownmenu to create new quotes or invoices

Figure 46: The header with search Æeld, Ælter indicator, and create button

[i]ProTip: The document list remembers your Ælter settings as long as the
application is open. After a restart, the list starts without Ælters.
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3.2 Filters and Search
With powerful Ælter and search functions, you can quickly Ænd the desired
documents.

Using the Search Field

The search Æeld searches across multiple Æelds simultaneously: - Doc-
ument numbers (e.g., RE-2024-001) - Customer names (company name,
Ærst name, last name) - Document descriptions and internal notes - Line
item descriptions (text of individual services or products)

The search is real-time – as you type, the list updates immediately.

Figure 47: Real-time search Ænds documents by number, customer name, or line
item content

Enhanced Multi-Field Search The search now Ænds documents even
when the search term appears inside a line item description, not just in
the customer name or document number. This makes it easy to answer
questions like “Which invoices included ‘website maintenance’?”.

Examples:

What you type What gets found

RE-2024-001 Document with that number
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What you type What gets found

Acme All documents for customers
containing “Acme”

website maintenance All documents with a line item
containing “website maintenance”

2024-003 Documents whose number contains
that fragment

[i]Tip: Shorter,more speciÆc search termsworkbest. Searching formain-
tenance will Ænd everything containing that word; searching for 2025
website maintenance contract may not match if the words appear
in different Æelds.

Figure XX: Searching for a service description Ænds matching documents instantly

Opening Filters

Click the Ælter icon (funnel icon) in the header. The Ælter panel opens on
the right side.
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Figure 48: The Ælter panel offers numerous Ælter options

Available Filters

Document Types Select one or more document types:

• Quote: Non-binding offer to a customer
• Invoice: Payment request
• Invoice Correction: Cancellation or correction of an invoice
• Payment Reminder: Reminder for overdue invoices
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Figure 49: Filter by one or more document types

[i] Pro Tip: Filters are additive – if you select “Quote” and “Invoice”, both
types are displayed.

Document Status Filter by current status:

• Draft: Document is still being edited
• Published: Document has been Ænalized and is immutable
• Partially Paid: Invoice has been partially paid
• Fully Paid: Invoice completely paid
• Cancelled: Invoice was cancelled (by correction invoice)
• Accepted: Quote was accepted by customer
• Turned Down: Quote was rejected
• Expired: Quote has expired
• Deletable: Document can be deleted after retention period
• Obsolete: Payment reminder is no longer current
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Figure 50: Filter by one or more statuses

Due Payments With this switch, you only show invoices whose due date
has been exceeded and which are not yet fully paid.

Figure 51: Show only overdue invoices

[»] Power Tip: This Ælter is identical to clicking “Overdue” on the dash-
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board – use it for your daily dunning management.

Due Quotes This switch shows only quotes whose expiration date has
been exceeded and which are still awaiting feedback.

Figure 52: Show only expired quotes

Document Range (From/To Date) Filter documents by their document
date (e.g., invoice date or quote date):

1. Click From to select a start date
2. Click To to select an end date
3. The list shows only documents within this time period
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Figure 53: Filter documents by creation period

[i] Pro Tip: You can set only “From” or only “To” – the Æelds are indepen-
dent of each other.

Reset Filters

Click Reset at the bottom of the Ælter panel to remove all Ælters at once.
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Figure 54: Reset all Ælters with one click

Reactivate Filters

If you’ve created a new document, Ælters are automatically temporarily de-
activated so you can see the new document immediately. A yellow banner
appears with the note “Filters were temporarily suspended”. ClickReacti-
vate Ælters to restore the previous Ælters.

Figure 55: Reactivate Ælters after creating a document

3.3 Create Document
Create New Quote or Invoice

1. Click + Create New in the header
2. Select from the dropdownmenu:

• New Invoice: For a payment request
• New Quote: For a non-binding offer

Figure 56: Choose between invoice and
quote

The application opens the creation form in Draft status.
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Figure 57: The creation form for a new document

[i] Pro Tip: You can also duplicate an existing document to use it as a tem-
plate (see section “Duplicate Document”).

3.4 Edit Document (Draft)
In draft mode, you can freely edit all Æelds. Once a document is published,
it becomes immutable (GoBD compliance).

General Information

Tenant (Sender) Select the tenant (your company) that appears as
sender on the document. This also determines: - Logo and company data
on the PDF - Numbering scheme (e.g., RE-2024- for tenant A, RE-2025-
for tenant B) - Bank details for payment information

[Screenshot: Tenant selection] Figure 58: Select the tenant for this document

[!] Important: The tenant cannot be changedafter saving, as thedocument
number uniquely belongs to the tenant.
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Customer (Recipient) Select the customer from the dropdown list. The
application automatically loads: - Address data for the document - Cus-
tomer’s default currency - Payment terms (if stored) - E-invoicing settings
(ZUGFeRD/XRechnung)

Figure 59: Select the customer for the document

If the customer doesn’t exist yet: 1. Click + Create new customer 2. The
customer creation form opens 3. After saving, the new customer is auto-
matically selected

[i] Pro Tip: Linked data (address, currency) are permanently saved in the
document when published – subsequent changes to the customer master
data do not affect already published documents.

Document Number The document number is automatically generated
as soon as you save the document for the Ærst time. The format is based on
the selected tenant’s numbering pattern, e.g.: - Invoices: RE-2024-001,
RE-2024-002, … - Quotes: ANG-2024-001, ANG-2024-002, … - Correction
invoices: RE-2024-001-KORR - Payment reminders: MAH-2024-001-L1
(Level 1), MAH-2024-001-L2 (Level 2), …

[Screenshot: Document number displayed] Figure 60: The document number
is automatically assigned

[!] Important: Document numbers are unique and sequential. You cannot
manually change them to ensure unbroken numbering sequences (GoBD
requirement).

Document Date Set the document date: - Invoices: Invoice date (impor-
tant for payment terms and tax period) - Quotes: Quote date - Correction
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invoices: Correction date - Payment reminders: Reminder date

Figure 61: Select the document date via calendar

[i]Pro Tip: The document date defaults to today but can be freely adjusted.

Due Date / Action Date Depending on document type:

• Invoices: Payment term (due date) – default is 14 days after invoice
date

• Quotes: Expiration date – until when the quote is valid
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• Payment reminders: Payment term for the reminder

Figure 62: Set the due or expiration date

[i] Pro Tip: You can store individual payment terms in customer settings –
these are automatically pre-Ælled.

Delivery Date (required) For invoices and invoice corrections, you
must specify a delivery date. It is printed on the PDF document.

79



Figure 63: Set the delivery date

ServicePeriod Start (optional) If you set a service period startdate, the
document represents a service period. In that case, the delivery date be-
comes the end of the service period.
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Order ID / Contract ID (optional) You can optionally store an order ID
and/or contract ID for internal reference (e.g., to match an ERP/order sys-
tem). These values are stored with the document data.

Line Items

Line items represent the services or products to be billed.

Add Line Item

1. Click Add line item below the line item table
2. A new empty row is inserted

Figure 64: Add a new line item with the + button

Edit Line Item Each line item has the following Æelds:

• Description: Description of service or product (required Æeld)
• Quantity: Number or hours (required Æeld, decimals possible)
• Unit price: Price per unit in document currency (required Æeld)
• VAT%: Value-added tax rate (e.g., 19%, 7%, 0%) (required Æeld)
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Figure 65: Edit the Æelds of a line item

Theapplicationautomatically calculates: -Subtotal=Quantity ×Unit price
-VATamount=Subtotal × (VAT%/100) -Total=Sumof all subtotals +Sum
of all VAT amounts

[i] Pro Tip: Use the Tab key to quickly jump between Æelds and efÆciently
enter multiple line items.

Optional (Alternative) Line Items in Quotes In quotes, you can mark a
line item as optional (alternative). Optional items are shown in the export
(PDF/HTML) with an Optional badge, but they do not contribute to totals.

• Use the layers icon at the end of the line item row to toggle a line item
as optional.

• You canoptionally assign agroupname (e.g., “Premium”) somultiple
optional items belong to the same alternative group.

• When converting a quote to a standard invoice, you select which op-
tional groups should be included. Selected optional items become
normal invoice items.

• When converting to partial or Ænal invoices, optional items are not
carried over.

Add Line Item From Product If you maintain product master data, you
can add pre-Ælled line items:

1. In the line items header, click Add line item from product
2. Search and select a product
3. The new line item is Ælled with the product’s defaults (price, unit, tax

rule, description)

You can still edit all Æelds after adding the product.

[?] Continue reading: Product management and CSV import/export are
described in Chapter 7 (Products).

82



Delete Line Item Click the trash icon to the right of the line item to re-
move it.

[Screenshot: Delete line item] Figure 66: Delete a line item with the trash icon

Text-OnlyLine Items In addition to regular billed line items, you canadd
text-only line items to any document. A text-only item is purely presenta-
tional – it does not contribute to the document total and is not billed.

When to use text-only items: - Section headings within the line item table
(e.g., “Phase1: Design”, “Phase2: Development”) - Separator lines or space
between item groups - A “Thank you for your business!” note embedded
within the line items - Company images or logos to be displayed between
item blocks - Any descriptive text that should appear inline with the line
items

Adding a text-only item:

1. Click the dropdown arrow next to Add line item
2. Select Add text-only item
3. A new row is inserted with a text editor (Markdown supported)

[Screenshot: Add text-only line item] Figure XX: Dropdown showing the text-
only item option

Adding an image to a text-only item:

1. Click the image icon inside the text-only item row
2. Select an image Æle from your computer (JPEG or PNG, max. 2 MB

recommended)
3. The image is embedded in the line item

[Screenshot: Text-only itemwith image] FigureXX: A text-only itemdisplaying
a company graphic

How text-only items appear on the PDF:

• They are printed in the line item table at their position
• They have no quantity, unit price, or tax columns
• They are visually distinct from billed items (no amount columns)
• Images are rendered inline at the position in the table

[!] Note: Text-only items are never included in totals, never subject
to tax, and do not affect the invoice balance. They are purely decora-
tive/structural.

The application validates line items in real-time: - Empty descriptions are
marked redwith “RequiredÆeld” - Invalid numbers aremarkedwith “Must
be a valid number”

[!] Important: You cannot publish the document as long as validation er-
rors exist. Figure 67: Validation errors are displayed directly below the Æeld
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[!] Important: You cannot publish the document as long as validation er-
rors exist.

Text Snippets

Text snippets are reusable text blocks (e.g., introductions, payment notes,
closing formulas) that you canadd to yourdocuments. They supportMark-
down formatting for bold text, lists, and more.

Add Text Snippet

1. Scroll to the Text blocks section below the line items
2. Click Add text block
3. Select a text snippet from the dropdown list
4. Choose the position:

• Before line items: Text appears above the line item table (e.g.,
introduction text)

• After line items: Text appears below the line item table (e.g.,
payment notes, closing formula)

[Screenshot: Add text snippet] Figure 68: Add a text snippet and choose the
position

Remove Text Snippet Click the X icon to the right of the text snippet to
remove it.

[Screenshot: Remove text snippet] Figure 69: Remove a text snippet with the X
icon

[i] Pro Tip: You can add multiple text snippets – they appear in the order
you add them.

[*] WorkÇow Tip: Create standard snippets for common scenarios (e.g.,
“Payment note 14days”, “Project start introduction”) and add themquickly
via dropdown.

TextSnippetsLibraryEmpty If youhaven’t createdany text snippets yet,
the application shows a note:

“Create a text block Ærst to use it here.”

Click Manage text snippets in the sidebar to create new snippets (see
Chapter 7).
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Figure 70: Note when no text snippets exist yet

Description / Notes (optional)

In the Description Æeld, you can store internal notes about the document.
These do not appear on the PDF, but are only visible to you.

Figure 71: Internal notes for the document

[i] Pro Tip: Use this Æeld for project notes, follow-up questions, or context
information.

3.5 Save Document
Save as Draft

ClickSave (or “Savequote” / “Save invoice”) to save thedocument as adraft.
The document: - Receives a document number (if not already present) -
Remains editable - Appears in the document list with status “Draft”

Figure 72: Save the document as draft

[i] Pro Tip: Save regularly to avoid losing your work. The application
doesn’t save automatically.

Go BackWithout Saving

Click the back arrow in the upper left corner to return to the previous
screen. If you have unsaved changes, a dialog appears:

Unsaved Changes
“You have unsaved changes. Do you really want to continue?”

• Discard: Changes will not be saved
• Cancel: Stay in the form

Figure 73: Warning for unsaved
changes
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[!] Important: Unsaved changes are irretrievably lost if you choose “Dis-
card”.

3.6 Document Status and Lifecycle
Each document type goes through a deÆned lifecycle with different sta-
tuses. The statuses determine which actions are possible.

Status Overview

Draft

• Document is fully editable
• Can be deleted
• Can be duplicated (except invoice corrections)
• Next step: Publish

Published

• Document is immutable (GoBD compliance)
• Receives a timestamp published_at
• Can be exported (PDF with optional ZUGFeRD/XRechnung)
• Cannot be deleted (only after 10-year retention period)
• Next steps (depending on document type):

– Invoice: Record payment, create reminder, cancel
– Quote: Mark as accepted/rejected, create invoice

Figure 74: Published document with status badge

Additional Statuses (depending on document type)

• Partially Paid (Invoice): Part of the invoice amount has been paid
• Fully Paid (Invoice): Invoice amount fully paid
• Cancelled (Invoice): Invoice was cancelled by correction invoice
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• Accepted (Quote): Customer accepted quote
• Turned Down (Quote): Customer rejected quote
• Expired (Quote): Quote is past expiration date
• Obsolete (Payment Reminder): Reminder is no longer current (e.g.,
due to payment)

• Deletable (all types): Document can be deleted after 10-year reten-
tion period

Figure75: Overviewofdifferentdocument statuseswith
color coding

Status Transitions

The application always shows you the possible Next Steps based on the
current status.

Figure 76: The action buttons show available next steps

3.7 Publish Document
Publishing a document is the most important step in the lifecycle. After
that, the document becomes immutable.

Prerequisites

Before publishing, the application checks: - [+] Customer selected - [+] At
least one line item present - [+] All Æelds valid (no red validation errors)

Perform Publication

1. Click Publish in the “Next Steps” section
2. A conÆrmation dialog appears:
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Publish quote?
“After publishing the quote, you can no longer change it.”

• Publish: ConÆrm
• Cancel: Abort operation

Figure 77: ConÆrmation dialog when publishing a quote

3. After conÆrmation:
• Status changes to Published
• Timestamp published_at is set
• All Æelds become write-protected (gray background)
• New actions become available (e.g., “Create invoice”, “Record
payment”)
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Figure 78: Published document with write-protected Æelds

[i] Pro Tip: Check all data carefully before publishing – there’s no going
back.

[»] Power Tip: Use the PDF preview (see section “PDF Export”) to check
the document before publishing or exporting.

3.8 Record Payment
For invoices, you can record payment receipts to track payment status.

Add Payment

1. Open the published invoice
2. Click Record payment in the “Next Steps” section
3. A dialog opens:

Figure 79: Dialog for recording a payment

Fields in Payment Dialog

• Payment amount: Amount of payment in document currency
• Payment date: When the payment was received
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• Auto-calculate payment: If enabled, the remaining amount is auto-
matically pre-Ælled

[i] Pro Tip: Enable “Auto-calculate payment” to enter the exact remaining
amount for full payment.

Partial Payments

You can record multiple payments if the customer pays in installments:

1. Record the Ærst partial payment → Status changes to Partially Paid
2. Record additional payments until the amount is reached → Status

changes to Fully Paid

Figure 80: Document with partial payment shows the remaining amount

Theapplication showsyou: -Amountpaid: Sumof all payments -Remain-
ing amount: Outstanding amount (Total - Amount paid)

Overpayment

If the customer pays more than the invoice amount (e.g., for tip or round-
ing), the application accepts this. The status still changes to Fully Paid.
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Figure 81: Overpayment is accepted and marked as fully paid

Undo Payment

If you recorded a payment by mistake (e.g., wrong amount, wrong date, or
a transfer that never actually arrived), you can reverse it.

How to undo a payment:

1. Open the invoice whose payment you want to reverse
2. In the detail panel, Ænd the Payments section – all recorded pay-

ments are listed there
3. Click the undo icon next to the payment you want to reverse
4. ConÆrm the action in the dialog

Figure XX: The undo button next to each recorded payment

When is undoing a payment appropriate?

• A payment was entered with the wrong amount
• A payment was assigned to the wrong invoice
• A customer’s bank transfer was reversed (chargeback)

What happens after undoing?

• If the invoice was Fully Paid, it returns to Published (unpaid)
• If the invoice was Partially Paid and other payments remain, the sta-
tus is recalculated from the remaining payments

• If all payments are removed, the invoice returns to Published (un-
paid)

[!] Note: Undoing a payment removes the payment record but does not
delete the audit log entry. The audit log faithfully records that a payment
was created and subsequently reversed, preserving your complete audit
trail.

3.9 Create Invoice from Quote
Once a quote has been accepted, you can create an invoice directly from it.
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WorkÇow: Quote → Invoice

1. Open the published quote
2. ClickMark as accepted (optional but recommended)
3. Click Create invoice
4. The application creates a new invoice draft with:

• Same line items and text snippets
• Reference to the quote (source document)
• New invoice number
• Today’s invoice date and adjusted payment term

Figure 82: “Create invoice” button on published quote

5. Edit the invoice if needed (e.g., adjust date, add line items)
6. Save and publish the invoice

[i] Pro Tip: The link to the quote remains – you see the quote number in
the “Source” Æeld.

Figure 83: Invoice shows the linked quote in the “Source” Æeld

[*] WorkÇow Tip (5–10 minutes): 1. Create quote and send to customer
(3 minutes) 2. Wait for feedback 3. Mark quote as accepted (10 seconds) 4.
Create invoice (30 seconds) 5. Publish and export invoice (1 minute)

3.10 Create Payment Reminder (Dunning)
If an invoice is overdue, you can create a payment reminder (dunning let-
ter).

Prerequisites

The application shows the Create payment reminder button only when: -
[+] Invoice is published or partially paid - [+] Due date has been exceeded
- [+] No active payment reminder exists
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Create Reminder

1. Open the overdue invoice
2. Click Create payment reminder in the “Next Steps” section
3. The application creates a new reminder draft with:

• Reference to the original invoice (Source Æeld)
• Escalation level (Level 1, Level 2, Level 3, …)
• New date and new payment term
• Line items of the original invoice

Figure 84: “Create payment reminder” button on overdue invoice

4. Edit the reminder if needed (e.g., add text snippets, add dunning fees)
5. Save and publish the reminder

Escalation Levels

The application automatically assigns escalation levels: - Level 1: First
payment reminder (e.g., MAH-2024-001-L1) - Level 2: Second reminder
(e.g., MAH-2024-001-L2) - Level 3: Third reminder (e.g., MAH-2024-001-
L3)

Figure 85: Reminder shows escalation level in badge

[i] Pro Tip: The escalation level automatically appears in the document
number and status badge.

Mark Reminder as Obsolete

If the customer has paid in themeantime or an out-of-court settlement has
been reached, you canmark the reminder as obsolete:

1. Open the published reminder
2. ClickMark as obsolete
3. Status changes to Obsolete

Figure 86: “Mark as obsolete” button on published reminder
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3.11 Invoice Correction Options
If you need to correct or cancel an invoice, the application provides three
options to handle different scenarios whilemaintaining GoBD compliance.

Prerequisites

You can correct an invoice if it is: - [+] Published or partially paid

[!] Important: Fully paid invoices can no longer be corrected or cancelled.

Perform Correction

1. Open the published invoice
2. Click Correct Invoice in the “Next Steps” section
3. A dialog appears with three options:

Figure 87: Dialog for choosing the correction type

Option 1: Full Cancellation (Cancellation Invoice / Stornorechnung)
The application: 1. Creates a new cancellation invoice with negated line
items (negative amounts matching the full original) 2. Automatically pub-
lishes the cancellation invoice 3. Sets the original invoice to Cancelled sta-
tus 4. Links both documents

When to use? - Invoice was issued to the wrong customer - Invoice was
completely incorrect - Full refund is required

Figure 88a: Cancellation invoice with fully negated line items

Option 2: Partial Adjustment (Invoice Correction / Rechnungskorrek-
tur) The application: 1. Creates a new correction invoice as a Draft 2.
Allows you to edit speciÆc line items to adjust partial amounts 3. Youmust
manually publish the correction after editing
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When to use? - Only speciÆc line items need adjustment - Partial refund
is required - You need to customize the correction before sending

[i] Pro Tip: After selecting this option, you canmodify the correction draft
to reÇect only the speciÆc adjustments needed, rather than negating the
entire invoice.

Figure 88b: Correction invoice draft ready for editing

Option 3: Cancel and Replace (Invoice Revision / Rechnungsberich-
tigung) The application: 1. Creates a cancellation invoice with fully
negated line items 2. Automatically publishes the cancellation invoice 3.
Creates a new invoice Draft with the same content as the original 4. The
new draft has a new invoice number and can be edited before publishing

When to use? - Minor errors need correction (wrong address, typo in de-
scription) - You need to issue a corrected version of the same invoice - The
customer should receive a replacement invoice

[i] Pro Tip: This is the recommended option when you need to Æx small
mistakes. The new draft preserves all line items, so you can quickly make
corrections and publish.

Figure 88c: New invoice draft created as replacement

[*] WorkÇow Tip (2–3 minutes): 1. Choose “Cancel and Replace” option
(30 seconds) 2. Export and archive the cancellation invoice (30 seconds)
3. Edit the new draft with corrections (1 minute) 4. Publish and export the
corrected invoice (1 minute)

3.12 Duplicate Document
To save time, you can use an existing document as a template for a new
document.

Note: Invoice correction documents cannot be duplicated.
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Perform Duplication

1. Click the three-dot menu to the right of the document in the docu-
ment list

2. Select Duplicate
3. A conÆrmation dialog appears:

Duplicate invoice?
“A copy of invoice RE-2024-005 will be created as a new draft.
Continue?”

• Duplicate: ConÆrm
• Cancel: Abort operation

Figure 89: ConÆrmation dialog when duplicating an invoice

4. The application creates a new draft with:
• Same line items and text snippets
• New document number
• Today’s date
• Status Draft

Figure 90: The duplicated document is a new draft

[i] Pro Tip: Duplicates are ideal for recurring invoices (e.g., monthly main-
tenance contracts).

[»] Power Tip: Combine duplication with text snippets to create standard
invoices in seconds.

3.13 PDF Export and Preview
The application creates professional PDF documents with optional
ZUGFeRD or XRechnung integration.
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Show PDF Preview

1. Open the document (draft or published)
2. Click Preview in the toolbar
3. The application generates a temporary PDF and displays it in the

browser viewer

Figure 91: “Preview” button in the toolbar

Figure 92: PDF preview in browser viewer

[i] Pro Tip: Use the preview to check the layout and all content before pub-
lishing or exporting the document.

Export PDF

1. Open the published document
2. Click Export in the toolbar
3. A Æle selection dialog opens
4. Choose the storage location and Ælename
5. Click Save

Figure 93: “Export” button in the toolbar

The application: - Generates the PDFwith all data, line items, and text snip-
pets - Optionally embeds ZUGFeRD/XRechnung XML (if enabled for cus-
tomer) - Saves the Æle in the selected directory - Shows a success message
with the Æle path
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Figure 94: Success message after PDF export

ZUGFeRD and XRechnung

If you’ve enabled ZUGFeRD or XRechnung in customer settings, the cor-
responding XML is automatically embedded in the PDF:

• ZUGFeRD: XML data according to ZUGFeRD standard (machine-
readable)

• XRechnung: XML data according to XRechnung standard (for public
contractors)

Figure 95: Customer settings with enabled ZUGFeRD

[i] Pro Tip: ZUGFeRD PDFs can be automatically read by modern account-
ing software – saving your customer time.

Export History

Theapplication logs every exportwith: -Date and time -Filenameandpath
- SHA-256 hash of the Æle (for integrity veriÆcation)

You canview the export history in the audit log (seeChapter 10 “GoBDCom-
pliance”).

Figure 96: Export history with veriÆcation status

[*] WorkÇow Tip: Always export documents immediately after
publishing and save them in your archive directory (e.g., ~/Docu-
ments/Invoices/2024/).
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3.14 Send Document via Email
Invoicer can sendadocumentdirectly via email using your conÆgured tem-
plates and email settings.

Prerequisites

• ConÆgure email sending in Settings (see Chapter 9: Email)
• Maintain customer email addresses (billing/general) in Customers
• The document should be in a state that can be exported (typically
published)

Send an Email

1. Open the document
2. Click Send via email (or the email action in the toolbar)
3. In the dialog, select the recipient:

• Billing email (recommended for invoices)
• General email
• One-off email address (manual input)

4. Review and edit Subject and Body
• Defaults come from your Document Emails templates
• The body supportsMarkdown

5. (Optional) Insert tokens into subject/body using the token list
6. Use Preview to validate the Ænal email
7. Click Send

[!] Important: If the dialog shows warnings about unknown tokens, Æx
them before sending to avoid placeholders being sent to the customer.

Copy to Sent Folder (IMAP)

If you enabled “copy to sent” via IMAP and the copy fails, the dialog pro-
vides a retry Çow. You may be asked to conÆrm or adjust the Sent folder
name and retry the copy.

3.15 Delete Document
Delete Drafts

Drafts can be deleted at any time:

1. Click the three-dotmenu to the right of the draft in the document list
2. Select Delete
3. A conÆrmation dialog appears:
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Delete draft?
“Do you really want to delete the draft”RE-2024-007”? This ac-
tion cannot be undone.”

• Delete: ConÆrm (red button)
• Cancel: Abort operation

Figure 97: ConÆrmation dialog when deleting a draft

[!] Important: If the draft originated from another document (e.g., correc-
tion invoice), the parent document is reset to its previous state (see warn-
ing in dialog).

Delete Published Documents

Published documents cannot be deleted to ensure GoBD compliance.
They must be retained for 10 years.

After the retention period expires (10 years after full payment or cancella-
tion), the status changes toDeletable. Then the actionsMark as deletable
and Delete appear.

Figure 98: Document with status “Deletable” can be deleted

[i] Pro Tip: The application automatically calculates the retention period –
you don’t need to track anything manually.

3.16 Show Audit Log
Each document has a complete audit log that records all changes and sta-
tus transitions.

Open Audit Log

1. Open the document
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2. Click Show audit log in the “Next Steps” section or in the toolbar
3. A dialog opens with the complete history

Figure 99: “Show audit log” button in the toolbar

Figure 100: Audit log shows all changes with timestamp

What is Logged?

• Creation: When the document was created
• Status changes: All transitions (e.g., Draft → Published, Published →
Fully Paid)

• Payments: Every recorded payment with amount and date
• Exports: When the document was exported as PDF (with Ælename
and hash)

• Changes: Changes to line items, text snippets, or customer data (only
in draft)

[i]Pro Tip: The audit log is part of GoBD compliance and cannot bemanip-
ulated.

3.17 Practical WorkÇows
WorkÇow 1: Quote Process – From Quote to Invoice (5–10minutes)

Goal: Create a quote, get customer approval, and create the Ænal invoice.

Steps: 1. Create quote (3 minutes) - Click + Create New → New Quote -
Select tenant andcustomer -Add line items -Add text snippets (e.g., “Quote
valid until …”) - Save as draft - Check PDF preview

2. Publish quote (30 seconds)
• Click Publish
• ConÆrm the dialog
• Export PDF and send to customer via email

3. Wait for feedback (external waiting time)
• Customer reviews quote
• Customer accepts

4. Mark quote as accepted (10 seconds)
• Open the quote
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• ClickMark as accepted
5. Create invoice from quote (1 minute)

• Click Create invoice
• Check line items and date
• Save as draft

6. Publish and export invoice (1 minute)
• Click Publish
• Click Export
• Save PDF in archive directory
• Send PDF to customer via email

Result: Customer receives binding invoice based on their accepted quote.
All steps are audit-proof logged.

[i]ProTip: Use text snippets for standard phrases like “Thank you for your
trust” or “Payable within 14 days”.

WorkÇow 2: Dunning Management – Process Overdue Invoices (5–10
minutes daily)

Goal: Identify and process overdue invoices.

Steps: 1. Open dashboard (10 seconds) - Click Dashboard in the sidebar
- Check the Overdue card

2. Filter overdue invoices (10 seconds)
• Click on the number in the Overdue card
• Youautomatically land in thedocument listwith “Duepayments”
Ælter

3. Check each invoice (1–2 minutes per invoice)
• Open the invoice
• Check if payment was received (banking app, bank statement)
• If paid: Click Record payment, enter amount and date
• If not paid: Check how long overdue (due date)

4. Create payment reminder (if necessary, 2 minutes per reminder)
• Click Create payment reminder
• Optionally add text snippets (e.g., “Friendly payment reminder”)
• Save and publish
• Export PDF and send via email

5. Escalation for repeated reminders (optional)
• At Level 2 or Level 3: Add stricter text snippets
• Increase dunning fees as additional line item if necessary

Result: All overdue invoices are processed, payment receipts recorded, re-
minders sent.
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[»]PowerTip: Perform thisworkÇowdaily orweekly tominimize payment
defaults.

WorkÇow 3: Month-End Closing – Export All Invoices (15–30 minutes
monthly)

Goal: Export all invoices of the current month for accounting and archiv-
ing.

Steps: 1. Filter document list (30 seconds) - ClickDocuments in the side-
bar - Open the Ælter panel - SelectDocument type: Invoice - SetDocument
range: From 1st of the month to last day of the month - Click Apply Ælters

2. Export all invoices (10–15minutes)
• Open each invoice individually
• Click Export
• Save PDF in archive directory (e.g., ~/Docu-
ments/Invoices/2024/November/)

• Use consistent Ælenames (e.g., RE-2024-
123_CustomerName.pdf)

3. Check export history (5 minutes)
• Open the audit log of an invoice
• Check that all exports are logged
• Optional: Perform Æle integrity check (see Chapter 10 “GoBD
Compliance”)

4. Create backup (5 minutes)
• Go to Settings→ Backup
• Click Create backup now
• Save the backup Æle on external drive or cloud

Result: All invoices of the month are exported, archived, and backed up.
Ready for accounting and tax advisor.

[*]WorkÇow Tip: Create a monthly archive directory (e.g., 2024/Novem-
ber/) to store invoices in a structured way.

3.18 Pro Tips for EfÆcient Work
[»] Use keyboard shortcuts: - Tab: Jump between Æelds - Enter: Save (in
many dialogs) - Esc: Close dialog

[i] Duplicates for recurring invoices: If you send monthly maintenance
invoices, duplicate the last invoice and only adjust the date.
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[*] Text snippets for common scenarios: Create snippets for: - Payment
notes (e.g., “Payable within 14 days”) - Project start (e.g., “Thank you for
the order. We start on …”) - Reminders (e.g., “Friendly payment reminder
– please transfer by …”)

[!] Check Ælters regularly: If you don’t see a new document in the list,
check if a Ælter is active (blue badge on Ælter icon).

[~]Regular backups: Create weekly ormonthly backups to avoid data loss
(see Chapter 9 “Settings”).

[i] PDF preview before sending: Always check the PDF preview before
sending the document to the customer. Verify: - Customer data correct
- Line items and amounts correct - Text snippets appropriate - Payment
terms correct

3.19 Related Documents Panel
Whendocuments are linked to eachother – for example, an invoicederived
from a quote, or a correction invoice created from an original invoice – AG-
YNAMIX Invoicer visualizes these connections in the Related Documents
panel.

Where the Panel Appears

The Related Documents panel is shown in the right-hand detail area when-
ever you open a document that is part of a document chain. Look for the
Related Documents section below the document details.

Figure XX: The Related Documents panel showing a linked quote, invoice, and
correction

What Links Are Shown

The panel displays the entire document chain, including:
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Relationship Example

Source document The quote that this invoice
was created from

Derived documents Invoices or reminders that
were created from this
document

Corrections Correction invoices that
cancel or partially correct
this invoice

Each linked document shows its: - Document number - Document type
(quote, invoice, correction, reminder) - Current status (Draft, Published,
Paid, etc.) - Date

Navigate Between Linked Documents

Click any entry in the Related Documents panel to navigate directly to that
document. This makes it easy to trace the full history of a business trans-
action:

• Start with a quote → see the invoice it turned into
• Open an invoice → see if a payment reminder was sent
• Open a corrected invoice → see the original it corrects

[i] Pro Tip: The Related Documents panel is especially useful during cus-
tomer disputes or audits – you can trace the complete document trail in a
few clicks without using the search Æeld.

3.20 Payment Overview
In addition to the per-invoice payment tracking described in section 3.8,
AGYNAMIX Invoicer provides a dedicated Payment Overview screen that
gives you a bird’s-eye view of all payment transactions across all your in-
voices at once.

How to Open the Payment Overview

Click Payments in the left sidebar.

Figure XX: The Payment Overview screen shows all payment transactions across
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all documents

What the Payment Overview Shows

The overview lists all payment entries with the following columns:

Column Description

Document Invoice number and document type
Customer Customer name
Amount Payment amount (or total invoice amount)
Due Date When the invoice is / was due
Status Payment status (Overdue, Due Soon, Paid, etc.)

Available Filters

Use the status Ælters at the top of the screen to focus onwhatmattersmost:

Filter Shows

All Every invoice with a payment status
Overdue Invoices past their due date that are not yet paid
Due Soon Invoices due within the next few days
Paid Invoices that have been fully paid

Figure XX: The Ælter tabs narrow the list to the most important items

Visual Payment Badges

Payment status badges (colored indicators) are also shown directly on doc-
ument list entries and the dashboard summarywidgets. These give you an
at-a-glance warning for overdue items without navigating to the Payment
Overview.

Using the Payment Overview to Manage Receivables

The Payment Overview is designed for a quick daily or weekly check of
open receivables:
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1. Open the Payment Overview
2. Switch to the Overdue Ælter
3. Review which invoices are past due
4. Click any entry to open the invoice and take action (record a payment,

send a reminder)

[i]ProTip: Start yourworkdaywith a quick glance at theOverdue andDue
Soon Ælters – this prevents invoices from slipping through the cracks.

Continue with Chapter 4: Time Tracking

4. Time Tracking (Timesheets)
Time Tracking (Timesheets) is the perfect tool for project-based billing
according to actual hours worked. Record your working hours continu-
ously, organize them into billing periods, and create professional invoices
from them with one click. Ideal for freelancers, consultants, and service
providers who bill by the hour.

Figure 101: The timesheet list shows all active and archived time tracking records

4.1 Timesheet Concept
A timesheet is a container for time entries for a speciÆc customer and
project. It deÆnes:

• Customer: For whom the work is performed
• Reporting period: Weekly, bi-weekly, monthly, or custom
• Default hourly rate: Your billing rate (can be overridden per entry)
• Billingperiods: Automatically calculated timeperiods that are billed
as invoices
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WorkÇow: From Time Tracking to Invoice

1. Create timesheet: DeÆne customer, reporting period, and hourly
rate

2. Record time entries: Enter your hours worked daily or weekly
3. Finalize period: Create an invoice from the current time period
4. Edit invoice: Adjust the invoice if needed (e.g., add text snippets)
5. Publish invoice: Finalize the invoice and export it as PDF

Figure 102: The complete workÇow from time tracking to invoice

[i]ProTip: A timesheet can be used overmonths – you simply create a new
invoice for each reporting period (e.g., each week).

4.2 Timesheet List
The timesheet list is your central workspace for all time tracking records.

List Overview

The list shows for each timesheet:

• Title: Descriptive name (e.g., “Project Alpha - January 2025”)
• Customer: Customer name
• Status: Active or Inactive
• Reporting period: Weekly, bi-weekly, monthly, or custom
• Time period: Start date (and optional end date)
• Hourly rate: Default billing rate
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Figure 103: Each entry shows all important information at a glance

Status Display

• Active: Timesheet is open for new entries (green badge)
• Inactive: Timesheet is archived and read-only (gray badge)

Figure 104: Active and inactive timesheets with color coding

[i]ProTip: A customer can only have one active timesheet at a time. If you
create a new timesheet for the same customer, the old one automatically
becomes inactive.

4.3 Filters and Search
Using the Search Field

The search Æeld searches: - Timesheet title - Description - Customer name

The search is real-time – as you type, the list updates immediately.

Figure 105: Real-time search Ænds timesheets by title or customer
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Filter by Customer

Click the “All Customers” dropdownmenu to show only timesheets for a
speciÆc customer.

Figure 106: Filter timesheets by customer

Filter by Status

Choose between: - Active: Show only active timesheets - Inactive: Show
only archived timesheets - All: Show all timesheets (default)

Figure 107: Filter by active or inactive status

4.4 Create Timesheet
Create New Timesheet

1. Click + Create new timesheet in the header
2. The creation form opens

Figure 108: Button to create a new
timesheet
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Form Fields

Basic Information Title (required Æeld) - Descriptive name for the
timesheet - Examples: “Project Alpha - Q1 2025”, “Consulting Customer
XY”, “January 2025 - Development”

Figure 109: Give the timesheet a meaningful title

Description (optional) - Additional notes or context information - Only vis-
ible to you, does not appear on invoices
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Figure 110: Optionally add a description

Customer & Time Period Tenant (required Æeld, read-only) - Your cur-
rently selected tenant (company) - Automatically pre-Ælled
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Figure 111: The tenant is pre-selected

Customer (required Æeld) - Select the customer from the dropdown list - If
the customer doesn’t exist yet, click + Create new customer
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Figure 112: Select the customer for this timesheet

[!] Important: If the customer already has an active timesheet, a warning
appears. You canproceed, but the old timesheetwill automatically become
inactive and all non-Ænalized entries will be moved to the new timesheet.

Figure 113: Warning when an active timesheet exists for this customer

Period Start (required Æeld) - Start date of the timesheet - Default: Today -
Determines the start of the Ærst billing period
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Figure 114: Select the start date via calendar

Period End (optional) - End date of the timesheet (only for time-limited
projects) - If empty: Timesheet runs indeÆnitely

Figure 115: Optionally set an end date

[i] Pro Tip: Leave the end date empty for ongoing projects – you can man-
ually archive the timesheet at any time.

Billing Information Reporting Period (required Æeld)

Choose how often you want to bill:

• Weekly: Billing periods fromMonday to Sunday (7 days)
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• Bi-weekly: Billing periods of 14 days (2 weeks)
• Monthly: Billing periods from beginning to end of month
• Custom: Flexible periods – you decide when the period ends when
Ænalizing

Figure 116: Select the billing rhythm

[i] Pro Tip: - Weekly is ideal for short-term projects with regular billing -
Monthly is typical formaintenance contracts or retainermodels - Custom
is perfect for irregular or project-based billing

[!] Important: The reporting period cannot be changed after creation once
a period has been Ænalized. In this case, create a new timesheet.

Default Hourly Rate (required Æeld)

• Your billing rate per hour in the tenant currency (e.g., EUR)
• Used as default for all time entries
• Can be overridden individually per entry
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Figure 117: Set your default hourly rate

[i] Pro Tip: Enter your standard hourly rate – for overtime or special activ-
ities, you can later set a different rate for individual entries.

Save Timesheet

Click Create timesheet to save the timesheet. The application: - Saves the
timesheet with status Active - Deactivates any existing active timesheet
for the same customer if necessary - Opens the detail view where you can
record time entries

Figure 118: Save the timesheet with the create button

4.5 Edit Timesheet
Open Timesheet

Click on a timesheet in the list to open the detail view.
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Figure 119: Click on a timesheet to open it

Detail View Overview

The detail view shows:

1. Header areawith title, customer, and status
2. Edit button (pencil icon) to change title, description, and hourly rate
3. Current periodwith all open time entries
4. Past periodswith Ænalized (billed) time periods

Figure 120: The detail view of an active timesheet

Edit Basic Data

1. Click the pencil icon in the header area
2. The edit form opens
3. You can change:

• Title
• Description
• Default hourly rate

[!] Important: Customer and reporting period cannot be changed once Æ-
nalized periods exist.
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Figure 121: Edit title, description, and hourly rate

[i] Pro Tip: Changes to the hourly rate only affect new entries – existing
entries keep their previous rate.

4.6 Record Time Entries
Time entries are the individual work hours you perform for a customer.

Add New Time Entry

1. Scroll to Current Period
2. Click + Add entry
3. The input form opens

Figure 122: Button to add a new
time entry
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Input Form

Work Date (required Æeld) - Select the date when the work was performed
- Must be within the current period

Figure 123: Select the work date via calendar

[!] Important: If you select a date outside the current period, an errormes-
sage appears. Finalized periods can no longer be edited.

Start Time (optional) - Beginning time of work (e.g., 09:00) - Can be left
empty if only duration is important
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Figure 124: Optionally enter a start time

End Time (optional) - End time of work (e.g., 17:00) - If start and end time
are provided, the application automatically calculates the duration
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Figure 125: Optionally enter an end time

Duration (Hours) (required Æeld) - Number of hours worked - Decimal
numbers possible (e.g., 2.5 for 2.5 hours) - Automatically calculated if start
and end time are provided
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Figure 126: Enter duration in hours or have it calculated

[i] Pro Tip: Use start and end time to have duration calculated automati-
cally – saves time and avoids calculation errors.

Description (required Æeld) - What did you do? - This description will ap-
pear on the invoice later
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Figure 127: Describe the work performed

[i] Pro Tip: Write customer-friendly descriptions like “Development of lo-
gin feature” instead of “Programming” – this makes invoice review easier
for the customer.

Task Category (optional) - Select a category from the dropdown list (e.g.,
“Development”, “Consulting”, “Support”) - Categories can be managed in
settings (currently not implemented)

Figure 128: Optionally select a task category

Billable - Checkbox: Should this entry appear on the invoice? - Default:
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Enabled - Disable this option for internal work that should not be billed
(e.g., administrative tasks)

Figure 129: Mark whether this entry should be billed

[i] Pro Tip: Use non-billable entries for internal administrative work or to
track all working hours, even if not everything is billed.

Hourly Rate Override (optional) - Override the default hourly rate for this
speciÆc entry - Useful for overtime, special activities, or discounts
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Figure 130: Optionally set a different hourly rate

[i] Pro Tip: Use a higher hourly rate for emergency support or weekend
work.

Save Entry

Click Add entry to save the entry. The entry appears in the current period
list.
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Figure 131: Save the entry with the add button

4.7 Manage Time Entries
Display Entries

The detail view shows all entries of the current period in a list with:

• Date: Work date
• Description: What was done
• Duration: Number of hours
• Amount: Calculated from duration × hourly rate
• Billable status: Badge “Billable” or “Not billable”

Figure 132: List of all time entries in the current period
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Edit Entry

1. Click the pencil icon to the right of the entry
2. The edit form opens with all pre-Ælled values
3. Change the desired Æelds
4. Click Save changes

Figure 133: Edit an existing time entry

[!] Important: Finalized entries (from billed periods) can no longer be
edited.

Delete Entry

1. Click the trash icon to the right of the entry
2. A conÆrmation dialog appears
3. ConÆrm with Delete

Figure 134: ConÆrmation dialog when deleting an entry

[!] Important: Deleted entries cannot be recovered.

4.8 Periods Overview
The detail view shows two areas:

1. Current Period: All open time entries that have not yet been billed
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2. Past Periods: Finalized (billed) time periods

Current Period

The current period shows:

• Time period: Start and end date (automatically calculated based on
reporting period)

• Number of entries: Howmany time entries are recorded
• Total hours: Sum of all hours
• Billable hours: Sum of billable hours
• Total amount: Calculated from billable hours × hourly rate

Figure 135: The current period with summary

[i] Pro Tip: The period ends automatically based on your reporting period
(e.g., every Sunday for weekly billing).

Past Periods

Past periods are automatically displayed once you’ve Ænalized a period
(by creating an invoice). They show the same information as the current
period but are read-only.

Figure 136: List of Ænalized periods with green border

Each Ænalized period shows:

• Invoice status: “Billed” (green badge) or “Draft invoice” (blue badge)
• Show invoice button: Opens the linked invoice
• Delete period button: Only visible if the invoice is still a draft (see
section “Delete Period”)

Figure 137: Finalized period shows the linked invoice
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4.9 Create Invoice from Period
The heart of time tracking: Create an invoice from your recorded hours
with one click.

Prerequisites

You can create an invoice from the current period if: - [+] At least one bill-
able entry exists - [+] The period contains hours with amount > 0

Create Invoice

1. Click Create invoice (receipt icon) in the header area of the current
period

2. A conÆrmation dialog opens

Figure 138: “Create invoice” button for the current period

ConÆrmation Dialog

The dialog shows:

• Title: “Create invoice from period”
• Time period: Start and end date of the period
• Note: Explanation that the period will be Ænalized and a draft invoice
created

• Warning (only for custom reporting period): You can adjust the end
date
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Figure 139: Dialog to conÆrm invoice creation

Adjust EndDate (only for custom reporting period) If your timesheet is
set to Custom, you can adjust the end date in the dialog:

• Default: Date of the last time entry
• You can choose an earlier or later date
• Only entries up to this date will be included in the invoice
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Figure 140: Adjusting end date for custom reporting period

[i] Pro Tip: For monthly, weekly, or bi-weekly billing, the end date is read-
only and automatically calculated.

3. Click Create invoice to conÆrm

What Happens in the Background?

The application automatically performs the following steps:

1. Finalize period: The current period is closed and marked as “past
period”

2. Create invoice: A new invoice with status Draft is created with:
• One entry per time entry
• Description: Date + description of entry (e.g., “01.03.2025: De-
velopment of login feature”)

• Quantity: Number of hours (e.g., 2.5)
• Unit price: Hourly rate of entry
• VAT: Customer’s default VAT rate

3. Link entries: All time entries are linked to the invoice (Ænalized)
4. Start new period: A new current period is automatically created

(start date = day after end date of Ænalized period)
5. Navigation: You are automatically redirected to the newly created in-

voice
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Figure 141: The created invoice with all time entries as line items

[i]ProTip: The invoice is initially adraft – you can still edit it (e.g., add text
snippets, adjust line items) before publishing.

4.10 Edit and Publish Invoice
Edit Invoice

After creation, you can edit the invoice like any other invoice:

• Line items: Adjust descriptions, add line items, or remove some
• Text snippets: Add introductions or closing formulas
• Date: Change invoice date or payment term
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Figure 142: Edit the invoice created from time entries

[i] Pro Tip: Add a text snippet like “Hourly billing according to time track-
ing” to increase transparency for the customer.

Publish Invoice

When the invoice is ready:

1. Click Publish in the “Next Steps” section
2. ConÆrm the dialog
3. The invoice becomes immutable (Status: Published)
4. The Ænalized period in time tracking is marked green (Status:

“Billed”)

Figure 143: Published invoice marks period as “Billed”

Return to Time Tracking

Click Back or navigate via the sidebar to Timesheets to return to time
tracking. You now see:
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• The Ænalized period in the “Past Periods” area with green border
• Show invoice button to open the linked invoice
• A new current period for the next time entries

Figure 144: Time tracking shows the Ænalized period and a new current period

4.11 Delete Period (Drafts Only)
If youaccidentallyÆnalizedaperiodordon’twant to create the invoiceafter
all, you can delete the period – but only as long as the invoice is still a draft.

Prerequisites

You can delete a period if: - [+] The linked invoice is still inDraft status - ❌
Published invoices cannot be deleted (GoBD compliance)

Delete Period

1. Open the time tracking detail view
2. Scroll to past periods
3. Click Delete period (trash icon) for the desired period
4. A conÆrmation dialog appears:
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Delete period and invoice?
“This will delete the draft invoice and unlink all time entries
from this period. This action cannot be undone.”

• Delete: ConÆrm (red button)
• Cancel: Abort operation

Figure 145: ConÆrmation dialog when deleting a period

5. ConÆrm with Delete

What HappensWhen Deleting?

• The linked draft invoice is deleted
• All time entries of this period are unÆnalized andmoved back to the
current period

• The period itself is removed

Figure 146: Entries are back in the current period after deletion

[i] Pro Tip: Use this function to undo accidentally created invoices – but
only as long as they’re still drafts.

4.12 Archive Timesheet (Set Inactive)
When a project is completed or you want to create a new timesheet for the
same customer, you can archive the old timesheet.

Manually Set Inactive

(Currently not implemented – timesheets automatically become inactive
when a new timesheet is created for the same customer)
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Automatically Inactive Through New Timesheet

When you create a new timesheet for a customerwho already has an active
timesheet:

1. Warning appears: “Active timesheet exists”
2. If you proceed:

• The old timesheet becomes inactive
• All non-Ænalized entries are moved to the new timesheet
• Finalized periods remain with the old timesheet

Figure 147: Old timesheet becomes inactive when a new one is created

Display Inactive Timesheets

Inactive timesheets appear with a gray badge in the list. They are read-
only and show only Ænalized periods.

Figure 148: Inactive timesheet with gray badge

[i] Pro Tip: Inactive timesheets serve as an archive – you can always go
back and view old invoices.

4.13 Practical WorkÇows
WorkÇow 1: Complete WorkÇow – Time Tracking to Invoice (15–30
minutes initial, then 5–10minutes weekly)

Goal: Create a timesheet, record time entries over several weeks, and cre-
ate monthly invoices from them.

Steps:

Initial Setup (15–30minutes, one-time)

1. Create timesheet (5 minutes)
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• Click + Create new timesheet
• Title: “Consulting Customer XY - 2025”
• Customer: Select Customer XY
• Reporting period: Weekly (for regular billing)
• Start date: Monday of current week
• Default hourly rate: 120 EUR
• Click Create timesheet

2. Record Ærst time entry (2 minutes)
• Click + Add entry
• Work date: Today
• Start time: 09:00
• End time: 12:00
• Description: “Kick-off meeting and project planning”
• Billable: Enabled
• Click Add entry

Weekly Routine (5–10minutes per week)

3. Record time entries (daily 1–2 minutes)
• Open the timesheet
• Add all time entries daily or at the end of the week
• Use concise, customer-friendly descriptions

4. Create weekly invoice (Friday or Monday, 3 minutes)
• Open the timesheet
• Check summary of current period (hours and amount)
• Click Create invoice
• ConÆrm the dialog
• The invoice opens automatically

5. Finalize invoice (2 minutes)
• Check all line items
• Optionally add text snippets (e.g., “Weekly hourly billing”)
• Click Publish
• ConÆrm the dialog

6. Export and send invoice (2 minutes)
• Click Export
• Save PDF in archive directory
• Send via email to customer

Monthly Closing (optional)

7. Check all invoices of the month (10 minutes)
• Go to Documents
• Filter for invoices of the current month
• Check if all payments have been received
• Record payments (see Chapter 3 “Documents”)
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Result: You have an ongoing timesheet withweekly invoices automatically
generated from your time entries. All hours are cleanly documented and
billed.

[i] Pro Tip: Set up a weekly appointment in your calendar (e.g., Friday 4
PM) for “Complete time tracking and create invoice” – so you won’t forget.

WorkÇow 2: Project-Based Billing with Custom Period (10–15 minutes
at completion)

Goal: Record time entries for a project over several weeks or months and
bill at project end or after milestones.

Steps:

1. Create timesheet with custom period (3 minutes)
• Title: “Project Alpha - MVP Development”
• Customer: Select customer
• Reporting period: Custom
• Start date: Project start
• End date: Leave empty (open-ended)
• Default hourly rate: 150 EUR

2. Record time entries continuously (daily/weekly)
• Record all hours worked
• Use meaningful descriptions like “Feature X developed”, “Bug Y
Æxed”

3. Intermediate billing at milestone (5 minutes)
• Click Create invoice
• In dialog: Adjust end date to milestone (e.g., end of Sprint 1)
• ConÆrm
• Only entries up to this date are billed

4. Finalize and send invoice (5 minutes)
• Add text snippet: “Billing Milestone 1 – MVP Sprint 1”
• Publish and export invoice

5. Continue next phase (0 minutes)
• The new current period automatically starts the day after the
milestone end date

• Continue recording time entries for the next milestones

Result: Flexible billing according to project progress or milestones, with-
out rigid weekly or monthly rhythms.

[*] WorkÇow Tip: Use custom periods for projects with irregular billing
(e.g., agency projects with partial payments after deliverables).
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WorkÇow 3: Track Partially Non-Billable Hours (5 minutes daily)

Goal: Recordallworkinghours, including internal activities, to have a com-
plete overview – but only bill billable hours.

Steps:

1. Create timesheet (as usual)
• Reporting period: Monthly (for monthly billing)

2. Record billable entries (daily)
• Work for customer: Billable enabled
• Example: “Consultation meeting with stakeholders” – 2 hours –
Billable

3. Record non-billable entries (daily)
• Internal activities: Billable disabled
• Example: “Internalmeeting for project planning” – 1 hour – Not
billable

4. Create monthly invoice (end of month, 5 minutes)
• Click Create invoice
• Only billable entries appear on the invoice
• Non-billable entries are documented but not billed

5. Check overall overview (optional)
• Open the period
• Summary shows:

– Total hours: All hours (billable + non-billable)
– Billable hours: Only billed hours
– Total amount: Only from billable hours

Result: Youhave a complete overviewof all hoursworkedbut only bill actu-
ally billable work. Ideal for projects with mixed activities (e.g., consulting
+ internal administration).

[i] Pro Tip: Use task categories (if implemented) to group billable and non-
billable activities for better analysis.

4.14 Pro Tips for EfÆcient Time Tracking
[»] Record times daily: Don’t wait until the weekend – record your hours
daily while they’re still fresh in yourmemory. This only takes 1–2minutes
per day.

[i]Use start and end time: Enter start and end time to have duration calcu-
lated automatically – this avoids calculation errors and is faster thanman-
ual calculation.

[*] Customer-friendly descriptions: Write descriptions so the customer
understands what you did. “Development of login feature” is better than
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“Programming”.

[!] Track non-billable hours: Also record internal activities as non-
billable entries to have a complete overview of your working time.

[~] Establish weekly or monthly routine: Set up a Æxed appointment in
your calendar (e.g., “Friday 4 PM: Create invoice”) – so you won’t forget
billing.

[i]Hourly rate override for special activities: Use a higher hourly rate for
emergency support, weekend work, or overtime – this keeps billing trans-
parent and fair.

[*]Customperiods for projects: If you bill project-based, use customperi-
ods and adjust the end date at milestones – so you can bill Çexibly accord-
ing to progress.

[»] Check summaries before invoice creation: Before creating an in-
voice, check the current period summary (total hours, billable hours, total
amount) – this avoids errors.

[i] Text snippets for standard phrases: Create text snippets like “Weekly
hourly billing according to time tracking” and add them automatically to
each invoice – saves time and creates consistency.

Continue with Chapter 5: Tenant Management

5. Tenant Management
Tenant Management allows you to manage multiple companies or busi-
ness units in one application. Each tenant has its own company data, bank
details, numbering schemes, and an optional logo. Ideal for self-employed
individuals with multiple companies, tax advisors, or agencies billing for
different businesses.

Figure 149: The tenant list shows all your companies
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5.1 Tenant Concept
A tenant represents a company or business unit. Each tenant:

• Has own company data: Name, address, contact details
• Has own bank details: IBAN, BIC, bank name
• Has own numbering schemes: Separate counters for invoices,
quotes, and reminders

• Can have its own logo for PDF documents
• Is completely independent from other tenants

WhyMultiple Tenants?

Scenarios for Multi-Company Management:

1. Self-employed with multiple companies: Bill separately for sole
proprietorship + GmbH

2. Tax advisor: Create invoices for different clients
3. Agency with brands: Different brands with their own company data
4. Freelancer with side project: Keep main activity + side activity sep-

arate

Figure 150: Each tenant has its own data and numbering schemes

[i] Pro Tip: Even if you only have one company, you must create at least
one tenant – it will automatically be set as the default tenant.
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5.2 Tenant List
The tenant list shows all your companies at a glance.

List Overview

Each entry shows:

• Company name: Name of the business
• Address: Street, postal code, and city in one line
• Contact details: Phone number (if available)
• Invoice format: Current numbering pattern and next invoice num-
ber

• Default badge: Yellow star for default tenant

Figure 151: Each entry shows company data and invoice format

Default Tenant

The default tenant is automatically pre-selected when you: - Create a new
document (invoice, quote) - Create a new timesheet - Start the application

The default tenant is marked with a yellow star [*].

Figure 152: The default tenant ismarkedwith a yellow star

[i] Pro Tip: Set the company you work with most frequently as the default
tenant – this saves time.

5.3 Create Tenant
Create New Tenant

1. Click + Create new tenant in the header
2. The creation form opens

Figure 153: Button to cre-
ate a new tenant
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The form is divided into several sections: - Company information - Contact
information - Bank information - Invoice settings - Quote and reminder
settings - Logo

5.4 Company Information
Company Name (required Æeld)

The name of your company as it should appear on invoices.

Examples: - Sole proprietorship: “John Doe – IT Consulting” - GmbH:
“TechVision GmbH” - Freelancer: “Dr. Jane Smith – Legal Consulting”

Figure 154: Enter the company name

[i]Pro Tip: Use the ofÆcial company name as registered in the commercial
register or on your business license.

Owner (optional)

Name of the owner or managing director (appears on invoices).

Examples: - “John Doe” - “Dr. Michael Johnson” - “Jane Smith, Managing
Director”

Figure 155: Optionally enter the owner

Address (required Æelds)

Street (required Æeld) - Street and house number - Example: “Main Street
123”
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Figure 156: Enter street and house number

Address Supplement (optional) - Additional address information - Exam-
ples: “4th Floor”, “Rear Building”, “c/o Schmidt”

Figure 157: Optionally enter an address supplement

Postal Code (required Æeld) - Postal code - Example: “10117”

Figure 158: Enter the postal code

City (required Æeld) - City name - Example: “Berlin”

Figure 159: Enter the city

State / Region (optional) - State or region (especially relevant for USA,
Canada) - Examples: “Berlin”, “Bavaria”, “California”

Figure 160: Optionally enter the state
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Country (required Æeld) - Country as text - Examples: “Germany”, “Aus-
tria”, “Switzerland”, “United States”

Figure 161: Enter the country

[i] Pro Tip: Use consistent spellings – either always in German (“Deutsch-
land”) or always in English (“Germany”) – this looks more professional on
invoices.

Tax Information

TaxNumber (requiredÆeld) - Your taxnumber fromthe taxofÆce -Format:
Depends on the state (e.g., “27/123/45678” for Berlin)

Figure 162: Enter your tax number

VAT ID (required Æeld) - Value Added Tax IdentiÆcation Number (for busi-
nesses) - Format: DE + 9 digits (e.g., “DE123456789”)

Figure 163: Enter your VAT ID

[!] Important: Both Æelds are required because they are legally mandated
on German invoices. If you don’t have a VAT ID yet, apply for it at the Fed-
eral Central Tax OfÆce.

[i] Pro Tip: The VAT ID is mandatory for intra-community business (EU).

Commercial Register (optional)

If your company is registered (e.g., GmbH), you can store register informa-
tion for use in documents.
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Typical Æelds: - Commercial register court - Commercial register number

Responsible Persons (optional)

Depending on your legal form youmaywant to store: - Managing directors
- Supervisory board chairman

5.5 Contact Information
General Email (required Æeld)

Your general business email address (appears on invoices).

Examples: - “info@techvision-gmbh.com” - “contact@johndoe.com” -
“jane.smith@legal-consulting.com”

Figure 164: Enter your business email address

Billing Email (optional)

Dedicated email address for invoices (recommended if different from the
general email).

Examples: - “invoices@techvision-gmbh.com” - “account-
ing@johndoe.com”

Main Phone (required Æeld)

Your business phone number (appears on invoices).

Examples: - “+49 30 12345678” (with country code) - “030 / 123 456 78”
(without country code) - “0171 / 123 45 67” (mobile number)

Figure 165: Enter your phone number
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[i] Pro Tip: Use a consistent format with country code (e.g., “+49 30
12345678”) – this looks professionally international.

Alternate Phone (optional)

Additional phone number (e.g., mobile or back ofÆce).

Fax (optional)

Fax number (if relevant for your business).

Website (optional)

Your company website (appears on invoices).

Examples: - “www.techvision-gmbh.com” - “https://johndoe.com” - “legal-
consulting-smith.com”

Figure 166: Optionally enter your website

[i] Pro Tip: Enter the URLwithout “http://” or “https://” – this looks cleaner
(e.g., “www.company.com” instead of “https://www.company.com”).

5.6 Bank Information
Bank details appear on your invoices so customers can transfer payment.

Bank Name (required Æeld)

Name of your bank.

Examples: - “Deutsche Bank AG” - “Sparkasse Berlin” - “Bank of America”

Figure 167: Enter your bank name
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Account Holder (optional)

Name of the account holder (if different from company name).

Examples: - Leave empty if identical to company name - “John Doe” (for
sole proprietorship) - “TechVision GmbH” (if explicitly desired)

Figure 168: Optionally enter the account holder

[i] Pro Tip: Leave this Æeld empty if the account holder is identical to the
company name – this saves space on the invoice.

IBAN (required Æeld)

Your International Bank Account Number.

Format: DE + 2 check digits + 18 digits (total 22 characters)

Example: DE89370400440532013000

Figure 169: Enter your IBAN

Validation: - Theapplicationautomatically checks if the IBAN is valid - For-
mat and checksum validation - Errormessage: “Please enter a valid IBAN”

Figure 170: Error message for invalid IBAN

[i]ProTip: You can enter the IBANwith orwithout spaces – the application
automatically removes spaces. Examples: “DE89 3704 0044 0532 0130
00” or “DE89370400440532013000”.
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[!] Important: Check the IBAN carefully – errors prevent customers from
making payments.

BIC/SWIFT (required Æeld)

SEPA Creditor ID (optional)

If you use SEPA direct debits, you can store your SEPA creditor identiÆer
here.

Bank IdentiÆer Code (also called SWIFT code).

Format: 8 or 11 characters (letters and digits)

Example: DEUTDEDB110

Figure 171: Enter your BIC/SWIFT code

Validation: - The application automatically checks if the BIC is valid - For-
mat validation according to ISO9362 - Errormessage: “Please enter a valid
BIC/SWIFT”

Figure 172: Error message for invalid BIC

[i]ProTip: You canÆnd theBIC on your bank statement, in online banking,
or on your bank’s website.

5.7 Invoice Settings
Invoice settingsdeterminehowyour invoicenumbers lookandwhichnum-
ber will be assigned next.

Invoice Number Pattern (required Æeld)

The pattern deÆnes how invoice numbers are generated.
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Default: INV-{doc_no}

Available Placeholders:

• {doc_no}: Sequential document number (1, 2, 3, …)
• {year}: Current year (e.g., 2025)
• {month}: Current month (01–12)
• {day}: Current day (01–31)

Examples:

Pattern Example Output Use Case

INV-{doc_no} INV-1, INV-2, INV-3 Simple sequential numbering
RE-{year}-{doc_no} RE-2025-1, RE-2025-2 With year
{year}{month}{day}-{doc_no} 20251116-1 With complete date
INV-{year}-{month}-{doc_no} INV-2025-11-1 With year and month

Figure 173: Enter the invoice number pattern

Tooltip Help:

Click the info icon (i) next to the Æeld to see detailed help on placeholders.

Figure 174: Tooltip shows all available placeholders and examples
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[i]ProTip: Use a patternwith year ({year}) to automatically start from the
beginning each year and have clear numbers (e.g., RE-2025-1, RE-2026-
1).
[!] Important: Don’t change thepatternafter theÆrst invoices– this creates
gaps in numbering.

Current Invoice Number (required Æeld)

The next invoice number to be assigned.

Default: 1

When to change? - For new setup: Leave at 1 if you want to start at 1 -
When migrating from another system: Enter last invoice number + 1 (e.g.,
if your last invoice was “RE-2024-450”, enter “451”)

Figure 175: Enter the
next invoice number

Note text: “The next invoice will use this number + 1”

Preview:

Below theÆeld you see apreview of the next invoice number based on your
pattern and current number.

Example: - Pattern: RE-{year}-{doc_no} - Current number: 5 - Preview:
“RE-2025-6”

Figure 176: Preview shows the next invoice number

[i] Pro Tip: Use the preview to test your pattern before saving.
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5.8 Quote and Reminder Settings
Just like invoices, you can deÆne your own patterns and numbering
schemes for quotes and reminders.

Quote Number Pattern

Default: Q-{doc_no}

Examples: - ANG-{doc_no} → ANG-1, ANG-2, ANG-3 - Q-{year}-
{doc_no}→ Q-2025-1, Q-2025-2 - {year}-ANG-{doc_no}→ 2025-ANG-
1

Figure 177: Enter the quote number pattern

Current Quote Number

The next quote number to be assigned.

Default: 1

Figure 178: Enter the
next quote number

Reminder Number Pattern

Default: M-{doc_no}

Examples: - MAH-{doc_no} → MAH-1, MAH-2, MAH-3 - M-{year}-
{doc_no}→M-2025-1, M-2025-2

Figure 179: Enter the reminder number pattern
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[i]ProTip: Remindernumbersautomaticallyhaveanescalation level (e.g.,
-L1, -L2, -L3) added by the application. Example: MAH-2025-1-L1 (Ærst
reminder), MAH-2025-1-L2 (second reminder).

Current Reminder Number

The next reminder number to be assigned.

Default: 0 (because reminders are less common)

Figure 180: Enter the
next reminder number

5.9 Upload Logo
Upload a company logo that appears in the top left of all PDF documents
(invoices, quotes).

Select Logo

1. Click Select logo
2. A Æle selection dialog opens
3. Select an image Æle (PNG, JPG, GIF, SVG)
4. The logo is loaded into the form

Figure 181: Button to upload a logo

Logo Preview

After uploading, you see a preview of the logo in the form.
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Figure 182: Preview of the uploaded logo

Delete Logo

Click Delete logo to remove the logo.

Figure 183: Button to delete the logo

Recommended Logo Formats

Recommendations: - Format: PNG with transparent background (looks
most professional) - Size: Maximum 500 × 200 pixels (landscape format) -
File size: Under 500 KB - Color: Color or black-and-white (depending on
corporate design)

Examples of good logos: - Company name + icon in one line - Logo only
without background - Lettering in company colors

Figure 184: Examples of well-suited logos

[i] Pro Tip: A transparent background (PNG) looksmore professional than
a white background – especially on colored PDFs.

[!] Important: The logo is stored in the database – very large logos can
cause performance issues. Keep Æle size under 500 KB.

5.10 Set as Default
Thedefault tenant is automatically pre-selectedwhen you create newdoc-
uments or timesheets.
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Set Default

Enable the checkbox Set as default to make this tenant the default tenant.

Figure 185: Checkbox to set as default tenant

What happens? - The previous default tenant loses default status - This
tenant becomes the new default tenant - This tenant is pre-selected for all
new documents

[i] Pro Tip: Set the company you work with most frequently as default –
this saves time when creating documents.

5.11 Save Tenant
Save

Click Create tenant (or Update tenantwhen editing) to save the tenant.

Figure 186: Save the tenant with the cre-
ate button

Validation:

The application checks before saving: - [+] Company name Ælled in - [+]
Street, postal code, city, country Ælled in - [+] Tax number and VAT ID Ælled
in - [+] IBAN valid (format and checksum) - [+] BIC valid (format according
to ISO 9362) - [+] Invoice pattern valid (at least one placeholder)
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Figure 187: Validation errors are marked in red

Go BackWithout Saving

Click the back arrow in the upper left corner to return to the previous
screen. If you have unsaved changes, a dialog appears:

Unsaved Changes
“You have unsaved changes. Do you really want to continue?”

• Discard: Changes will not be saved
• Cancel: Stay in the form

Figure 188: Warning for unsaved changes

5.12 Edit Tenant
Open Tenant

Click on a tenant in the list to open it. The edit form shows all saved data.
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Figure 189: Click on a tenant to edit it

Edit Fields

You can edit all Æelds, except: - Company name (can be changed, but care-
fully – appears on all new documents) - Current invoice number (editable
only for a newnumber pattern that has not beenused yet; existing patterns
with published documents are locked)

[!] Important: Changes only affect new documents – already published
documents keep their saved data (GoBD compliance).

Change Number Pattern

You can change the number pattern, but: - [!] Already created documents
keep their old pattern - [!] New documents use the new pattern - [!] This
can lead to inconsistent numbers

If you switch to a completely new number pattern (no documents created
for it yet), you can set the current number freely (e.g., back to 0) to deÆne
the start value.

Recommendation: Only change the pattern at the beginning of the year or
during fundamental restructuring.

[i] Pro Tip: If you need to change the pattern, also increase the current
number to avoid overlaps.
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5.13 Delete Tenant
Prerequisites

You can delete a tenant if: - [+] No published documents exist (invoices,
quotes, reminders) - [+] It’s not the only tenant (at least one tenant must
remain)

[!] Important: Deletion is permanent and cannot be undone.

Perform Deletion

1. Click the three-dot menu to the right of the tenant in the list
2. Select Delete
3. A conÆrmation dialog appears:

Delete tenant?
“Do you really want to delete ‘TechVision GmbH’? This action
cannot be undone.”

• Delete: ConÆrm (red button)
• Cancel: Abort operation

Figure 190: ConÆrmation dialog when deleting a tenant

4. ConÆrm with Delete

What Gets Deleted?

• All company data
• All bank details
• The logo
• All associated drafts (non-published documents)

What Remains?

• Published documents remain (GoBD compliance)
• Customers remain (not assigned to any tenant)
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[i] Pro Tip: If you want to “archive” a tenant without deleting it, simply
create a new tenant and set it as default. The old tenant remains in the list
but is no longer actively used.

5.14 Switch Tenant
Quick Tenant Switch in Menu Bar

In the top menu bar you see the currently selected tenant as a dropdown
menu.

Figure 191: Tenant dropdown in the top menu bar

Switch tenant: 1. Click on the company name in the menu bar 2. A drop-
down menu shows all tenants 3. Select another tenant 4. The application
loads all data for the new tenant

Figure 192: Dropdownmenu shows all available tenants

What changes when switching? - Dashboard shows only documents of
the selected tenant - Document list shows only documents of the selected
tenant - Timesheets showonly timesheets of the selected tenant -Newdoc-
uments are automatically created with the selected tenant
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[i] Pro Tip: The default tenant is marked with a yellow star [*] – so you can
Ænd it faster.

Select Tenant When Creating Documents

When creating an invoice or quote, you can change the tenant in the form:

1. Open the creation form for an invoice
2. Select another tenant in the Tenant Æeld
3. The invoice will be created for the selected tenant

Figure 193: Tenant selection when creating an invoice

[!] Important: The tenant cannot be changed after the Ærst save because
the document number belongs to the tenant.

5.15 Understanding Numbering Schemes
Each tenant has own numbering schemes for: - Invoices - Quotes - Re-
minders

Why Separate Numbering Schemes?

Reason 1: Legal Separation - Each companymust have gap-free, sequen-
tial invoice numbers (GoBD) - Different companies cannot use the same
numbers

Reason 2: Clarity - Customers immediately see which company the in-
voice is from - Example: “RE-2025-1” (TechVisionGmbH) vs. “BW-2025-1”
(Consulting Works GmbH)
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Figure 194: Each tenant has its own numbering schemes

Number Example

Tenant 1: TechVision GmbH - Invoices: RE-2025-1, RE-2025-2, RE-
2025-3, … - Quotes: ANG-2025-1, ANG-2025-2, ANG-2025-3, …
Tenant 2: Consulting Works GmbH - Invoices: BW-2025-1, BW-2025-2,
BW-2025-3, … - Quotes: Q-2025-1, Q-2025-2, Q-2025-3, …
[i] Pro Tip: Use different preÆxes (e.g., “RE” vs. “BW”) to easily distinguish
tenants.

5.16 Practical WorkÇows
WorkÇow 1: Create First Company (10–15minutes, one-time)

Goal: Create your Ærst tenant with all necessary data.

Steps:

1. Create tenant (2 minutes)
• Click + Create new tenant
• Company name: “John Doe – IT Consulting”
• Owner: “John Doe”

2. Enter address (1 minute)
• Street: “Sample Street 123”
• Postal code: “10117”
• City: “Berlin”
• Country: “Germany”
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3. Enter tax information (1 minute)
• Tax number: Copy from tax ofÆce notice
• VAT ID: Copy from notice if available (otherwise apply at Federal
Central Tax OfÆce)

4. Enter contact details (1 minute)
• Email: “contact@johndoe.com”
• Phone: “+49 30 12345678”
• Website: “www.johndoe.com”

5. Enter bank details (3 minutes)
• Bank name: “Sparkasse Berlin”
• IBAN: Copy from bank statement or online banking
• BIC: Copy from bank statement or online banking
• Account holder: Leave empty (identical to company name)

6. Invoice settings (2 minutes)
• Invoice pattern: RE-{year}-{doc_no} (Example: RE-2025-1)
• Current number: 1 (if starting at 1)
• Check preview: “RE-2025-1”

7. Upload logo (2 minutes, optional)
• Click Select logo
• Select your company logo (PNG with transparent background)
• Check preview

8. Set as default (10 seconds)
• Enable Set as default

9. Save (10 seconds)
• Click Create tenant
• Success message appears
• You land in the tenant list

Result: Your Ærst tenant is created and set as default. You can now create
invoices and quotes.

[i] Pro Tip: Have your tax notice, bank statement, and logo ready before
starting – this saves time.

WorkÇow 2: Add Second Company (5–10minutes)

Goal: Add a second company (e.g., GmbH alongside sole proprietorship).

Steps:

1. Create tenant (2 minutes)
• Click + Create new tenant
• Company name: “TechVision GmbH”
• Owner: “Dr. Michael Johnson, Managing Director”

2. Enter address (1 minute)
• GmbH address (can be identical to Ærst company)
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3. Enter tax information (1 minute)
• Different tax number (GmbH has its own tax number)
• Different VAT ID (GmbH has its own VAT ID)

4. Enter contact details (1 minute)
• Can be identical to Ærst company or different email/phone

5. Enter bank details (2 minutes)
• Different IBAN (GmbH has its own bank account)
• Different BIC

6. Invoice settings (2 minutes)
• Invoice pattern: TG-{year}-{doc_no} (Example: TG-2025-1)
• Important: Use a different preÆx than the Ærst company (e.g.,
“TG” instead of “RE”)

• Current number: 1 (new numbering scheme)
7. Upload logo (optional)

• If the GmbH has a different logo, upload it
8. Set default (optional)

• If you mainly work with the GmbH, enable Set as default
• Otherwise leave disabled

9. Save (10 seconds)
• Click Create tenant

Result: Second company is created with its own numbering schemes. You
can now switch between both companies.

[*] WorkÇow Tip: Use unique preÆxes in invoice patterns (e.g., “RE” for
sole proprietorship, “TG” for GmbH) to easily assign documents.

WorkÇow 3: Switch Tenant and Create Invoice (1–2minutes)

Goal: Switch between tenants and create an invoice for a speciÆc company.

Steps:

1. Switch tenant (10 seconds)
• Click on the company name in the top menu bar
• Select “TechVision GmbH” from the dropdown

2. Check dashboard (5 seconds)
• Dashboard shows only documents from TechVision GmbH
• Tenant name is visible in the menu bar

3. Create invoice (30 seconds)
• Click + Create New→New Invoice
• Tenant is automatically set to “TechVision GmbH”
• Select customer, add line items
• Save

4. Check invoice number (5 seconds)

164



• Invoice number follows TechVision GmbH pattern (e.g., “TG-
2025-1”)

Result: Invoice was created for the correct tenant with correct company
details and numbering scheme.

[i] Pro Tip: Always check the tenant in themenu bar before creating a doc-
ument – this prevents creating invoices for the wrong company.

5.17 Pro Tips for Tenant Management
[»] Use default tenant smartly: Set the company you work with most fre-
quently as default – this saves you a click for every document.

[i] Use unique preÆxes: Use different preÆxes in invoice patterns (e.g.,
“RE” for Company A, “BW” for Company B) to easily assign documents.

[*] Number pattern with year: Use {year} in the pattern (e.g., RE-
{year}-{doc_no}) to automatically start from the beginning each year
and have clear numbers.

[!] Check IBAN and BIC carefully: Check IBAN and BIC multiple times –
errors prevent customers frommaking payments.

[~] Logo with transparent background: Use PNG logos with transpar-
ent background – this looks more professional on PDFs than white back-
grounds.

[i] Optimize logo size: Keep logos under 500 KB to avoid overloading the
database. Use online tools like TinyPNG for compression.

[*] Don’t delete tenants prematurely: Only delete tenants if you’re sure
you’ll never need themagain – published documents remain, but all drafts
are deleted.

[»]Don’t change number pattern: Only change the number pattern at the
beginning of the year or during fundamental restructuring – otherwise in-
consistent numbering occurs.

[i] Omit account holder: If the account holder is identical to the company
name, leave the Æeld empty – this saves space on the invoice.

[*] Use tenant dropdown in menu bar: Use the tenant dropdown in the
top menu bar for quick switches between companies – faster than via the
sidebar.
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5.18 Payment ProÆles
What Is a Payment ProÆle?

A payment proÆle contains one set of payment details for a tenant – for
example, a bank account (IBAN/BIC) or a PayPal link. Each tenant can have
multiple payment proÆles, making it easy to offer customers a choice of
payment methods on the same invoice.

Examples: - ProÆle 1: Bank transfer (IBAN/BIC) - ProÆle 2: PayPal (pay-
ment link) - ProÆle 3: Stripe (payment link)

Create and Manage Payment ProÆles

1. Open the tenant you want to add a proÆle to
2. Scroll to the Payment ProÆles section
3. Click + Add payment proÆle
4. Fill in the proÆle details

Figure XX: The payment proÆles section in the tenant editor

Fields per Payment ProÆle

Field Description

Name Label shown in the proÆle selector (e.g., “Bank
Transfer”, “PayPal”)

Type Bank transfer or payment link
IBAN (bank transfer) International Bank Account Number
BIC (bank transfer) Bank IdentiÆer Code
Bank name Optional: displayed on invoice
Account holder Optional: if different from company name
Payment URL (payment
link)

URL customers open to pay (e.g., PayPal.me
link)
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Field Description

QR code Auto-generated based on proÆle data (preview
shown inline)

Select Which ProÆle Appears on a Document

When creating or editing a document, you can choose which payment pro-
Æle to use:

1. In the document editor, Ænd the Payment section on the right-hand
side

2. Select the desired proÆle from the Payment proÆle dropdown
3. The selected proÆle (including its QR code if one is conÆgured) will

appear on the exported PDF

Figure XX: Selecting a payment proÆle in the document editor

QR Codes on Invoices

For payment proÆles with bank transfer details, AGYNAMIX Invoicer can
generate aQR code using the EPC (European Payments Council) standard.
Customers can scan this QR code with their banking app to Æll in the pay-
ment details automatically.

What the QR code encodes: - Recipient name (tenant) - IBAN - BIC - Pay-
ment amount - Invoice number as reference

Useful for: - Customers who use mobile banking apps (common in Ger-
many, Austria, Switzerland) - Reducing input errors in payment reference
Æelds
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Figure XX: A QR code printed on the invoice for instant mobile payment

[i] Pro Tip: If you have clients who frequently miss the payment reference,
enable QR codes on your invoices – it virtually eliminates reference errors.

[!] Note: QR code generation is only available for payment proÆles with
IBAN/BIC details. PayPal or other link-based proÆles do not generate bank-
transfer QR codes.

5.19 Document Templates
What Is a Document Template?

Adocument template controls thevisual appearanceof yourexportedPDF
invoices and quotes: where the logo is placed, how the banner looks, which
fonts are used, and the overall page layout. AGYNAMIX Invoicer ships with
several preset templates and allows you to customize and duplicate them.

Opening the Template Editor

1. Open the tenant you want to customize
2. Scroll to the Document Layout section
3. Click Edit template (or Select template to choose a different preset)
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Figure XX: Template selection and editing in the tenant editor

Available Layout Options

Option Description

Banner placement Top, side, or no banner
Logo size and position Scale and placement of your company logo
Color scheme Primary color used for headings and

accents
Font Select from available font families
Paper margins Adjust whitespace around the content area
Header / Footer content What appears in the static top and bottom

area
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Figure XX: Layout controls in the template editor

Select or Duplicate a Preset Template

1. Click Select template to choose from the library of built-in designs
2. A gallery shows available presets with thumbnails
3. Click a preset to apply it
4. To keep the original preset intact and build on it: clickDuplicate→ a

copy is created that you can freely modify

Figure XX: Gallery of preset templates
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Live Preview

Click Preview at any time to see how a sample invoice would look with the
current settings. The preview uses the real tenant data and a placeholder
document.

Figure XX: Live PDF preview of the current template settings

Best Practices

• Optimal logo dimensions: Use a horizontal logo at roughly 400–600
px wide and 100–150 px tall with a transparent background (PNG)

• Keep colors accessible: Ensure there is good contrast between your
chosen accent color and black text

• Test on paper: Print or save a test PDF to check how colors and fonts
look when printed, not just on screen

Continue with Chapter 6: Customer Management

6. Customer Management
Customer Management is the heart of your invoicing. Here you main-
tain all information about your business partners – from company data to
contact details, tax rates, and e-invoice preferences. Well-maintained cus-
tomerdata speedsup invoice creationandensuresprofessional, error-free
documents.
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Figure 197: The customer list shows all your business partners

6.1 Customer Concept
A customer represents a company or individual for whom you create in-
voices. Each customer has:

• Company data: Name, owner, complete address
• Contact details: Billing email, general email, phone numbers, fax
• Tax data: VAT ID (optional), standard VAT rate
• Currency and language: Which currency and language for invoices
• E-invoice preference: ZUGFeRD, XRechnung, or no electronic in-
voice

Why Customer Master Data Is Important

BeneÆts of well-maintained customer data:

1. Faster invoice creation: All data available with one click
2. Error-free documents: No typos in addresses or tax numbers
3. Automatic pre-Ælling: VAT rate, currency, and language are automat-

ically Ælled
4. E-invoice compliance: Correct XML formats for authorities and large

companies
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5. Professional impression: Consistent, correct customer data on all
documents

Figure 198: Customer data is automatically transferred to documents

[i]ProTip: Invest time in complete customer datawhenÆrst creating them
– it pays off with every invoice.

6.2 Customer List
The customer list shows all your business partners at a glance.

List Overview

Each entry shows:

• Company name: Name of the company or person
• Address: Street, postal code, and city in one line
• Contact details: Billing email and phone (if available)
• VAT ID: Value Added Tax IdentiÆcation Number (if available)

Figure 199: Each entry shows the most important customer data

Search Customers

Use the search bar at the top to quickly Ænd customers.
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Searchby: - Companyname (e.g., “AcmeCorporation”) -Owner (e.g., “John
Doe”)

Figure 200:
Search by company name or owner

[i] Pro Tip: The search works in real-time – just start typing without press-
ing Enter.

Filter Customers

Click the Ælter icon (funnel) to apply special Ælters.

Available Ælters: - Due payments: Shows only customers with overdue
invoices
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Figure 201: Filter customers with due payments

Reset Ælters: Click Clear Ælters to remove all Ælters.

Figure 202: Reset Ælters

[*] WorkÇow Tip: Use the “Due payments” Ælter for weekly payment re-
minders – you’ll immediately see who needs follow-up.

Empty Customer List

If you haven’t created any customers yet, you’ll see a message:

No customers found
“Create your Ærst customer to get started”
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Figure 203: Message when customer list is empty

6.3 Create Customer
Create New Customer

1. Click + Create new customer in the header
2. The creation form opens

Figure 204: Button to create a new cus-
tomer

The form is divided into Æve sections: - Customer information - Address -
Contact information - Tax information - Invoice settings

6.4 Customer Information
Company Name (required Æeld)

The name of the company or person you’re billing.

Examples: - Company: “Acme Corporation GmbH” - Individual: “Dr. Jane
Smith” - Authority: “City of Berlin – Department of Digitalization”
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Figure 205: Enter the company name

[i] Pro Tip: Use the ofÆcial company name as it appears in the commercial
register or on the customer’s website.

Owner (optional)

Name of the owner, managing director, or contact person.

Examples: - “John Doe” - “Dr. Jane Smith” - “Managing Director: Michael
Johnson”
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Figure 206: Optionally enter the owner

[i] Pro Tip: The owner Æeld appears on the invoice below the company
name – use it for personal contact.

Salutation (optional)

Salutation of the contact person (useful for email communication).

Examples: - “Mr” - “Ms”

Title (optional)

Optional title for the contact person.

Examples: - “Dr.” - “Prof.”

Internal Notes (optional)

Internal notes are for your internal organization and are not printed on
invoices.

Customer Number (required, unique)

The Customer Number is an internal, unique identiÆer for the customer.
You can use it to reference customers consistently (e.g., in conversations
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or exports).

[!] Important: Each customer number must be unique.

Customer Reference / Leitweg-ID (optional)

An optional external reference for the customer, e.g. a Leitweg-ID (used by
public-sector customers in Germany) or another internal identiÆer from
your customer’s systems.

6.5 Address
The customer’s address appears on all invoices andmust be complete.

Street (required Æeld)

Street and house number.

Examples: - “Main Street 123” - “Friedrich Street 45b” - “Market Square
7”

Figure 207: Enter street and house number
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Address Supplement (optional)

Additional address information such as Çoor, building, or c/o details.

Examples: - “4th Floor” - “Rear Building” - “c/o Schmidt Administration
GmbH” - “Building A, Room 301”

Figure 208: Optionally enter an address supplement

Postal Code (required Æeld)

Postal code.

Examples: - Germany: “10117”, “80331” - Austria: “1010”, “5020” -
Switzerland: “8001”, “3011”
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Figure 209: Enter the postal code

City (required Æeld)

City name.

Examples: - “Berlin” - “Munich” - “Vienna” - “Zurich”
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Figure 210: Enter the city

State (optional)

State, region, or canton.

Examples: - Germany: “Bavaria”, “Berlin”, “North Rhine-Westphalia” -
Austria: “Vienna”, “Tyrol” - Switzerland: “Zurich”, “Bern” - USA: “Califor-
nia”, “New York”
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Figure 211: Optionally enter the state

[i] Pro Tip: In Germany, the state is usually not necessary – but for inter-
national customers (especially USA, Canada) it’s important.

Country (required Æeld)

Country as text.

Default value: “Germany”

Examples: - “Germany” - “Austria” - “Switzerland” - “USA” or “United
States”

Figure 212: Enter the country

[i] Pro Tip: Use consistent spellings – either always in German (“Deutsch-
land”, “Österreich”) or always in English (“Germany”, “Austria”) – depend-
ing on whether your invoices are primarily in German or English.

[!] Important: The Æeld is pre-Ælled with “Germany” – only change it for
international customers.
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6.6 Contact Information
Contact details are not printed on invoices but support your internal work-
Çows (e.g., sending invoices and payment reminders via email).

[i] Pro Tip: Use the billing email for invoices and the general email for
general communication.

Billing Email

Email address for invoices/payment reminders (typically accounting).

Examples: - “accounting@acme.com” - “john.doe@company.com” - “in-
voice@company.com”

Figure 213: Enter the email address

[i]ProTip: If the customerhas a separate accounting email (e.g.,account-
ing@...), use it – this way you reach the right department directly.

General Email (optional)

General email address for non-billing communication.

Examples: - “info@acme.com” - “ofÆce@company.com”
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Figure 213b: Enter the general email address

Main Phone

Phone number of the contact person.

Examples: - “+49 30 12345678” (with country code) - “030 / 123 456 78”
(without country code) - “0171 / 123 45 67” (mobile number)
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Figure 214: Enter the phone number

[i] Pro Tip: Always save the direct line to accounting if available – this
saves time for payment inquiries.

Alternate Phone (optional)

Additional phone number (e.g., mobile or back ofÆce).

Fax (optional)

Fax number (if the customer still uses fax for ofÆcial communication).

6.7 Tax Information
Tax data determines how invoices are calculated for this customer.

VAT ID (optional)

Value Added Tax IdentiÆcation Number of the customer (if available).

Format: - Germany: DE + 9 digits (e.g., “DE123456789”) - Austria: ATU +
8 digits (e.g., “ATU12345678”) - Switzerland: CHE + 9 digits + MWST (e.g.,
“CHE123456789MWST”)
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Examples: - “DE123456789” - “ATU87654321” - “FR12345678901”

Figure 215: Enter the customer’s VAT ID

When do you need the VAT ID? - For intra-community supplies (EU), the
VAT ID is mandatory - For reverse charge procedure (reversal of tax lia-
bility) - For public clientswith e-invoice obligation

[i] Pro Tip: You can Ænd the VAT ID at the Federal Central Tax OfÆce or on
the customer’s website (usually in the imprint).

[!] Important: If the customer doesn’t have or provide a VAT ID, leave the
Æeld empty–not all businesses are subject toVAT (e.g., small businessown-
ers).

Tax ID / Tax Number (optional)

Optional tax identiÆer of the customer (if you need it for internal pro-
cesses).

VAT Rate (%) (required Æeld)

The standard VAT rate used for invoices to this customer.

Default value: 19 (for Germany)

Common rates: - 19%: German standard rate - 7%: Reduced rate (books,
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food, etc.) - 0%: Reverse charge, export delivery, small business regulation
- 20%: Austria standard rate - 8.1%: Switzerland standard rate

Figure 216: Enter the standard VAT rate

Input format: - Enter the rate as a decimal number: “19” or “19.0” for
19% - Use period or comma as decimal separator: “7.0” or “7,0”

Note text: “Enter VAT percentage (e.g., 19.0 for 19%)”

[i] Pro Tip: The rate entered here is used as the default pre-Æll for all line
items in invoices to this customer – but you can override it for each line
item individually.

[*] WorkÇow Tip: For customers you frequently bill with a reduced rate
(e.g., publishers, food retailers), set the default rate to 7% – this saves time
when creating invoices.

Currency (required Æeld)

The currency in which invoices to this customer are issued.

Default value: EUR

Common currencies: - EUR: Euro (Germany, Austria, etc.) - USD: US Dol-
lar -GBP: British Pound - CHF: Swiss Franc

Input format: - Enter the ISO 4217 currency code (3 letters) - Examples:
“EUR”, “USD”, “GBP”, “CHF”, “JPY”
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Figure 217: Enter the currency

Note text: “Currency code (e.g., EUR, USD, GBP)”

Warning for unknown currency: If you enter an unknown code, a warn-
ing appears: > “Unknown currency code. The code will be displayed un-
changed.”
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Figure 218: Warning for unknown currency

[i]ProTip: The currency determineswhich symbol appears on the invoice
(€, $, £, etc.) – only change it for international customers.

[!] Important: The currency cannot be changed after the Ærst save if in-
voices already exist – create a new customer if needed.

6.8 Invoice Settings
Invoice settings determine how invoices are generated for this customer.

Invoice Language (required Æeld)

The language in which invoices to this customer are issued.

Options: - German: All texts on the invoice (headings, footers) are in Ger-
man - English: All texts on the invoice are in English
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Figure 219: Select the invoice language

Default value: German

What changes?

Element German English

Document type “Rechnung” “Invoice”
Line item table “Pos.”,

“Beschreibung”,
“Menge”

“Pos.”, “Description”,
“Quantity”

Totals “Nettobetrag”,
“MwSt.”,
“Gesamtbetrag”

“Subtotal”, “VAT”,
“Total”

Payment terms “Zahlbar bis” “Due date”
Footer “Vielen Dank für Ihr

Vertrauen”
“Thank you for your
business”

Figure 220: Comparison of invoice in German and English

[i] Pro Tip: For international customers, English is recommended – even
if the billing address is in Germany.

E-Invoice (required Æeld)

Determines whether and which electronic invoice format is used for this
customer.

Options: - None: PDF invoice only (classic paper invoice as PDF) -
ZUGFeRD / Factur-X: PDF with embedded XMLmetadata (hybrid format)
- XRechnung / CII: Separate XML Æle (pure XML format)
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Figure 221: Select the e-invoice format

Default value: None

Option 1: No E-Invoice You receive a classic PDF document without
electronic metadata.

Advantages: - [+] Simple and universally readable - [+] No technical re-
quirements - [+] Ideal for private customers and small companies

Disadvantages: - ❌ No automatic invoice processing at recipient - ❌ Not
suitable for public clients

Figure 222: Classic PDF without electronic metadata

Option 2: ZUGFeRD / Factur-X You receive a hybrid PDF with embed-
ded XMLmetadata.

What is ZUGFeRD? - ZUGFeRD = Central User Guide of the Forum for Elec-
tronic Invoicing Germany - A PDF document with invisible XML data em-
bedded in the PDF - Can be both read by humans and processed by ma-
chines

Advantages: - [+] Universally readable (any PDF viewer displays it) - [+] Au-
tomatic processing possible (accounting software can read XML) - [+] Only
one Æle (no separate XML Æles needed) - [+] Recognized throughout the EU
(also known as Factur-X)

Disadvantages: - ❌ Not all public clients accept ZUGFeRD (some require
XRechnung)

192



Figure 223: ZUGFeRD PDF with embedded XMLmetadata

[i] Pro Tip: ZUGFeRD is the best choice for business customers who use
modern accounting software – they can both read and automatically im-
port the invoice.

Option 3: XRechnung / CII You receive a separate XML Æle in addition
to the PDF.

What is XRechnung? - XRechnung is the standard for public clients in
Germany -ApureXMLÆle (CII =Cross Industry Invoice)withoutPDF -Must
be submitted via special portals (e.g., OZG-RE, XRechnung portal)

Advantages: - [+] Mandatory for public clients (authorities, municipalities,
state-owned companies) - [+] Fully machine-readable - [+] Automatic pro-
cessing in administrative software

Disadvantages: -❌Not human-readable (XMLÆle is pure source code) -❌
You must additionally create a PDF for your records - ❌ Requires upload
via special portals (cannot be sent via email)

Figure 224: XRechnung as separate XML Æle

[i] Pro Tip: Use XRechnung only for public clients who explicitly require
it – for all other customers, ZUGFeRD is the better choice.

[!] Important: Since November 2020, all public clients in Germany are
required to accept electronic invoices (XRechnung or ZUGFeRD). Check in
advance which format your customer prefers.

WhenWhich Format?

Decision guide:
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Customer Type Recommended Format Reason

Private customer None Classic PDF is
sufÆcient

Small company (< 10
employees)

None or ZUGFeRD Depends on
whether they
use modern
accounting
software

Medium/Large
company

ZUGFeRD Automatic
invoice
processing
saves time

Authority, public client XRechnung Legally
required
since
Nov. 2020

International company
(EU)

ZUGFeRD EU-wide
standard
(Factur-X)

Figure 225: Which e-invoice format for which customer?

[*] WorkÇow Tip: Ask new customers on Ærst contact if they prefer e-
invoices – this saves later inquiries.

6.9 Save Customer
Save

ClickCreate customer (orUpdate customerwhen editing) to save the cus-
tomer.
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Figure 226: Save the customer with the create button

Validation:

The application checks before saving: - [+] Company name Ælled in - [+]
Street Ælled in - [+] Postal code Ælled in - [+] City Ælled in - [+] Country Ælled
in

Figure 227: Validation errors are marked in red

[i] Pro Tip: The email and phone Æelds are notmandatory, but highly rec-
ommended – without email you can’t send payment reminders later.

Go BackWithout Saving

Click the back arrow in the upper left corner to return to the previous
screen. If you have unsaved changes, a dialog appears:

Unsaved Changes
“You have unsaved changes. Do you really want to continue?”

• Discard: Changes will not be saved
• Cancel: Stay in the form
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Figure 228: Warning for unsaved changes

6.10 Edit Customer
Open Customer

Click on a customer in the list to open them. The edit form shows all saved
data.

Figure 229: Click on a customer to edit them

Edit Fields

You can edit all Æelds, except: - Currency (cannot be changed after Ærst
save if documents already exist)

[!] Important: Changes to customer data only affect new documents – al-
ready published documents keep their saved data (GoBD compliance: im-
mutability).

Correct Address

If a customer has moved or you discover an error:

1. Open the customer
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2. Change the address Æelds (street, postal code, city)
3. Click Update customer

Effect: - Allnew invoices show the new address -Old invoices keep the old
address (historical accuracy)

Figure 230: Change the address and save

[i]Pro Tip: If youwant to send an old invoice with the new address, use the
duplicate function (duplicate invoice → new address is transferred).

6.11 Delete Customer
Prerequisites

You can delete a customer if: - [+] No published documents exist (invoices,
quotes) - [+] No timesheets exist

[!] Important: Deletion is a soft delete (the customer is marked as deleted
but not permanently removed from the database) – this preserves histori-
cal references.

Perform Deletion

1. Click the three-dot menu to the right of the customer in the list
2. Select Delete
3. A conÆrmation dialog appears:

Delete customer?
“Do you really want to delete ‘Acme Corporation’? This action
cannot be undone.”

• Delete: ConÆrm (red button)
• Cancel: Abort operation
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Figure 231: ConÆrmation dialog when deleting a customer

4. ConÆrm with Delete

What HappensWhen Deleting?

• The customer no longer appears in the list
• All associated drafts (non-published documents) remain but are no
longer assigned to a customer

• Published documents remain fully intact with all customer data
(GoBD compliance)

[i] Pro Tip: If you want to “pause” a customer (e.g., because you’re not cur-
rently working with them), you don’t need to delete them – deleted cus-
tomers are only invisible but not really gone.

6.12 Customer Count
In the footer of the list you see the number of displayed customers in re-
lation to the total.

Example: “25 of 100” - 25 customers are currently displayed (after
search/Ælter) - 100 customers exist in total
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Figure 232: Number of displayed customers

[i] Pro Tip: If the display shows “0 of 100”, your search term or Ælter is too
restrictive – reset Ælters or change the search term.

6.13 Practical WorkÇows
WorkÇow 1: Create First Customer (5 minutes)

Goal: Create your Ærst customer with all important data.

Steps:

1. Create customer (30 seconds)
• Click + Create new customer
• Company name: “Acme Corporation GmbH”
• Owner: “John Doe, Managing Director”

2. Enter address (1 minute)
• Street: “Main Street 456”
• Address supplement: Leave empty (if not needed)
• Postal code: “20095”
• City: “Hamburg”
• State: Leave empty
• Country: “Germany” (pre-Ælled)
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3. Enter contact details (1 minute)
• Email: “accounting@acme.com”
• Phone: “+49 40 98765432”

4. Enter tax data (2 minutes)
• VAT ID: “DE987654321” (if available, otherwise empty)
• VAT rate: “19” (standard for Germany)
• Currency: “EUR” (pre-Ælled)

5. Invoice settings (30 seconds)
• Invoice language: German (default)
• E-invoice: None (for standard business customers)

6. Save (10 seconds)
• Click Create customer
• Success message appears
• You land in the customer list

Result: Your Ærst customer is created and ready for the Ærst invoice.

[i] Pro Tip: Keep customer correspondence (emails, contracts) ready to
copy data correctly – especially VAT ID and email are often hard to Ænd.

WorkÇow 2: Create Customer with E-Invoice (5–7minutes)

Goal: Create a public client with XRechnung requirement.

Steps:

1. Create customer (30 seconds)
• Company name: “City of Berlin – Department of Digitalization”
• Owner: Leave empty

2. Enter address (1 minute)
• Street: “Sample Street 1”
• Postal code: “10115”
• City: “Berlin”
• Country: “Germany”

3. Enter contact details (1 minute)
• Email: “accounting@berlin.de”
• Phone: “+49 30 90269000”

4. Enter tax data (2 minutes)
• VAT ID: “DE123456789” (public clients usually have a VAT ID)
• VAT rate: “19”
• Currency: “EUR”

5. Set e-invoice (1 minute)
• Invoice language: German
• E-invoice: XRechnung / CII (mandatory for public clients)

6. Save (10 seconds)
• Click Create customer
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Result: Customer is created with XRechnung preference. All future in-
voices to this customer automatically include the XRechnung XML Æle.

[*]WorkÇow Tip: Note the Leitweg-ID (a special ID for electronic invoice
transmission) when Ærst contacting public clients – you’ll need it later for
upload in the invoice portal.

WorkÇow 3: International Customers with Reverse Charge (7–10 min-
utes)

Goal: Create an EU customer with reverse charge procedure (0% VAT).

Steps:

1. Create customer (30 seconds)
• Company name: “Software Solutions Austria GmbH”
• Owner: “Dr. Jane Smith”

2. Enter address (1 minute)
• Street: “Ring Street 45”
• Postal code: “1010”
• City: “Vienna”
• Country: “Austria” (important: change from “Germany”)

3. Enter contact details (1 minute)
• Email: “accounting@software-solutions.at”
• Phone: “+43 1 12345678”

4. Tax data for reverse charge (3 minutes)
• VAT ID: “ATU12345678” (mandatory for reverse charge)
• VAT rate: “0” (reverse charge = no VAT on invoice)
• Currency: “EUR”

5. Invoice settings (1 minute)
• Invoice language: English (recommended for international cus-
tomers)

• E-invoice: ZUGFeRD (for automatic processing)
6. Save (10 seconds)

• Click Create customer

Result: Customer is created with 0% VAT (reverse charge). All invoices to
this customer are in English and contain the note “Reverse charge – tax
liability of the recipient of services”.

[!] Important: Verify the customer’s VAT ID at the Federal Central Tax Of-
Æce (BZSt) via the website ec.europa.eu/taxation_customs/vies – only valid
VAT IDs qualify for reverse charge.

[i] Pro Tip: For reverse charge invoices, you must add the text “Reverse
charge according to Art. 196VATSystemDirective” in the invoice line item
– note this as a text snippet for faster creation.
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WorkÇow 4: Update Customer Data (2–3minutes)

Goal: Update outdated contact details of an existing customer.

Steps:

1. Search customer (30 seconds)
• Open the customer list
• Type in the search bar: “Acme”
• Click on “Acme Corporation GmbH”

2. Check contact details (30 seconds)
• Scroll to the “Contact Information” section
• Check email and phone

3. Update email (30 seconds)
• Change email from “accounting@acme.com” to “in-
voices@acme.com”

4. Update phone (30 seconds)
• Change phone from “+49 40 98765432” to “+49 40 11223344”

5. Save (10 seconds)
• Click Update customer

Result: Contact details are updated. All new documents use the new data.

[~] WorkÇow Tip: Keep customer data regularly updated – change
email/phone immediately when you learn of changes (e.g., from email sig-
natures).

6.14 Pro Tips for Customer Management
[»] Complete data on Ærst creation: Invest 5 minutes when Ærst creating
a customer to carefully Æll in all Æelds – this saves time with every invoice
and prevents errors.

[i]Always verify VAT ID: Use the free online veriÆcation at the Federal Cen-
tral Tax OfÆce (BZSt) to validate the VAT ID – invalid numbers can lead to
tax problems.

[*] Use default VAT rate cleverly: Set the default rate to the rate you use
most frequently for this customer (e.g., 7% for publishers, 0% for EU cus-
tomers) – this saves clicks when creating invoices.

[!] Clarify e-invoice in advance: Ask new customers on Ærst contact if
they prefer e-invoices (ZUGFeRD/XRechnung) – changing later is time-
consuming.
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[~]Recommend ZUGFeRD for business customers: Actively recommend
ZUGFeRD to business customers withmodern accounting software – auto-
matic invoice processing saves time for both sides.

[i] Consistent country spelling: Decide once whether to use German
(“Deutschland”) or English (“Germany”) and stick with it – this looksmore
professional.

[*]Use accounting email: Always save the accounting department’s email
(e.g., accounting@..., invoices@...) instead of general contact emails
– this way invoices reach the right department directly.

[»]Direct line to accounting: If available, save the direct line to accounting
instead of the main number – this saves time for payment inquiries.

[i] Don’t delete customers prematurely: Only delete customers if you’re
sure you’ll never work with them again – old customers can be reactivated
anytime.

[*] Leverage search function: Use real-time search for quick access – just
type the Ærst letters of the company name.

6.15 Customer Import/Export (CSV)
For bulk operations (moving to a new installation, initial data entry, or
syncing with other tools), you can export and import customers as CSV.

Export Customers (CSV)…

1. Click File→ Export→ Export Customers (CSV)...
2. Select a destination folder
3. The application creates a timestamped CSV Æle (e.g., customers-

export-...csv)
[i] Tip: Export once and use the exported Æle as a template for your own
CSV.

Import Customers (CSV)…

1. Click File→ Import→ Import Customers (CSV)...
2. Select a CSV Æle
3. Review the mapping and preview
4. Select the rows you want to import
5. Start the import
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Mapping and preview

The import dialog supports:

• Enabling/disabling individual Æelds
• Mapping columns by header names (case-insensitive)
• Previewing rows before importing
• Highlighting issues (e.g., duplicates, invalid rows)

Required Æelds (for import)

To import a customer, the following information must be available:

• Street, Postal code, City
• At least one of: Company name or Contact person

If required values are missing, the row is marked as invalid and cannot be
imported.

Duplicate detection

During preview the application highlights potential duplicates, for exam-
ple:

• Duplicate email
• Duplicate customer number
• Possible duplicate record (same/similar customer data)

[*] Best Practice: If you already have customers in your database, import
in smaller batches and resolve duplicates as you go.

Continue with Chapter 7: Product Management

7. Product Management
TheProducts section lets youmaintain reusable productmaster data (e.g.,
standard services, hourly packages, Æxed-price items). Products help you
create sales documents faster and keep descriptions/prices consistent.
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Figure XXX: Product list with search and create button

7.1 Product Concept
A product is a reusable template for a line item. A product can contain:

• SKU (required): Your internal identiÆer (unique)
• Title (required): Short name shown in lists and selection
• Net unit price (required): Price per unit in the document currency
• Quantity unit (optional): e.g., hour, piece
• Tax rule (optional): Default tax rule for the product
• Description (optional): Detailed text (Markdown supported)

[*] Best Practice: Use products for everything you bill repeatedly (stan-
dard consulting hour, maintenance package, hosting fee, etc.).

7.2 Product List
Navigate to the product list via the sidebar:

• Products
The list provides:

• Search: Filter products by typing part of the SKU or title
• Create: Add a new product
• Edit/Delete: Manage existing products

7.3 Create and Edit Products
1. Open Products
2. Click + Create new product
3. Fill the Æelds and click Save

Required Æelds

• SKU: Must be unique
• Title
• Net unit price
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Optional Æelds

• Quantity unit: Used as default when adding the product to a docu-
ment

• Tax rule: Used as default tax rule when adding the product to a doc-
ument

• Description: Markdown formatting is supported

[i] Tip: Keep SKUs stable over time; they are useful for CSV import/export
and for searching.

7.4 Using Products in Sales Documents
Products integrate into the line items section of sales documents.

Add line item from product

1. In a draft document, go to the Line items section
2. Click Add line item from product
3. Search and select a product

Anew line item is createdandpre-Ælled fromthe selectedproduct (descrip-
tion/title, quantity unit, unit price, and tax rule).

Apply a product to an existing line item

In each line item row you can also pick a product via the product icon. This
updates the line item Æelds based on the selected product.

View product details

If a line item is linked to a product, you can open the product details from
the line item.

[!] Important: The product link is meant as a draft-time helper.
The document always stores its own values; changing a product
later does not retroactively change already created documents.

[?] Continue reading: More details about line items are in Chapter 3 (Doc-
uments).

7.5 Product Import/Export (CSV)
Products can be exported and imported as CSV.
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Export Products (CSV)…

1. Click File→ Export→ Export Products (CSV)...
2. Select a destination folder
3. The application creates a timestamped CSV Æle (e.g., products-

export-...csv)

Import Products (CSV)…

1. Click File→ Import→ Import Products (CSV)...
2. Select a CSV Æle
3. Review the mapping and the preview
4. Start the import

Mapping and preview

The import dialog allows you to:

• Enable/disable individual Æelds for import
• Map columns via header names (case-insensitive)
• Preview rows before importing
• Select which rows to import

Required Æelds

To import products, these Æelds must be present (and enabled in the map-
ping):

• SKU
• Title
• Net unit price

Rows with missing/invalid required values are marked as invalid and can-
not be imported.

Duplicate detection

During preview the application highlights potential issues, for example:

• Duplicate SKU (within the Æle or already existing in the database)
• Possible duplicate record (same/similar product data)

[*] Best Practice: Start by exporting products once and use the exported
Æle as a template for your import.

Continue with Chapter 8: Text Snippets
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8. Text Snippets
Text snippets are reusable text blocks that you can insert into invoices and
quotes. Once created, you can incorporate them into any number of doc-
uments with just a few clicks – ideal for recurring content like payment
terms, terms and conditions, or standard descriptions. Text snippets sup-
port Markdown formatting for professional styling.

Figure 233: The text snippets list shows all your reusable content

8.1 Text Snippets Concept
A text snippet (text block) is reusable content that you can use acrossmul-
tiple documents. Each text snippet has:

• Name: Label for identiÆcation (e.g., “Payment Terms”, “Terms&Con-
ditions”)

• Content: The actual text with Markdown formatting
• Positioning: Can be inserted before or after invoice line items

Why Use Text Snippets?

BeneÆts of reusable content:

1. Time savings: Create once, use as often as needed
2. Consistency: Same text on all documents (no typos)
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3. Professional formatting: Markdown enables headings, lists, bold
text

4. Central maintenance: Changes in one place – new documents auto-
matically use the updated version

5. Multilingual: Different text snippets for German and English in-
voices

Figure 234: Text snippets are inserted into documents

[i]ProTip: Create at least two text snippets: One forpayment terms (before
line items) and one for legal notices (after line items).

8.2 Typical Use Cases
Payment Terms

Example:

**Payment Terms:**
Please transfer the invoice amount within 30 days, including the invoice number as reference. If you have any questions about the invoice, please don't hesitate to contact us.
Position: Before line items (visible directly below customer address)
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Figure 235: Payment terms as text snippet

Terms and Conditions

Example:

**Terms and Conditions:**
Our general terms and conditions apply, which you can view on our website at www.company.com/terms. All prices are exclusive of statutory VAT.
Position: After line items (visible at the end of the invoice)
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Figure 236: Terms and conditions as text snippet

Delivery Terms

Example:

**Delivery Terms:**
- Delivery within 10 business days after payment receipt
- Shipping costs are calculated separately
- Partial deliveries are possible
Position: After line items

211



Figure 237: Delivery terms with list

Warranty Information

Example:

**Warranty:**
We provide a 24-month warranty on all products from the date of purchase. The warranty covers material and workmanship defects. Damage due to improper use is excluded.
Position: After line items

Project Description

Example:

**Project Description:**
The following services were provided as part of the "Website Relaunch" project. The work includes design, development, and quality assurance according to the agreed specification dated October 15, 2025.
Position: Before line items

[i] Pro Tip: For international customers, you can create English versions
of the same text snippets (e.g., “Payment Terms” instead of “Zahlungshin-
weise”).
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8.3 Text Snippets List
The text snippets list shows all your reusable content at a glance.

List Overview

Each entry shows:

• Name: Label of the text snippet
• Content preview: The Ærst lines of the text (up to 6 lines)
• Action buttons: Edit and Delete

Figure 238: Each entry shows name and content preview

Empty Text Snippets List

If you haven’t created any text snippets yet, you’ll see a message:

No text snippets yet
“Create reusable text snippets for invoices and emails.”

Figure 239: Message when text snippets list is empty
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8.4 Create Text Snippet
Create New Text Snippet

1. Click + Create new text snippet in the header
2. The creation form opens

Figure 240: Button to create a new text
snippet

The form has two Æelds: - Name (required Æeld) - Content (required Æeld,
with Markdown support)

8.5 Name (required Æeld)
The name is used to identify the text snippet in the list and when inserting
into documents.

Recommendations: - Short and concise (e.g., “Payment Terms”, “Terms &
Conditions”, “DeliveryTerms”) - Self-explanatory (you should immediately
knowwhat the text snippet contains) - Formultilingual text snippets: Mark
the language (e.g., “Payment Terms EN”, “Zahlungshinweise DE”)

Examples: - “PaymentTerms” - “TermsandConditions” - “StandardDeliv-
ery Terms” - “24MonthWarranty Information” - “Website Project Descrip-
tion”

Figure 241: Enter a descriptive name

[i] Pro Tip: Use numbers or preÆxes for similar text snippets (e.g., “01 –
Standard Payment Terms”, “02 – Express Payment Terms”) – this keeps
them sorted in the list.

8.6 Content (required Æeld)
The content is the actual text that will be inserted into documents. You can
useMarkdown formatting to style the text professionally.

Plain Text

Example:
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Please transfer the invoice amount within 30 days, including the invoice number as reference on the account provided.

Figure 242: Enter the text

Markdown Formatting

Markdown is a simple markup language that lets you format text. The for-
matting is displayed on the invoice in the PDF.

Note text in form: “Markdown formatting is supported.”

Figure 243: Note about Markdown support

8.7 Markdown Syntax
Bold Text

Enclose text with double asterisks for bold text.

Syntax:
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**Payment Terms:**
Result: Payment Terms:

Figure 244: Bold text with double asterisks

Italic Text

Enclose text with single asterisks for italic text.

Syntax:

*Important:* Please include invoice number.
Result: Important: Please include invoice number.
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Figure 245: Italic text with single asterisks

Headings

Use hash symbols (#) for headings. More hashes = smaller heading.

Syntax:

# Large Heading
## Medium Heading
### Small Heading
Result:
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Large Heading

MediumHeading
Small Heading

Figure 246: Headings with hash symbols

[i] Pro Tip: For text snippets in invoices, ### Small headings (3 hashes)
are recommended – larger headings often appear oversized.

Bullet Lists (unordered)

Use hyphens (-) or **asterisks (*)** for unordered lists.

Syntax:

**Delivery Terms:**
- Delivery within 10 business days
- Shipping costs calculated separately
- Partial deliveries possible
Result:

Delivery Terms: - Delivery within 10 business days - Shipping costs cal-
culated separately - Partial deliveries possible
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Figure 247: Unordered list with hyphens

Numbered Lists (ordered)

Use numbers with period (1., 2., 3.) for numbered lists.

Syntax:

**Payment Steps:**
1. Review invoice
2. Transfer amount
3. Await payment confirmation
Result:

Payment Steps: 1. Review invoice 2. Transfer amount 3. Await payment
conÆrmation
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Figure 248: Numbered list with numbers

Nested Lists

You can also nest lists by adding two spaces before the hyphen/number.

Syntax:

**Warranty Conditions:**
- Material and workmanship defects:

- 24 months warranty
- Free replacement

- Excluded:
- Improper use
- Wear parts

Result:

Warranty Conditions: - Material and workmanship defects: - 24 months
warranty - Free replacement - Excluded: - Improper use - Wear parts
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Figure 249: Nested list with indentation

Links

Use square brackets + parentheses for clickable links.

Syntax:

Find our terms and conditions at [www.company.com/terms](https://www.company.com/terms).
Result: Find our terms and conditions at www.company.com/terms.
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Figure 250: Links with square and round brackets

[!] Important: Links are not clickable on printed PDFs – for in-
voices, it’s recommended to provide the URL as plain text (e.g.,
“www.company.com/terms”).

Line Breaks

For a single line break, add two spaces at the end of a line, followed by
Enter.

Syntax:

First line
Second line
For a paragraph (more spacing), insert a blank line.

Syntax:

First paragraph.

Second paragraph.
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Figure 251: Line breaks and paragraphs

Combinations

You can combine different formatting:

Syntax:

**Important Payment Terms:**

Please note the following points *carefully*:
- Transfer the amount **within 30 days**
- Include the invoice number as reference
- Contact us at accounting@company.com with questions

Find more information at www.company.com/payment.
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Figure 252: Combination of bold, italic, and lists

8.8 Markdown Preview
Live Preview in Form

While entering content, you cannot see the formatting directly – the ap-
plication only shows the raw text with Markdown syntax.

To check the formatting: 1. Save the text snippet 2. Create a test invoice
3. Insert the text snippet 4. Use the preview/PDF function of the invoice

Figure 253: Raw text with Markdown syntax in form

[i] Pro Tip: Use an external Markdown editor (e.g., dillinger.io) with live
preview to compose longer texts and then paste them via copy & paste.
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8.9 Save Text Snippet
Save

ClickCreate text snippet (orUpdate text snippetwhenediting) to save the
text snippet.

Figure 254: Save the text snippet
with the create button

Validation:

The application checks before saving: - [+] NameÆlled in - [+] Content Ælled
in

Figure 255: Validation errors are marked in red

Go BackWithout Saving

Click the back arrow in the upper left corner to return to the previous
screen. If you have unsaved changes, a dialog appears:

Unsaved Changes
“You have unsaved changes. Do you really want to continue?”

• Discard: Changes will not be saved
• Cancel: Stay in the form

Figure 256: Warning for unsaved changes
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8.10 Edit Text Snippet
Open Text Snippet

Click on a text snippet in the list to open it. The edit form shows all saved
data.

Figure 257: Click on a text snippet to edit it

Edit Fields

You can edit all Æelds: - Name - Content (with Markdown formatting)

[!] Important: Changes to text snippets only affect new documents – al-
readypublisheddocuments keep their original text (GoBDcompliance: im-
mutability).

Why? Text snippets are copied into the document (embedded) when the
invoice is published. Later changes to the text snippet have no effect on
already published documents.

Figure 258: Change name or content
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[i] Pro Tip: If you discover an error in an already sent document, youmust
create a correction invoice – changing the text snippet afterwards doesn’t
help.

8.11 Delete Text Snippet
Prerequisites

You can delete a text snippet at any time, even if it was used in documents.

[!] Important: Deletion is permanent and cannot be undone. Already pub-
lished documents keep their text (since it was copied during publishing).

Perform Deletion

1. Click the three-dot menu to the right of the text snippet in the list
2. Select Delete
3. A conÆrmation dialog appears:

Delete text snippet?
“Delete ‘Payment Terms’? This action cannot be undone.”

• Delete: ConÆrm (red button)
• Cancel: Abort operation

Figure 259: ConÆrmation dialog when deleting a text snippet

4. ConÆrm with Delete

What HappensWhen Deleting?

• The text snippet is removed from the list
• New documents can no longer use this text snippet
• Drafts (non-published documents) that use the text snippet keep it
• Publisheddocuments keep their text completely (since it was copied
during publishing)
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[i] Pro Tip: If you no longer want to use a text snippet but are unsure about
deleting it, simply change the name to “[ARCHIVE] Payment Terms” – this
way you immediately see it’s no longer active.

8.12 Insert Text Snippets into Documents
You can insert text snippets into invoices and quotes. Details can be found
in Chapter 3 – Documents (Section 3.8 – Add Text Blocks).

Quick Overview

1. Open an invoice or quote (draft)
2. Scroll to the Text Blocks section
3. Click + Add text block
4. Select a text snippet from the list
5. Choose the position: Before line items or After line items
6. Save the invoice

Figure 260: Insert text snippet in invoice

Position “Before line items”: The text snippet appears above the line
items table (ideal for payment terms, project descriptions).

Position “After line items”: The text snippet appears below the line items
table and totals (ideal for terms & conditions, warranty information, deliv-
ery terms).
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Figure 261: Text snippet before and after line items in PDF

[i] Pro Tip: You can insert multiple text snippets into a document – e.g.,
payment terms before line items and terms & conditions after line items.

8.13 Practical WorkÇows
WorkÇow 1: Create Standard Text Snippets (15–20minutes, one-time)

Goal: Create the most important text snippets that you want to use in all
invoices.

Steps:

1. Create payment terms (5 minutes)
• Click + Create new text snippet
• Name: “Payment Terms”
• Content:
**Payment Terms:**

Please transfer the invoice amount within 30 days, including the invoice number as reference on the account provided. If you have any questions about the invoice, please don't hesitate to contact us.
• Click Create text snippet

2. Create terms and conditions (5 minutes)
• Click + Create new text snippet
• Name: “Terms and Conditions”
• Content:
**Terms and Conditions:**

Our general terms and conditions apply, which you can view on our website at www.company.com/terms. All prices are exclusive of statutory VAT.
• Click Create text snippet

3. Create delivery terms (5 minutes)
• Click + Create new text snippet
• Name: “Standard Delivery Terms”
• Content:
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**Delivery Terms:**

- Delivery within 10 business days after payment receipt
- Shipping costs calculated separately
- Partial deliveries possible

• Click Create text snippet

Result: Youhave three standard text snippets that youcan insert into every
invoice.

[*] WorkÇow Tip: Insert the text snippets directly into your next invoice
to check how they look in the PDF – this way you can optimize formatting
and wording.

WorkÇow 2: Create Multilingual Text Snippets (10–15minutes)

Goal: Create German and English versions for international customers.

Steps:

1. German payment terms (3 minutes)
• Name: “Zahlungshinweise DE”
• Content:
**Zahlungshinweise:**

Bitte überweise den Rechnungsbetrag innerhalb von 30 Tagen unter Angabe der Rechnungsnummer.
2. English payment terms (3 minutes)

• Name: “Payment Terms EN”
• Content:
**Payment Terms:**

Please transfer the invoice amount within 30 days, including the invoice number as reference.
3. German terms & conditions (3 minutes)

• Name: “AGB DE”
• Content:
**Allgemeine Geschäftsbedingungen:**

Es gelten unsere AGB unter www.firma.de/agb.
4. English terms & conditions (3 minutes)

• Name: “Terms & Conditions EN”
• Content:
**Terms & Conditions:**

Our general terms and conditions apply, available at www.company.com/terms.
Result: You have bilingual text snippets for German and international cus-
tomers.
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[i] Pro Tip: Use the language abbreviation (DE/EN) at the end of the name
to immediately see which language the text snippet has in the list.

WorkÇow 3: Update Text Snippet (2–3 minutes)

Goal: Update an existing text snippet (e.g., change payment deadline).

Steps:

1. Open text snippet (30 seconds)
• Open the text snippets list
• Click on “Payment Terms”

2. Change content (1 minute)
• Change “30 days” to “14 days”
• New content:
**Payment Terms:**

Please transfer the invoice amount within **14 days**, including the invoice number as reference on the account provided.
3. Save (10 seconds)

• Click Update text snippet
4. Check (1 minute)

• Create a new test invoice
• Insert the updated text snippet
• Check the preview

Result: All new invoices use the updated payment deadline (14 days).

[!] Important: Already published invoices keep the old payment deadline
(30 days) – this is GoBD-compliant and prevents retroactive changes.

WorkÇow 4: Test Markdown Formatting (5 minutes)

Goal: Test various Markdown formatting to see how they look in the PDF.

Steps:

1. Create test text snippet (2 minutes)
• Name: “Test Formatting”
• Content:
### Heading

This is **bold text** and this is *italic text*.

**List:**
- First point
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- Second point
- Subpoint A
- Subpoint B

**Numbered List:**
1. First step
2. Second step
3. Third step

2. Insert into invoice (1 minute)
• Create a test invoice
• Insert the test text snippet

3. Check PDF preview (2 minutes)
• Open the preview/PDF
• Check how the formatting looks
• Adjust text snippet if needed and check again

4. Delete test text snippet (30 seconds)
• Delete the test text snippet after testing

Result: You know how various Markdown formatting looks in the PDF.

[i] Pro Tip: Don’t save the test text snippet – create it again when needed
to try different formatting.

8.14 Pro Tips for Text Snippets
[»] Standard text snippets for all invoices: Create at least “Payment
Terms” and “Terms & Conditions” as text snippets – this saves time with
every invoice.

[i] Use language abbreviations in name: Add “DE” or “EN” at the end of
the name (e.g., “Payment Terms EN”, “Zahlungshinweise DE”) to easily dis-
tinguish multilingual text snippets.

[*] Markdown preview in external editor: Use dillinger.io or another
Markdown editor with live preview for longer text snippets – then paste
via copy & paste.

[!] Bold text for headings: Use **Heading:** instead of ### Heading for
small headings in text snippets – this often looks better on invoices.

[~]Lists for structure: Use lists (- or 1.) for clear presentation of conditions
or steps – this increases readability.

[i]Short and concise: Keep text snippets short (max. 3–5 sentences or 5–7
list items) – too much text appears cluttered.

[*] Group text snippets by position: Use preÆxes like “01 –” for text snip-
pets that comebefore line itemsand “02–” for text snippets after line items
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– this keeps them sorted in the list.

[»]Not toomany text snippets: Only create text snippets that you actually
usemultiple times – otherwise the list becomes confusing (5–10 text snip-
pets are ideal).

[i] Links as plain text: Write URLs as plain text
(www.company.com/terms) instead of as Markdown link
([Link](https://...)) – links are not clickable on printed invoices.

[*] Update regularly: Review your text snippets every 6–12 months for
currency (e.g., new payment deadlines, changed terms& conditions) – this
keeps you legally compliant.

8.15 Auto-Assignment Rules
What Is Auto-Assignment?

Auto-assignment lets you deÆne rules on a text snippet so that it is au-
tomatically added to new documents that match certain criteria, without
you having to select it manually each time.

For example: “Always add the ‘Reverse Charge Note’ snippet to invoices
for customers in the EU” — once the rule is set, this happens automatically
whenever you create an invoice for a matching customer.

When Auto-Assignment Saves Time

• You have a standard payment-terms snippet that should go on every
invoice you ever create

• Youhavea legal disclaimer that only applies to customers in a speciÆc
country

• You want a project description template pre-Ælled for a speciÆc cus-
tomer

ConÆguring Auto-Assignment on a Text Snippet

1. Open the text snippet you want to conÆgure (create it Ærst if needed)
2. Scroll to the Auto-Assignment section in the snippet edit form
3. Enable Auto-assign to matching documents
4. ConÆgure the matching criteria:
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Figure XX: Auto-assignment section in the text snippet editor

Matching Criteria

Criterion Description

Customer Only add to documents for a speciÆc
customer

Document type Only add to invoices, or only to quotes,
etc.

Tenant Only add to documents from a speciÆc
tenant (company)

Position Where in the document the snippet
should be placed (before or after line
items)

You can combine criteria. For example: “Add to invoices (type) for cus-
tomer Acme (customer)” — the snippet will only be auto-added when both
conditions are met.

Leave a criterion empty tomatch all values (e.g., leaving “Customer” empty
means the snippet applies to documents for any customer).
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How to Test That Auto-AssignmentWorks

1. Create a new document that should match the rule (correct type, cor-
rect customer, correct tenant)

2. Check the Text blocks section of the document – the snippet should
already be present

3. If it is not there, revisit the rule criteria to verify they match the doc-
ument you created

Disabling or Overriding Auto-Assignment on a SpeciÆc Document

Auto-assignment adds the snippet as a starting point, but you are always
free to: - Remove the auto-assigned snippet from a speciÆc document by
clicking the X icon - Add additional snippets manually on top of the auto-
assigned ones - Reorder snippets in the document

Removing a snippet from one document does not affect the rule – the snip-
pet will still be auto-added to the next new document that matches.

If you want to permanently disable auto-assignment for a snippet, go back
to the snippet and uncheck Auto-assign to matching documents.

Continue with Chapter 9: Settings

9. Settings
Settings allow you to customize the application to your preferences. Here
you conÆgure appearance, automatic backups, document export, and up-
date notiÆcations. All settings are saved immediately and restored on ev-
ery start.

[>] First time here? Start with the 5-minute setup. If you’re
settingupAGYNAMIX Invoicer for theÆrst time, jumpdirectly to
Section9.13WorkÇow1: Initial Setupwhichguides you through
the essential settings in order. Come back to this chapter for
detailed reference on individual options.
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Figure 262: The settings overview shows all conÆguration options

9.1 Open Settings
You can open settings in two ways:

Way 1: Via Sidebar

1. Click Settings (gear icon) in the left sidebar

Figure 263: Settings link in the sidebar

Way 2: Via Menu Bar

1. Click Edit in the top menu bar
2. Select Preferences (or use the keyboard shortcut Ctrl+, / Cmd+,)

Figure 264: Open settings via menu bar
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9.2 Settings Overview
Settings are divided into sections:

1. Appearance: Design (Light/Dark/System)
2. Backup: Automatic backups and retention
3. Documents: Storage location and Æle names
4. Updates: Automatic update checking
5. Email: ConÆgure sending (SMTP) and sent-copy (IMAP)
6. Document Emails: Templates for document emails
7. User Management: Manage users, roles, and permissions (if en-

abled)
8. Server: Operating mode (Standalone/Host/Client) and server conÆg-

uration

Figure 265: The settings sections

9.3 Appearance
Design Mode

Choose how the application should look: Light, Dark, or automatically
adapted to your system settings.

Available options:
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Option Description When to use?

System
Default

Follows your operating
system setting
(Light/Dark)

Recommended –
automatic adaptation

Dark Design Application is always
dark

For working in low light

Light Design Application is always
light

For working in daylight

Figure 266: Choose between Light, Dark, and System Default

Select:

1. Click the radio button next to the desired option
2. The change is applied immediately (no save button needed)

Figure 267: The change is immediately visible

[i] Pro Tip: Use System Default so the application automatically switches
between light and dark when you activate dark mode on your computer in
the evening.

Light Design (Light Mode)

• Light background colors (White, Light Gray)
• Dark text colors (Black, Dark Gray)
• High contrast for daylight work
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Figure 268: Light design (Light Mode)

Dark Design (Dark Mode)

• Dark background colors (Dark Gray, Black)
• Light text colors (White, Light Gray)
• Easy on the eyes in low light

Figure 269: Dark design (Dark Mode)

[!] Important: The design setting only affects the application itself, not
the exported PDF documents. PDFs always have a light design for optimal
readability when printing.

9.4 Backup
Why Backups Are Important

Backups protect your data from: - Accidental deletion - Hard drive failure
- Software problems - Unwanted changes

[i] Pro Tip: Enable Daily orWeekly to automatically create backups – this
way you’re always on the safe side.

Frequency

Determine how often automatic backups are created.

Available options:
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Option Description Recommendation

None No automatic backups [!] Not recommended – only
for test environments

Always (on
every exit)

Every time you exit the
application

For very important data

Daily Once per day on exit [*] Recommended for normal
use

Weekly Once per week on exit For occasional use
Monthly Once per month on exit For rare use

Figure 270: Choose backup frequency

Select:

1. Click the Frequency dropdownmenu
2. Select an option from the list
3. The setting is saved immediately

Figure 271: Dropdownmenu for backup frequency

[i] Pro Tip: For active use (several invoices daily),Daily is recommended –
for occasional use (1–2 invoices per week),Weekly is sufÆcient.

Backup Directory

Choose the folder where backup Æles are stored.

Default: Empty (no backups)

Select:

1. Click Choose directory
2. A Æle selection dialog opens
3. Navigate to the desired folder (e.g., ~/Backups/Invoicer/)
4. Click Select folder
5. The path is displayed in the text Æeld
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Figure 272: Choose the folder for backups

Recommended storage locations:

• Cloud folder: ~/Dropbox/Backups/Invoicer/ or ~/Google
Drive/Backups/Invoicer/ (automatically backed up to cloud)

• External drive: /Volumes/Backup/Invoicer/ (additional secu-
rity)

• Local folder: ~/Documents/Invoicer-Backups/ (fast, but local
only)

Figure 273: The selected path is displayed

[i] Pro Tip: Use a cloud folder (Dropbox, Google Drive, iCloud) for double
security – if your computer fails, the backups are available in the cloud.

[!] Important: The backup directorymust have sufÆcient storage space (at
least 500 MB for ~100 backups with an average of 5 MB per backup).

Backup Retention

Determine how long old backups are kept before being automatically
deleted.

Available options:
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Option Description Recommendation

Keep Backups are never
deleted

[!] Caution – storage space
can run out

1 Day Backups older than 1
day are deleted

Only for daily backups with
limited storage

1Week Backups older than 1
week are deleted

For weekly backups

1 Month Backups older than 1
month are deleted

[*] Recommended for daily
backups

1 Year Backups older than 1
year are deleted

For maximum security

Figure 274: Choose retention period

Select:

1. Click the Backup Retention dropdownmenu
2. Select an option from the list
3. The setting is saved immediately

Figure 275: Dropdownmenu for retention period

[i] Pro Tip: For daily backups, 1 Month is recommended – this gives you
up to 30 backups to choose from if you need to restore something, without
taking up too much storage space.

Note Text

“Backups are automatically created when closing the applica-
tion and saved in the speciÆed folder”

When are backups created?

Backups are automatically created when you: 1. Close the application (via
File → Exit or the close button) 2. The backup frequency is met (e.g., daily
→ 1 day has passed since last backup)
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Backup Æle name:

Backups have the following format:

invoicer-{production|sandbox}-YYYY-MM-DD-HHMMSS.zip
Example: invoicer-production-2025-11-16-143522.zip

Figure 276: Backup Æles in backup directory

[!] Important: If the application crashes (e.g., power failure), no backup is
created. Use regular backups to minimize data loss.

Backup Reminder on Exit

If you have not conÆgured automatic backups (Frequency = None), a re-
minder dialog appears when exiting the application:

Create backup?
“You have not conÆgured automatic backups. Do you want to
create a backup before closing?”

• Continue: Create backup
• Skip: Exit without backup
• Don’t ask again: Don’t show this dialog again (checkbox)

Figure 277: Reminder when exiting without automatic backups

[i] Pro Tip: If you activated the Don’t ask again checkbox and want to re-
enable the reminder, you can currently only do this by resetting all settings
(see Section 9.12).

Encrypted Backups

For additional security – especially when backups are stored in cloud ser-
vices or shared locations – you can create encrypted backups. An en-
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crypted backup is a password-protected ZIP Æle that cannot be opened
without the passphrase.

Create an Encrypted Backup

1. Go to File → Create Backup… (or wait for the automatic backup on
exit)

2. In the backup dialog, enable the Encrypt backup option
3. Enter a passphrase in the Æeld provided
4. ConÆrm the passphrase in the second Æeld
5. Click Create Backup

Figure XX: The backup dialog with the encryption option enabled

[!] Important – store your passphrase safely: If you lose the passphrase,
the encryptedbackupcannotbe restored. Write it downandkeep it in a se-
cure place (e.g., a passwordmanager or a printed note in a locked drawer).

Restore an Encrypted Backup

1. Go to File → Restore from Backup…
2. Select the encrypted backup Æle (.zip)
3. The application detects that the backup is encrypted and asks for the

passphrase
4. Enter the passphrase
5. Click Restore

Figure XX: The restore dialog asking for the passphrase
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When to Use Encrypted Backups

Storage Location Recommendation

Local hard drive (home computer,
not shared)

Encryption optional

Cloud storage (Dropbox, Google
Drive, iCloud)

Encryption recommended

NAS or shared network drive Encryption recommended
USB stick / external drive (portable,
can be lost)

Encryption strongly
recommended

[i] Security tip: Encrypted backups offer peace of mind when backups are
stored off-device. Even if someone gains access to the storage, they cannot
read your business data without the passphrase.

9.5 Documents
Document Folder

Choose the main folder where all exported PDFs and HTMLs are stored.

Default: Empty (no export possible)

Select:

1. Click Choose directory
2. A Æle selection dialog opens
3. Navigate to the desired folder (e.g., ~/Docu-

ments/Invoicer/Invoices/)
4. Click Select folder
5. The path is displayed in the text Æeld
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Figure 278: Choose the main folder for documents

Recommended storage locations:

• Cloud folder: ~/Dropbox/Invoices/ (automatically backed up to
cloud)

• Local folder: ~/Documents/Invoices/ (fast, but local only)
• External drive: /Volumes/Data/Invoices/ (additional security)

Figure 279: The selected path is displayed

Note text: “Main folder where all generated documents are saved”

[i] Pro Tip: Use a folder in your cloud (Dropbox, Google Drive) so your in-
voices are automatically backed up and accessible from anywhere.

[!] Important: You must choose a document folder before you can export
PDFs. Without a document folder, an error message appears on export:

Document settings missing
“The document folder has not been conÆgured. Please conÆg-
ure the settings before exporting.”

• Open Settings: Opens the settings page
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Figure 280: Error message on export without document folder

Document Name Pattern (optional)

Determine how exported PDF Æles are named and organized.

Default: Empty (standard naming: {docu-
ment_type}_{document_number})
Available parameters:

You can use the following placeholders to dynamically generate Æle names:

Parameter Description Example

{tenant} Company name of the tenant TechVision_GmbH
{customer} Company name of the customer Doe_GmbH
{year} Year (4 digits) 2025
{month} Month (2 digits) 11
{day} Day (2 digits) 16
{date} Full date (YYYYMMDD) 20251116
{document_type} Document type Invoice, Quote, Reminder
{document_number} Document number RE-2025-1, Q-2025-1

Figure 281: Enter a document name pattern

Note text:

“Pattern for organizing documents. If empty, Æles are named
as {document_type}_{document_number} (Invoice_RE-
2025-1.pdf)
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Available parameters: {tenant}, {customer}, {year}, {month},
{day}, {date}, {document_type}, {document_number}

Examplepattern: {customer}/Invoices/{date}_{document_type}_{document_number}_{tenant}
Result: Doe_GmbH/Invoices/20251116_Invoice_RE-2025-
1_MyCompany.pdf”

Placeholder: “Leave empty for default: {docu-
ment_type}_{document_number}”

Examples for Document Name Patterns

Example 1: Default (leave empty) Pattern: (empty)

Result:

Invoice_RE-2025-1.pdf
Quote_Q-2025-1.pdf
Reminder_M-2025-1-L1.pdf

Figure 282: Default document names

Example 2: Organized by customer Pattern: {cus-
tomer}/{document_type}_{document_number}
Result:

Doe_GmbH/Invoice_RE-2025-1.pdf
Doe_GmbH/Quote_Q-2025-1.pdf
Acme_Corporation/Invoice_RE-2025-2.pdf
Folder structure:

Document folder/
├── Doe_GmbH/
│ ├── Invoice_RE-2025-1.pdf
│ └── Quote_Q-2025-1.pdf
└── Acme_Corporation/
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└── Invoice_RE-2025-2.pdf

Figure 283: Documents sorted by customer

[i] Pro Tip: Ideal if you want all documents (invoices, quotes, reminders)
for each customer in one place.

Example 3: Organized by year and document type Pattern:
{year}/{document_type}/{document_number}_{customer}
Result:

2025/Invoice/RE-2025-1_Doe_GmbH.pdf
2025/Invoice/RE-2025-2_Acme_Corporation.pdf
2025/Quote/Q-2025-1_Doe_GmbH.pdf
Folder structure:

Document folder/
└── 2025/

├── Invoice/
│ ├── RE-2025-1_Doe_GmbH.pdf
│ └── RE-2025-2_Acme_Corporation.pdf
└── Quote/

└── Q-2025-1_Doe_GmbH.pdf
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Figure 284: Documents sorted by year and type

[i]ProTip: Ideal for year-end closing and archiving – all invoices for a year
are in one folder.

Example 4: With full date Pattern: {cus-
tomer}/Invoices/{date}_{document_type}_{document_number}_{tenant}
Result:

Doe_GmbH/Invoices/20251116_Invoice_RE-2025-
1_TechVision_GmbH.pdf
Doe_GmbH/Invoices/20251117_Invoice_RE-2025-
2_TechVision_GmbH.pdf
Acme_Corporation/Invoices/20251116_Invoice_RE-2025-
3_TechVision_GmbH.pdf

Figure 285: Documents with full date
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[i] Pro Tip: Ideal if you create multiple invoices per day – the date helps
with chronological sorting.

Pattern Validation

The document name pattern must contain both placeholders {docu-
ment_type} and {document_number}, otherwise an error message ap-
pears:

“Pattern must contain both placeholders {document_type} and
{document_number}”

Figure 286: Error message for invalid pattern

Why?

These two placeholders are mandatory to guarantee unique Æle names.
Without them, Æles could be overwritten.

Invalid examples: - {customer}/{date} (missing {document_type}
and {document_number}) - {year}/{month}/{customer} (missing
{document_type} and {document_number})
Valid examples: - {document_type}_{document_number} (Minimal) -
{customer}/{document_type}_{document_number} (With customer)
- {year}/{document_type}/{document_number}_{customer} (With
year and customer)

[i] Pro Tip: Test your pattern by exporting a test invoice – this way you
immediately see if the folder structure Æts.

Special Characters in Parameters

If company or customer names contain special characters (e.g., &, /, \),
they are automatically replaced with underscores (_) to avoid Æle name er-
rors.
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Examples:

Original name In Æle name

Miller & Co. GmbH Miller___Co__GmbH
A/B Testing GmbH A_B_Testing_GmbH
Tech\Vision Tech_Vision

Figure 287: Special characters are replaced with underscores

GoBD Archive (Archive Root)

For GoBD functions such as Audit log export, Z3 export, and DATEV ex-
port, the application uses a separate document archive.

Setting: - Archive Root: Main folder for the GoBD-compliant document
archive

Usage: 1. Open Settings 2. Find Archive Root 3. Click Choose directory
4. Select an empty directory (or create a new one)

Notes: - The archive folder uses a Æxed, GoBD-compliant structure (ten-
ant/year/month/…) - If you change the archive location, the application can
migrate existing Æles or you can start fresh

Changing the archive location (Archive migration) If you change an
Archive Root that has already been used, the application can offer a mi-
gration.

Dialog title: Archive Location Changed
Options in the dialog: - Move Files: Copies the existing archive Æles to
the new location (progress is shown in the dialog Migrating Archive).
- Start Fresh: Keeps existing Æles at the old location and uses the new
location for future exports.

Note: - If there is not enough disk space, the application disables Move
Files and shows a corresponding warning.
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[i] Tip: Place the archive root on storage that is backed up regu-
larly (e.g., NAS/backup drive).

Write Protection (WORM)

Write protection (WORM = Write Once Read Many) protects archived Æles
from accidental modiÆcations.

Setting: -Write protection (WORM): If enabled, archived documents are
set to read-only after export

Important notes: - Enabling/disabling can lock/unlock existing archive
Æles and is recorded in the audit log - If write protection is disabled, you
are responsible for storing archived documents in an immutable way

[!] Important: Before enabling, verify that your archive storage
supports meaningful write protection.

DATEV (Booking Batch Export)

For the DATEV export (File → Export DATEV (Buchungsstapel)...),
DATEV parameters must be conÆgured in settings.

Settings (DATEV): - Advisor number: DATEV number of your tax advisor
(a default value may be possible) - Client number: Provided by your tax
advisor (required for export) - Revenue account: Default account for post-
ings (e.g., 8400/8300) - Export encoding: Character encoding for the ex-
port Æle (ISO-8859-1 for older DATEV versions) - Fiscal year start: Start of
your Æscal year (often January 1st)

Why Æscal year start matters: - The export period must not span across
two Æscal years. The application uses this setting to validate your selection.

S3-Compatible Archive Storage

As an alternative to the local Ælesystem, you can conÆgure an S3-
compatible storage backend for the GoBD archive. This is useful if you
have a NAS with S3 support or want to use a cloud object storage service
for compliance purposes.

[i] Recommendation: Test your conÆguration with a non-
production document Ærst, then verify the archive Æles are visi-
ble in your S3 bucket before relying on this setup in production.

253



When to Consider S3 Storage

• You have a NAS device (e.g., Synology, QNAP) that exposes an S3-
compatible API

• Your organization requires off-site archiving in cloud object storage
• You want the archive to be accessible frommultiple computers

ConÆguration Fields To enable the S3 backend, open Settings → Docu-
ments → Archive Backend and select S3 Compatible:

Field Description

Endpoint URL URL of the S3-compatible service (e.g.,
https://s3.eu-central-
1.amazonaws.com or your NAS address)

Bucket name The name of the S3 bucket to use for the
archive

Access key S3 access key ID
Secret key S3 secret access key
Region Region of the bucket (e.g., eu-central-1;

may be optional for self-hosted services)

Figure XX: S3-compatible archive backend conÆguration

[i] Recommendation: Test your conÆguration with a non-production doc-
ument Ærst, then verify the archive Æles are visible in your S3bucket before
relying on this setup.
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9.6 Updates
Automatically Check for Updates

Enable or disable automatic update checking on application start.

Default: Enabled (recommended)

Enable/Disable:

1. Click the switch next to “Automatically check for updates”
2. The setting is saved immediately

Figure 288: Enable or disable automatic update checking

Note text: “Automatically check for new application versions on startup”

What Happens with Update Checking Enabled?

1. Onstartup, the application checks in thebackground if anewversion
is available

2. If a new version is available, a notiÆcation appears: >Update avail-
able
> “A new version (v1.2.0) is available. Do you want to download it
now?” > > - Download: Opens the download page > - Later: Close
dialog

Figure 289: NotiÆcation when update is available

3. If no new version is available, no notiÆcation appears (silent check)

[i]ProTip: Keepautomatic update checking enabled tonotmiss important
bug Æxes or new features.

Manual Update Check

You canmanually check for updates at any time:
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1. ClickHelp in the top menu bar
2. Select Check for updates
3. A dialog shows the result:

• Update available: Shows version number and download link
• No updates: “You are using the latest version”

Figure 290: Manual update check via Help menu

9.7 Email
This section covers the application-wide conÆguration for sending emails.

[!] Important: To send documents via email from Invoicer, you must con-
Ægure an email sending method Ærst.

SMTP (Outgoing Mail)

Use SMTP settings to deÆne how Invoicer sends outgoing emails.

Typical settings include: - SMTP server/host and port - Security (e.g.,
TLS/STARTTLS) -Authentication (username/password) - Sendernameand
sender email address

Figure 291a: SMTP settings for outgoing mail
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IMAP (Copy to Sent Folder)

If enabled, Invoicer can copy the sent email to your mail account’s Sent
folder via IMAP.

Typical settings include: - IMAP server/host and port - Security (TLS) - Au-
thentication - Sent folder name/path (provider-speciÆc)

Figure 291b: IMAP settings for copying to the Sent folder

[i] Pro Tip: If your provider uses a non-standard Sent folder name, you
may need to enter it exactly as shown by your mail client (e.g., “Sent”,
“Gesendet”, “Sent Items”).

Test ConÆguration

Use the test actions in this settings section to validate your conÆguration
before you start sending real documents.

9.8 Document Emails
Document emails are based on templates so you don’t have to rewrite the
subject and message body for every document.

Templates (Subject & Body)

You can deÆne: - A subject template - A body template (Markdown)

Templates can contain tokens/placeholders that are replaced with real
values (e.g., customer name, document number).
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Figure 291c: Edit subject and body templates

Token List and Insertion

Invoicer provides a token list. You can insert tokens into the last active
input Æeld (subject or body).

[!] Important: Unknown tokens are shown as warnings. Fix them before
sending to avoid placeholders leaking to the customer.

Preview

Use Preview to render the Ænal email (including token replacement) be-
fore sending.

Language Variants

You can maintain language-speciÆc templates (e.g., German/English) so
customers receive emails matching their document language.

9.9 User Management
If enabled for your installation and your account has the required permis-
sions, you canmanage users and roles.

Typical actions: - Create users - Assign roles/permissions - Set or clear
passwords - Delete users (with conÆrmation)
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Figure 291d: User management screen

9.10 Error Handling
If an error occurs while saving settings, an error message appears above
the settings card.

Example:

Error saving settings
“Settings could not be saved. Please try again.”

• Try again: Retry
• ×: Close error message

Figure 291: Error message for save problems

[i] Pro Tip: If save errors occur, check whether the application
has write permissions for the database Æle: - Linux: chmod +w
~/.local/share/agynamix-invoicer/invoicer_db.db - ma-
cOS: chmod +w ~/Library/Application\ Support/agynamix-
invoicer/invoicer_db.db

9.11 Discard Invalid Settings
If you enter invalid settings (e.g., a document name pattern without {doc-
ument_type} and {document_number}), a dialog appears when leaving
the settings page:
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Invalid settings
“Thedocument namepattern contains validation errors. Do you
want to discard the invalid settings?”

• Discard invalid settings: Undo changes
• Continue editing: Stay in form

Figure 292: Dialog for invalid settings

[i] Pro Tip: ChooseDiscard invalid settings to automatically return to the
last valid conÆguration.

9.12 Reset Settings
There is currently no one-click “reset all settings” button in the user inter-
face.

If you need to reset your settings, please contact support:

Email: support@agynamix.de
Subject: “Settings Reset Request”

Please include your operating system and application version (seeHelp →
About) so support can assist you quickly.

[!] Note: Resetting settings requires access to the internal
database and is not something we recommend users attempt
manually, as an incorrect change could affect your invoice data.
Our support team can guide you safely.

9.13 Practical WorkÇows
WorkÇow 1: Initial Setup (5–10minutes, one-time)

Goal: ConÆgure all important settings for optimal use.
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Steps:

1. Choose design (30 seconds)
• Open Settings
• Choose System Default (recommended)

2. ConÆgure backup (3 minutes)
• Frequency: Daily (recommended)
• Backup directory: Choose a cloud folder (e.g., ~/Drop-
box/Backups/Invoicer/)

• Backup retention: 1 Month (recommended)
3. Choose document folder (2 minutes)

• Document folder: Choose a cloud folder (e.g., ~/Drop-
box/Invoices/)

4. Document name pattern (optional) (2 minutes)
• If desired: {customer}/Invoices/{document_type}_{document_number}
• Otherwise: Leave empty (default)

5. Enable updates (10 seconds)
• Automatically check for updates: Enabled (recommended)

Result: All settings are conÆgured, automatic backups are enabled, docu-
ments are saved in the cloud.

[i] Pro Tip: Test the backup immediately by closing the application and
checking in the backup directory if a backup Æle was created.

WorkÇow 2: Backup Strategy for Important Data (10 minutes)

Goal: Maximum data security through cloud backups and local copies.

Steps:

1. ConÆgure cloud backup (3 minutes)
• Open Settings
• Frequency: Daily
• Backup directory: ~/Dropbox/Backups/Invoicer/ (or Google
Drive)

• Backup retention: 1 Month
2. Local backup to external drive (5 minutes)

• Close the application
• Open File → Create Backup…
• Choose a folder on an external drive (e.g., /Vol-
umes/Backup/Invoicer/)

• Save the backup
3. Document backup plan (2 minutes)

• Note:
– Cloud backup: Daily automatic
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– External drive: Monthly manual (e.g., on the 1st of each
month)

Result: You have double security – automatic cloud backups (daily) and
manual backups on external drive (monthly).

[*]WorkÇow Tip: Create a calendar entry “Invoicer Backup” on the 1st of
each month as a reminder for the manual backup to external drive.

WorkÇow 3: Document Organization by Customer (5 minutes)

Goal: All documents for a customer in one folder.

Steps:

1. Choose document folder (1 minute)
• Open Settings
• Document folder: ~/Documents/Invoices/

2. Set document name pattern (2 minutes)
• Pattern: {customer}/{document_type}_{document_number}

3. Export test invoice (2 minutes)
• Create a test invoice for customer “Doe GmbH”
• Export as PDF
• Check if folder ~/Documents/Invoices/Doe_GmbH/ was cre-
ated

Result: All documents are organized by customer – each customer has
their own folder.

Example folder structure:

~/Documents/Invoices/
├── Doe_GmbH/
│ ├── Invoice_RE-2025-1.pdf
│ └── Quote_Q-2025-1.pdf
└── Acme_Corporation/

└── Invoice_RE-2025-2.pdf
[i] Pro Tip: If you send documents to customers, you can simply send the
entire customer folder as a ZIP archive (contains all invoices, quotes, etc.).

WorkÇow 4: Automatically Switch Design by Time of Day (1 minute)

Goal: Use light design during the day, automatically switch to dark design
in the evening.

Steps:
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1. Enable system default (30 seconds)
• Open Settings
• Design: Choose System Default

2. Check operating system setting (30 seconds)
• macOS: System Preferences → Appearance → Automatic
• Windows10/11: Settings→Personalization→Colors→Choose
mode: Automatic

• Linux (GNOME): Settings → Appearance → Automatic

Result: The application automatically switches between light and dark de-
pending on time of day (e.g., dark from 8 PM).

[i] Pro Tip: If your operating system doesn’t support automatic switching,
you can manually switch between light and dark in the application at any
time.

9.14 Pro Tips for Settings
[»] Use system default for design: Enable System Default instead of
manually choosing Light/Dark – this way the application automatically
switches with your operating system.

[i]Dailybackups incloud: UseDaily+cloud folder (Dropbox/GoogleDrive)
for double security – this way your data is protected even if the hard drive
fails.

[*] Backup retention 1month: Use 1Month instead of “Keep” – this gives
you enough backups to restore without taking up too much storage space.

[!] Document folder before Ærst export: ConÆgure the document folder
before the Ærst PDF export – otherwise an error message appears.

[~] Document name pattern with customer: Use {cus-
tomer}/{document_type}_{document_number} for better organi-
zation – all documents for a customer are in one folder.

[i] Date in Æle name for chronology: If you create multiple invoices per
day, use {date}_{document_type}_{document_number} for chrono-
logical sorting.

[*] Keep update checking enabled: Keep automatic update checking en-
abled to not miss bug Æxes or new features.

[»] Don’t disable backup reminder: If you use “None” backups, don’t dis-
able the reminder – it protects against accidental data loss.

[i] External drive for extra security: Additionally create amanual backup
to external drive monthly – this protects you in case of cloud outage or ac-
count problems.
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[*] Test document name pattern: Test your pattern with a test invoice be-
fore exporting many documents – this avoids confusing folder structures.

9.15 Server (Operating Mode)
The Server section lets you conÆgure how this installation operates in a
multi-computer setup. You can switch between three operating modes:

• Standalone— single-machine setup (default). No network sharing.
• Host (Server) — this computer acts as the central server for other
clients.

• Client—this computer connects to ahost and synchronizesdata from
it.

To change themode, clickChangeMode and follow thewizard. Thewizard
guides you through each step, including entering the host URL and authen-
tication token when switching to Client mode, or conÆguring the server
bind address and port when switching to Host mode.

Note: Switching to Host mode requires an Ultimate license.
Client mode does not require a license — the client inherits the
host’s license tier.

For a full explanation of each mode, setup instructions, headless server
operation, and troubleshooting, see Chapter 12: Operating Modes.

9.16 Admin Area
The Admin area is a dedicated section of the sidebar that gives you access
to system-wide conÆgurations affecting how documents are numbered
and how taxes are calculated. Think of it as the “back ofÆce” of your In-
voicer – settings you usually conÆgure once at the start and only revisit
when your business situation changes.

To open the Admin area, click Admin in the left sidebar.
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Figure XX: Admin area in the sidebar

The Admin area has two sub-sections:

• Tax Rules – deÆne which tax rates apply to which types of transac-
tions and customers

• NumberRanges – control how document numbers are generated for
each document type

9.17 Tax Rules
What Is a Tax Rule?

A tax rule is a named conÆguration that combines a tax ratewith a descrip-
tion of when it applies. Unlike a bare tax rate (e.g., “19 %”), a tax rule ex-
plains the purpose: “Standard VAT (Germany, 19 %)”, “Reduced VAT (Ger-
many, 7 %)”, or “Reverse Charge (EU B2B)”.

Using tax rules – rather than entering a percentage by hand each time –
keeps your documents consistent and makes the logic transparent to you
and any auditor reviewing your records.
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Built-In Tax Presets

AGYNAMIX Invoicer ships with presets for the most common scenarios in
the DACH region:

Country Rule Name Rate

Germany Standard VAT 19 %
Germany Reduced VAT 7 %
Austria Standard VAT 20 %
Austria Reduced VAT 10 %
Switzerland Standard VAT 7.7 %
All Tax-free / Exempt 0 %

These presets are shown in the Tax Rules list in the Admin area.

Figure XX: The tax rules list with built-in presets

Automatic Tax Selection Based on Customer Location

When you create a new line item in a document, AGYNAMIX Invoicer can
automatically suggest the correct tax rule based on the customer’s country.
For example:
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• Customer is inGermany→ “Standard VAT (19 %)” is suggested
• Customer is in theEU(business, VATIDpresent)→“ReverseCharge”
is suggested

• Customer is outside the EU→ “Tax-free / Export” is suggested

This automatic suggestion reduces errors and saves time, especially if you
work with international customers.

Create a Custom Tax Rule

If none of the presets Æt your situation (e.g., you sell digital services to EU
consumers and need the customer’s local VAT rate), you can create your
own rule:

1. In the Admin area, click Tax Rules
2. Click + New
3. Fill in the Æelds:

• Name: A clear description (e.g., “Reverse Charge EU”)
• Tax rate: The percentage (e.g., 0 for Reverse Charge)
• Note / label: Optional text that appears on the invoice (e.g., “VAT
liability transfers to the recipient”)

• Country / scope: Which country or situation this rule applies to
4. Click Save

Figure XX: Dialog for creating a custom tax rule
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How Tax Rules Interact with Customers and Documents

• On the Customer card: You can set a default tax rule for a speciÆc
customer. This overrides the automatic suggestion when you create
a document for that customer.

• In a Document: Each line item has its own tax rule, pre-Ælled from
the customer default or the general suggestion. You can manually
change it per line item.

• On the PDF: The tax breakdown on the printed invoice reÇects ex-
actly the rules used.

Common Scenarios in Plain Language

Situation Which rule to use

German customer,
standard goods/services

Standard VAT (Germany, 19 %)

German customer,
food/books/cultural

Reduced VAT (Germany, 7 %)

Business customer in
another EU country (has
VAT ID)

Reverse Charge

Customer in a non-EU
country

Tax-free / Export

Internal note line or
deposit

Tax-free / Exempt

[i]Pro Tip: Set the default tax rule on each customer card once – youwon’t
have to think about it when creating documents for that customer again.

[!] Important: Tax rules affect the amounts shown on legal documents. If
you are unsure which rule applies to your situation, consult your tax advi-
sor.

9.18 Number Ranges
What Are Number Ranges?

Everydocument inAGYNAMIX Invoicer receives aunique, sequential num-
ber (e.g., RE-2024-001). Number Ranges let you control the exact format
and counter for each document type separately.

A number range deÆnes:

• The preÆx (e.g., RE for invoices, ANG for quotes)
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• Whether and how the year is embedded in the number
• The current counter (starting point)
• Whether the counter resets automatically at the start of each year

Opening Number Ranges

1. Click Admin in the left sidebar
2. ClickNumber Ranges

Figure XX: The Number Ranges screen with one range per document type

Document Types and Their Ranges

Each of the following document types has its own number range:

Document Type Example Default Pattern

Invoice RE-{year}-{counter}
Quote ANG-{year}-{counter}
Payment Reminder MAH-{year}-{counter}
Correction Invoice KOR-{year}-{counter}

Fields of a Number Range
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Field Description

PreÆx Characters at the start of the number (e.g., RE)
Year pattern How the year appears (e.g., {year} for 4

digits, {year2} for 2 digits, empty for no year)
Counter The current number (increments with each

new document)
Year rollover If enabled, the counter resets to 1 at the start

of each calendar year

Live Preview

As you change any Æeld, a live preview shows exactly how the next doc-
ument number will look (e.g., RE-2025-001). This helps you conÆrm the
format before saving.

Figure XX: Live preview shows the resulting document number immediately

Year-End Rollover

Rollover enabled: At the start of each year, the counter automatically re-
sets to 1. The Ærst invoice of 2026 would be RE-2026-001 regardless of
howmany invoices you created in 2025.
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Rollover disabled: The counter never resets. This gives you a single as-
cending sequence across all years (e.g., invoice 4,500 in year 3 of using the
application).

Which to choose? Most users in the DACH region prefer rollover enabled,
as it makes the year clearly visible in every invoice number and matches
common bookkeeping conventions.

Best Practices for Naming Schemes

• Keep preÆxes short (2–3 characters): RE not RECHNUNG
• Include the year: The year in thenumbermakes it immediately clear
which Æscal year a document belongs to

• Start counters at 1 (or a round number like 1000 if you want to ob-
scure volume)

• Be consistent: Once you publish documents under a scheme, avoid
changing it mid-year

[!] Important: Consequences of Changing a Number Range

Once invoices have been published under a number scheme:

• Changing the preÆx or year pattern will create a gap or inconsistency
in the numbering sequence

• Under GoBD guidelines, invoice numbers must be sequential and
gap-free

• Recommendation: Only change number ranges at the start of a new
Æscal year, or before publishing the Ærst document in a series

[i] Pro Tip: Use the live preview to double-check the format before saving
– you cannot undo the counter value once it has been incremented by a
published document.

Continue with Chapter 10: GoBD Compliance

10. GoBD Compliance
GoBD compliance (Principles for the proper management and storage of
books, records, and documents in electronic form as well as for data ac-
cess) is a central component of the application. It ensures that your busi-
ness transactions are documented in accordance with the law, archived
immutably, and can be traced at any time for tax audits.

In this chapter you will learn: -What GoBDmeans and why it’s important
- Which requirements the application fulÆlls - How the audit log works -
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How to create exports for tax audits -How to verify the integrity of your
data

Figure 293: GoBD compliance features protect your data

10.1What Is GoBD?
DeÆnition

GoBD are binding guidelines from the Federal Ministry of Finance for elec-
tronic bookkeeping. They regulate how companies and self-employed in-
dividuals must digitally store their business data so they are recognized
under tax law.

Goal: Ensure that digital records are complete, correct, timely, traceable,
and immutable.

Why Is GoBD Important?

During a tax audit (operational audit), youmust be able to prove: - That all
invoices were recorded correctly - That no invoices were changed retroac-
tively - That all business transactions are completely documented - That
data was archived tamper-proof

[!] Important: Violations of GoBD can lead to: - Estimates by the tax ofÆce
(often to your disadvantage) - Tax back paymentswith interest - Fines for
gross negligence

[i] Pro Tip: The application fulÆlls all GoBD requirements automatically –
you don’t need to worry about anything as long as you follow the rules in
this chapter.
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10.2 The Seven GoBD Principles
GoBD deÆnes seven principles that your accounting systemmust fulÆll:

1. Orderliness

Requirement: The systemmust be documented (process documentation).

How the application fulÆlls this: - This user manual serves as process
documentation - All business processes are clearly deÆned - Changes are
documented in the audit log

2. Completeness

Requirement: All business transactions must be recorded, no gaps in the
audit log.

How the application fulÆlls this: - All invoices, quotes, payments are
logged - Gap-free numbering (RE-2025-1, RE-2025-2, RE-2025-3, …) -
Deleted drafts are logged to avoid gaps

3. Accuracy

Requirement: Data must be correct and complete.

How the application fulÆlls this: - Validation of all required Æelds (cus-
tomer, amount, date, tax number) - Automatic calculation of VAT - Source
documents (PDFs) are stored unchanged

4. Timely Bookings and Records

Requirement: Business transactions must be recorded promptly.

How the application fulÆlls this: - Publication timestamp is set automati-
cally - Audit log entries contain precise timestamps (millisecond accuracy)
- No manual date changes possible

5. Immutability

Requirement: Original data may not be changed after publication.

How the application fulÆlls this: - Published invoices are immutable
(Status: Published → no more editing) - Changes only via correction in-
voices (new invoice with negated line items) - Cryptographic hash chain
prevents undetected manipulation
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Figure 294: Published invoices cannot be edited

[i] Pro Tip: If you discover an error in a published invoice, use Create cor-
rection invoice – this way the original invoice is preserved and the change
is traceable.

6. Traceability

Requirement: Business transactions must be traceable from start to Æn-
ish.

How the application fulÆlls this: -Audit logdocuments all status changes
- Transaction IDs link related events (e.g., invoice published + PDF ex-
ported) - Assignment to customers, tenants, periods

Figure 295: The audit log shows all changes

7. Auditability

Requirement: Tax auditors must be able to review the data.

How the application fulÆlls this: - Export function for tax audits (CSV
+ PDFs) - VeriÆcation function checks data integrity - Access to SQLite
database (if required by auditor)
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10.3 The Audit Log
What Is the Audit Log?

The audit log is an immutable list of all business transactions in the appli-
cation. It documents: - Who did what when - Which invoices were pub-
lished, paid, canceled -Which PDFs were exported (with Æle hash) -Which
payments were recorded

Storage location: Audit log database (SQLite). The database Æle is stored
at: - Linux: ~/.local/share/agynamix-invoicer/invoicer_db.db
- macOS: ~/Library/Application Support/agynamix-
invoicer/invoicer_db.db - Windows: %LOCALAPPDATA%\agynamix-
invoicer\invoicer_db.db

How Does the Audit LogWork?

Each business transaction is stored as an audit log entry:

Field Description Example

Sequence
number

Sequential number (0, 1, 2, 3,
…)

42

Timestamp Time of event (milliseconds) 2025-11-16
14:35:22.123

User Who performed the action john.doe
Tenant ID Which tenant the transaction

belongs to
tenant-123

Event type Type of business transaction Invoice
published

Entity type What was changed Sales document
Entity ID Unique ID of the object doc-001
Document type Invoice, Quote, Reminder, … Invoice
Document
number

Invoice number RE-2025-1

State before Previous status Draft
State after New status Published
Description Readable description “Invoice published”
Event data Additional information (JSON) {"total_amount_cents":

119000}
Previous hash Hash of previous entry a1b2c3d4e5f6...
Current hash Hash of this entry b2c3d4e5f6a7...
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Figure 296: Example entries in audit log

Cryptographic Hash Chain

Each audit log entry contains a cryptographic hash (SHA-256) that is cal-
culated from: 1. All important Æelds of the entry (sequence number, times-
tamp, event type, document number, …) 2. The hash of the previous entry

Advantage: Manipulations are detected immediately because the hash
chain breaks.

Example:

Entry 1 (Genesis):
- Hash: a1b2c3... (first entry, no predecessor)

Entry 2:
- Previous hash: a1b2c3... (hash of Entry 1)
- Hash: b2c3d4... (calculated from Entry 2 + a1b2c3...)

Entry 3:
- Previous hash: b2c3d4... (hash of Entry 2)
- Hash: c3d4e5... (calculated from Entry 3 + b2c3d4...)

If someone changes Entry 2 retroactively: - The hash of Entry 2 changes
(e.g., from b2c3d4... to x9y8z7...) - Entry 3 expects b2c3d4... as
previous hash - VeriÆcation fails: Manipulation detected!
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Figure 297: The hash chain protects against manipulation

[i] Pro Tip: The hash chain works like a blockchain – any change to an
earlier entry breaks the entire chain.

What Is Logged?

[+] Always logged (business transactions): - Invoice published (Draft →
Published) - Invoice sent (Published→Sent) - Payment recorded (partial or
complete) - Invoice canceled - PDF/XML exported (with Æle hash) - Correc-
tion invoice created and published - Quote accepted/rejected - Reminder
sent - Timesheet invoiced - Draft deleted (for gap-free chain)

❌Never logged (internal operations): - Draft created - Draft saved (while
status = Draft) - User interface interactions - Read operations (queries)

Why are drafts not logged?

GoBD principle: Only log business transactions.

• Draft = preparation: Drafts are internal work, not business transac-
tions

• No tax obligation: Drafts create no tax-relevant obligations
• Frequent changes: Drafts are often saved – logging every savewould
be noise

• Publication = transaction starts: Only with publication does the
business transaction begin
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Exception: Draft deletion is logged to avoid gaps in the chain.

XRechnung Export: Two Separate Entries

If you export an invoice asXRechnung (e-invoice), two separate audit log
entries are created:

1. DOCUMENT_EXPORTED_PDF: For the PDF Æle with its own hash
2. DOCUMENT_EXPORTED_XML: For the XML Æle with its own hash

Why two entries? - Each Æle is an independent artifact - Each Æle needs
its own hash for integrity check - Completeness: Both Æles are explicitly
tracked

Example: Export of invoice RE-2025-42with XRechnung:

Sequence 1234: DOCUMENT_EXPORTED_PDF - RE-2025-
42.pdf (Hash: a1b2c3...)
Sequence 1235: DOCUMENT_EXPORTED_XML - RE-2025-
42.xml (Hash: d4e5f6...)

10.4 View Audit Log
Display Audit Log for a Document

Each published invoice, quote, or reminder has its own audit log.

Access:

1. Open the document list (Documents in sidebar)
2. Select a published document
3. Click Audit log (or the corresponding icon)

Figure 298: Open the audit log of a document
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Display:

The audit log shows all events for this document in chronological order: -
Sequence number: Sequential number in the entire chain - Timestamp:
When the event occurred - User: Who performed the action - Event type:
Type of business transaction - Description: Readable description - State
before/after: Status transitions

Figure 299: Audit log of a document

[i]ProTip: If you seemultiple events for a document (e.g., publication, pay-
ment, export), they are linked via the transaction ID.

Export Complete Audit Log

For tax audits, you can export the complete audit log of all tenants.

See Section 9.5: Export for tax audits

10.5 Export for Tax Audits
Why an Export?

During an operational audit, you must grant the tax auditor access to your
business data. With the export function, you create a GoBD-compliant
archive that contains: - All audit log entries (CSV format) - All exported
PDFs and XMLs - VeriÆcation data (JSON) for integrity check - Instructions
for the auditor (README.txt)
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Create Export

Steps:

1. Click File in the top menu bar
2. Select Export audit log…

Figure 300: Export audit log via File menu

3. A dialog opens: Export audit log

Figure 301: Export dialog for audit log

4. Select tenant (if you use multiple tenants)
• Dropdownmenu shows all tenants
• Select the tenant you want to export

5. Select period
• From: Start date (e.g., 01/01/2025)
• To: End date (e.g., 12/31/2025)
• Only audit log entries in this period are exported
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6. Choose storage location
• Click Choose directory
• Select a folder (e.g., ~/Documents/Tax-Audit/2025/)
• The export is saved as a ZIP Æle

7. Start export
• Click Export
• A progress bar shows export status

Figure 302: Export progress indicator

8. Export completed
• A success message appears
• The ZIP Æle was saved in the selected folder

Figure 303: Export completed successfully

[i] Pro Tip: Create monthly exports for your accounting – this way you
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always have an archive ready.

Export Package Structure

The exported ZIP Æle has the following structure:

gobd_export_MyCompany_202511.zip
├── README.txt # Instructions for auditor (German)
├── audit_log_202511.csv # All audit log entries (CSV)
├── audit_log_202511_verification.json # Verification data (JSON)
└── documents/ # All exported documents

├── invoices/
│ ├── RE-2025-1.pdf
│ ├── RE-2025-1.xml # If XRechnung
│ └── RE-2025-2.pdf
├── quotes/
│ └── Q-2025-1.pdf
├── corrections/
│ └── CORR-2025-1.pdf
└── reminders/

└── M-2025-1-L1.pdf

Figure 304: Contents of export package

CSV Format

The Æle audit_log_202511.csv contains all audit log entries in CSV for-
mat (UTF-8 with BOM, separator: semicolon):

Columns: - sequence_number: Sequence number - timestamp: Times-
tamp (epoch milliseconds) - created_by: User - tenant_id: Tenant
ID - event_type: Event type - entity_type: Entity type - entity_id:
Entity ID - transaction_id: Transaction ID (groups related events) -
document_type: Document type - document_number: Document num-
ber - state_before: Status before - state_after: Status after - de-
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scription: Description - event_data_json: Event data (JSON) - pre-
vious_hash: Hash of previous entry - current_hash: Hash of this entry

Example row:

1,1698753600000,john.doe,tenant-123,DOCUMENT_PUBLISHED,SALES_DOCUMENT,doc-001,txn-001,INVOICE,RE-2025-1,DRAFT,PUBLISHED,"Invoice published","{""total_amount_cents"":119000}",null,a1b2c3d4e5f6...
[i] Pro Tip: The CSV Æle can be opened with Excel, LibreOfÆce Calc, or spe-
cialized audit software.

VeriÆcation JSON

The Æle audit_log_202511_verification.json containsmetadata for
integrity check:

Contents: - Export metadata: Date, tenant, user - Hash chain info: First
hash, last hash - Document hashes: SHA-256 hashes of all PDFs/XMLs -
Statistics: Number of invoices, payments, corrections

Example:

{
"export_metadata": {

"export_date": "2025-11-16T14:35:22Z",
"tenant_name": "MyCompany GmbH",
"exported_by": "john.doe",
"date_range": {

"from": "2025-11-01",
"to": "2025-11-30"

}
},
"chain_integrity": {

"first_entry_hash": "a1b2c3d4e5f6...",
"last_entry_hash": "x9y8z7w6v5u4...",
"total_entries": 1234

},
"document_hashes": {

"RE-2025-1.pdf": "d4e5f6a7b8c9...",
"RE-2025-1.xml": "e5f6a7b8c9d0...",
"Q-2025-1.pdf": "f6a7b8c9d0e1..."

},
"statistics": {

"invoices": 42,
"quotes": 12,
"payments": 38,
"corrections": 2

}
}
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README for Auditors

The Æle README.txt contains German instructions for tax auditors:

Contents: - What is contained in this archive - How to read the CSV Æle -
How to verify the hash chain - Contact information for inquiries

[i] Pro Tip: If the auditor has questions, refer them to this user manual
(Chapter 9).

10.6 Verify Audit Log
Why Verify?

VeriÆcation checks the integrity of the hash chain and ensures that: - No
audit log entries were changed retroactively - No entries were deleted - Se-
quence numbers are gap-free - All hashes are calculated correctly

When to verify? - Before an export for tax audits - Regularly (e.g., monthly)
for quality assurance - If you suspect manipulation

Verify Complete Chain

Steps:

1. Click File in the top menu bar
2. Select Verify audit log

Figure 305: Verify audit log via File menu

3. A dialog opens: Verify audit log
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Figure 306: VeriÆcation dialog

4. Select veriÆcationmode
• Complete chain: All entries (recommended)
• Date range: Only entries in a speciÆc period
• Sequence range: Only entries with speciÆc sequence numbers

5. Start veriÆcation
• Click Start veriÆcation
• A progress bar shows veriÆcation status

Figure 307: VeriÆcation running

6. Check result
• Success: All hashes match, no manipulation detected
• Failed: Hash chain is broken, manipulation detected
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Figure 308: VeriÆcation successful – no manipulation

Figure 309: VeriÆcation failed – manipulation detected

[i] Pro Tip: If veriÆcation fails, contact support immediately – a broken
hash chain indicates database corruption or manipulation.

Verify Export Archive

You can also verify an already exported archive (ZIP Æle).

Steps:

1. Click File in the top menu bar
2. Select Verify export archive…
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Figure 310: Verify export archive via File menu

3. A dialog opens: Verify export archive

Figure 311: Select an export archive

4. Select ZIP Æle
• Click Choose Æle
• Select an exported ZIP Æle (e.g.,
gobd_export_MyCompany_202511.zip)

5. Start veriÆcation
• Click Start veriÆcation
• The application:

– Unpacks the archive temporarily
– Reads audit_log_202511.csv
– Reads audit_log_202511_verification.json
– Checks all hashes
– Checks document hashes (PDFs/XMLs)
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Figure 312: VeriÆcation of export archive

6. Check result
• Success: Archive is intact, no manipulation
• Failed: Archive was modiÆed or is damaged

Figure 313: Export archive is intact

[i] Pro Tip: Verify export archives before handing over to tax auditors to
ensure they are complete and unchanged.
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10.7 Immutability: Why Invoices Cannot Be Edited
The Problem: Retroactive Changes

Imagine: - You publish an invoice: RE-2025-1 for €1,190.00 (incl. VAT) -
Your customer pays the invoice - Later you change the amount to €990.00
(to save taxes) - The tax ofÆce doesn’t detect the manipulation

Result: Tax evasion, Ænes, possibly imprisonment.

The Solution: Immutability

The application prevents retroactive changes through:

1. Status-based lock: Published invoices (status ≠ Draft) cannot be
edited

2. Audit log: All changes are logged
3. Hash chain: Manipulations break the cryptographic chain
4. Correction invoices: Changes only via new correction invoices

Figure 314: Published invoice cannot be edited

Create Correction Invoice

If you need to correct a published invoice:

Steps:

1. Open the invoice
2. Click Actions → Create correction invoice
3. A new invoice is created with:

• Negated line items (cancels original invoice)
• New document number (e.g., CORR-2025-1)
• Reference to original invoice

4. Publish the correction invoice
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5. Result: Original invoice remains preserved, change is traceable

Figure 315: Correction invoice with negated line items

[i] Pro Tip: Correction invoices are GoBD-compliant because they don’t
change the original invoice but create a new invoice with reference.

See Section 3.11: Create correction invoice (complete instructions)

10.8 Sequential Numbering
Why Gap-Free Numbering?

GoBD requires gap-free, sequential numbers for invoices so the tax ofÆce
can detect if invoices were hidden.

Example (GoBD-compliant):

RE-2025-1
RE-2025-2
RE-2025-3
RE-2025-4
Example (NOT GoBD-compliant):

RE-2025-1
RE-2025-2
RE-2025-4 ← Gap! Where is RE-2025-3?
RE-2025-5

How the Application Ensures This

1. Automatic numbering: Invoice numbers are automatically assigned
on publication (based on tenant’s number pattern)

2. Nomanual numbers: You cannotmanually change invoice numbers
3. Tenant-speciÆc sequences: Each tenant has its own number ranges

(MyCompany: RE-2025-1, YourCompany: RE-2025-1)
4. Audit log: Deleted drafts are logged to document gaps
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Avoid Gaps

Scenario: You create a draft RE-2025-3, delete it, and create a new draft.

What happens? - Drafts have no invoice numbers, only temporary IDs
(e.g., Draft-UUID-123) - Only on publication is an invoice number as-
signed - If you delete a draft, no gap is created

Result: Gap-free numbering guaranteed.

[i] Pro Tip: If you accidentally publish an invoice you don’t need, use Can-
cel – this way the number remains (as canceled) but no gap is created.

10.9 Retention Obligation
10-Year Rule

GoBD requires 10 years retention period for tax-relevant documents (§
147 Abs. 3 AO): - Start: End of the calendar year in which the invoice
was created - Example: Invoice from 11/16/2025 → Retention period un-
til 12/31/2035

Affected: - Invoices (issued and received) - Receipts (receipts, delivery
notes) - Booking documents - Audit logs

How the Application Supports This

1. Automatic calculation: Retentionperiod is calculatedonpublication
2. Delete prevented: Documents cannot be deleted while retention pe-

riod is active
3. Soft delete: If you want to delete a document, it’s only marked as

“deleted” but not physically removed
4. Export archive: Monthly exports secure data long-term

Figure 316: Retention period of an invoice
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Archiving Strategy

Recommended approach:

1. Monthly exports: Create a GoBD export archive every month (see
Section 9.5)

2. WORM storage: Store archives onWrite Once Read Manymedia:
• External hard drive (mount read-only)
• Cloud storage with Object Lock (AWS S3 Glacier, Google Cloud
Archival Storage)

• DVD-R/Blu-ray (only for small archives)
3. Verify: Check annually if archives are still readable and intact
4. Backup-backup: Keep second copy at different location (Ære protec-

tion)

[i] Pro Tip: Use cloud storage with 10-year retention guarantee (e.g., AWS
S3 Glacier Deep Archive) – this way you’re protected even with hard drive
failure.

10.10 Data Access for Tax Auditors (Z1, Z2, Z3)
The Three Access Levels

The tax ofÆce can require different access options during an operational
audit:

Access Level Description What you must provide

Z1 Direct access –
Auditor works
directly in your
system

Read access to database or
application

Z2 Mediated access
– You export
Æltered data for
auditor

GoBD export for speciÆc
period (see Section 9.5)

Z3 Data media
transfer
(Z3/GDPdU) –
Export as ZIP
archive

Z3/GDPdU export archives for
the requested period(s)

In practice: - Z2 is most common: You export data for the year being au-
dited - Z1 is rarer: Only for complex audits or suspicion of manipulation -
Z3 is very rare: Only for very large companies or forensic audits
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Z1: Direct Access

What youmust do:

1. Create database copy:
• Close the application
• Copy the database Æle:

– Linux: ~/.local/share/agynamix-
invoicer/invoicer_db.db

– macOS: ~/Library/Application Support/agynamix-
invoicer/invoicer_db.db

– Windows: %LOCALAPPDATA%\\agynamix-
invoicer\\invoicer_db.db

• Hand over the copy to the auditor (e.g., on USB stick)
2. Auditor opens database:

• With SQLite browser (e.g., DB Browser for SQLite)
• Or with specialized audit software (IDEA, ACL Analytics)

[i] Pro Tip: Create a backup before handover – this way you have a copy in
case the database is damaged.

Z2: Export Filtered Data

What youmust do:

1. Create a GoBD export for the period being audited (see Section 9.5)
2. Hand over the ZIP Æle to the auditor (e.g., on USB stick or via cloud

link)
3. The auditor opens the CSV Æle with Excel/LibreOfÆce or specialized

software

Advantages: - You retain control over your data (auditor has no access to
entire database) - Auditor can analyze data but not change it - Export is
portable and universally readable

Z3: Z3/GDPdU Export

What youmust do:

1. Open File→ Export Data (Z3)...
2. Select tenant and the requested time period
3. Start export and hand over the created ZIP Æle(s) to the auditor

[i] Hint: If the auditor requests multiple years/periods, create multiple ex-
ports accordingly.
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10.11 Frequently Asked Questions (FAQ)
Question 1: Can I change a published invoice?

Answer: No, that’s not GoBD-compliant. Use a correction invoice instead
(see Section 9.7).

Question 2: What happens if I delete the audit log?

Answer: The audit log is stored in the database and cannot be deleted via
the user interface. If you manually change the database (e.g., with SQLite
browser), you break GoBD compliance and risk tax back payments.

Question 3: Do I have to create an archive every month?

Answer: It’s recommended but not mandatory. For GoBD compliance,
it’s sufÆcient if you can create an archive during a tax audit. But monthly
archives are a good backup strategy.

Question 4: What if veriÆcation fails?

Answer: If the hash chain is broken, this indicates: -Database corruption
(e.g., from hard drive error) -Manual changes to the database (not via the
application)

Solution: Restore the database from a backup and contact support.

Question 5: Can I delete drafts without violating GoBD compliance?

Answer: Yes, deleting drafts is GoBD-compliant because: - Drafts are not
business transactions - Drafts don’t have invoice numbers - The deletion
is logged (for traceability)

Question 6: What if I discover an error in an invoice after 10 years?

Answer: After the retention period expires (10 years), you can delete doc-
uments. If you discover an error, you cannot change the invoice anymore
– but the tax period has expired, so no problem.

Question 7: Do I have to print the audit log for the tax auditor?

Answer: No, the digital form (CSV + ZIP archive) is sufÆcient. The auditor
analyzes the data digitally with specialized software.
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Question8: What ifmycomputer crashesand thedatabase isdamaged?

Answer: That’s why regular backups are important: -Automatic backups:
ConÆgure daily backups in settings (see Chapter 9) -Monthly exports: Cre-
ate GoBD exports and store them externally - Cloud backup: Use cloud
storage for double security

If the database is damaged, restore it from the most recent backup.

10.12 Practical WorkÇows
WorkÇow 1: Create Monthly Export for Accounting (10 minutes)

Goal: Create a GoBD export archive every month for your accounting.

Steps:

1. Choose timing (5 minutes at beginning of month)
• E.g., on the 1st of each month for previous month

2. Create export (3 minutes)
• Open File → Export audit log…
• Select tenant
• Period: 1st to last day of previous month (e.g., 11/01/2025 to
11/30/2025)

• Storage location: ~/Documents/GoBD-Exports/2025/
• Click Export

3. Secure archive (2 minutes)
• Copy ZIP Æle to your cloud folder (Dropbox, Google Drive)
• Optional: Copy to external hard drive

Result: You have a complete archive for the month that you can use any-
time for tax audits.

[*]WorkÇowTip: Create a calendar entry “Create GoBD export” on the 1st
of each month as a reminder.

WorkÇow 2: Before Tax Audit: Prepare Data (30 minutes)

Goal: Prepare all data for an upcoming operational audit.

Steps:

1. Clarify audit period (2 minutes)
• The auditor speciÆes the period (e.g., 01/01/2023 to
12/31/2025)

2. Verify audit log (5 minutes)
• Open File → Verify audit log
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• Select Complete chain
• Click Start veriÆcation
• Check result: Success (if failed, contact support)

3. Create export for audit period (10 minutes)
• If period spans multiple years, create one export per year:

– 01/01/2023 to 12/31/2023 →
gobd_export_MyCompany_2023.zip

– 01/01/2024 to 12/31/2024 →
gobd_export_MyCompany_2024.zip

– 01/01/2025 to 12/31/2025 →
gobd_export_MyCompany_2025.zip

• Storage location: ~/Documents/Tax-Audit-2025/
4. Verify exports (10 minutes)

• Open File → Verify export archive…
• Select all ZIP Æles one by one
• Click Start veriÆcation
• Check result: Success

5. Hand over data (3 minutes)
• Copy all ZIP Æles to USB stick for auditor
• Or: Provide cloud link (e.g., Dropbox share)

Result: You have prepared and veriÆed all data for tax audit – ready for
handover.

[i] Pro Tip: If auditor requires Z1 access (direct database), Ærst create a
complete backup of the database.

WorkÇow 3: Regular VeriÆcation (Quarterly, 15 minutes)

Goal: Check the integrity of your audit log quarterly (preventive).

Steps:

1. Choose timing (e.g., end of each quarter)
• March 31, June 30, September 30, December 31

2. Complete veriÆcation (10 minutes)
• Open File → Verify audit log
• Select Complete chain
• Click Start veriÆcation
• Wait for result (can take several minutes with many entries)

3. Document result (5 minutes)
• If Success: Note date and result (e.g., in notes app)
• If Failed: Contact support immediately and create backup

Result: You ensure that your data is always intact and no manipulations
exist.
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[*]WorkÇowTip: Create a calendar entry “Verify audit log” on the last day
of each quarter.

10.13 Pro Tips for GoBD Compliance
[»]Monthly exports: Create a GoBD export archive every month and store
it in the cloud– thiswayyoualwayshaveanarchive readyandareprepared
for tax audits.

[i] Correction invoices instead of changes: If you discover an error in a
published invoice, use Create correction invoice – this way original in-
voice and change remain traceable.

[*] VeriÆcation before export: Verify the audit log before each export for
tax audits – this ensures no manipulations exist.

[!] No manual database changes: Never change the database manually
(e.g., with SQLite browser) – this breaks the hash chain and violates GoBD
compliance.

[~] Enable automatic backups: ConÆgure daily backups in settings (see
Chapter 9) – this protects you from data loss.

[i]Don’t publish drafts before they’re ready: Only publish invoices when
all data is correct – retroactive changes are not possible.

[*] WORM storage for archives: Store GoBD export archives on Write
OnceReadManymedia (external harddrive, cloudwithObject Lock) – this
protects them from accidental deletion.

[»] Quarterly veriÆcation: Verify the audit log quarterly (every 3 months)
– this helps you detect problems early.

[i] Include README for auditors: ZIP exports automatically contain a
README.txt for tax auditors – you don’t need to explain anything extra.

[*] Backup-backup: Keep second copy of your GoBD exports at different
location (e.g., external hard drive at friends/family) – Ære protection!

Continue with Chapter 11: Appendix

11. Appendix
This appendix contains additional information to help you with daily work
in the application.
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11.1 Glossary
A

Audit Log
Immutable list of all business transactions. Documents Who, What, When.
Uses cryptographic hash chain. See Chapter 10.3 (The Audit Log).

Auditability
GoBD principle: Tax auditors must be able to review the data. See Chapter
10.2 (The Seven GoBD Principles).

B

Backup
Backup copy of the database. Can be created automatically (daily, weekly,
monthly) or manually. See Chapter 10.4 (Backup).

BIC (Bank IdentiÆer Code)
International bank identiÆer code (ISO 9362). Also called SWIFT code. Re-
quired for international payments.

C

Client
An AGYNAMIX Invoicer installation that connects to a Host over the net-
work and shares its data. The client works with a local synchronized
replica of the host database. See Chapter 12.5 (Connecting as Client).

Correction Invoice
Invoice with negated line items that corrects an erroneous invoice. FulÆlls
GoBD requirement of immutability.

CSV (Comma-Separated Values)
Text format for tabular data. Used for GoBD exports (separator: semicolon,
encoding: UTF-8 with BOM).

Customer
Business partner to whom you issue invoices or quotes. Can havemultiple
addresses (billing address, delivery address).

D

Database
SQLite database that stores all business data. Storage location: -
Linux: ~/.local/share/agynamix-invoicer/invoicer_db.db
- macOS: ~/Library/Application Support/agynamix-
invoicer/invoicer_db.db - Windows: %LOCALAPPDATA%\agynamix-
invoicer\invoicer_db.db
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DATEV
The accounting software systemmost commonly used byGerman tax advi-
sors. When you export data in DATEV format, your tax advisor can import
it directly into their accounting systemwithoutmanual re-entry. SeeChap-
ter 10 for export options.

Delivery Note
Document that conÆrms delivery of goods. No payment request.

Demo Database
Prefabricated database with sample data for tests and screenshots. In the
application this is stored as a sandbox and can be removed via Edit →
Delete Demo Data.

Document Status
Current status of a document (Draft, Published, Sent, Partially paid, Fully
paid, Canceled, Deletable). See Chapter 3.5 (Understanding document sta-
tus).

Draft
Preliminary version of a document that can still be edited. Not recorded in
audit log (except deletion). Only receives document number upon publica-
tion.

E

E-Invoice (Electronic Invoice)
Invoice in structured format (XRechnung or ZUGFeRD) that can be pro-
cessed by machine. Mandatory from 2025 for B2G invoices, from
2027/2028 for B2B invoices.

G

GoBD (Principles for the proper management and storage of books,
records, and documents in electronic form as well as for data access)
Guidelines from the Federal Ministry of Finance for electronic bookkeep-
ing. See Chapter 10 (GoBD Compliance).

H

Hash (Cryptographic Hash)
Unique checksum (SHA-256) of an audit log entry. Used for hash chain to
detect manipulation.

Hash Chain
Linking of audit log entries through cryptographic hashes. Each entry con-
tains the hash of the previous entry. Manipulation breaks the chain.
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Headless Mode
Starting AGYNAMIX Invoicer with the --headless Çag so no desktop win-
dow is shown. The server runs silently in the background and accepts
client connections. Only available when the installation is conÆgured as
Host. See Chapter 12.4 (Headless Mode).

Host (Server)
The central AGYNAMIX Invoicer installation that stores the authoritative
database and shares it with Clients. The host can run interactively (with a
window) or headlessly (as a background server). See Chapter 12.3 (Setting
Up as Host).

I

IBAN (International Bank Account Number)
International bank account number (ISO 13616). Required for SEPA pay-
ments in Europe.

Immutability
GoBD principle: Published invoices may no longer be changed. Changes
only via correction invoices.

Invoice
Payment request to a customer. Must contain certain mandatory informa-
tion according to § 14 UStG (invoice number, tax number, VAT amount,
etc.).

M

Leitweg-ID
A routing identiÆer required on XRechnung invoices sent to German
public-sector clients. It tells the government’s receiving system exactly
which department or cost center should receive the invoice. Ask your
public-sector customer for their Leitweg-ID before creating the invoice.

Markdown
Simple markup language for formatted texts (bold, italic, lists, etc.). Used
in text blocks. See Chapter 7.6 (Markdown syntax).

N

Number Pattern
Template for document numbers (e.g., RE-{year}-{doc_no}). Uses
placeholders like {year}, {month}, {doc_no}. See Chapter 5.7 (Under-
standing number patterns).
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O

Operational Audit
Tax audit by the tax ofÆce. Can require Z1, Z2, or Z3 access to your data.
See Chapter 10.10 (Data access for tax auditors).

Order ConÆrmation
ConÆrmation of an order placed by the customer. Sent before service de-
livery.

P

Payment Reminder
Payment reminder for overdue invoices. Can be multi-level (level 1, 2, 3
with increasing reminder fees).

Payment Term
Period within which an invoice must be paid (e.g., 14 days, 30 days). After
expiration, the invoice is overdue.

PDF (Portable Document Format)
Standard format for exported invoices. Can be combined with XRechnung
(XML) for e-invoices.

Publish
Transfer document from Draft status to Published status. From this point
on, the document is immutable and receives a document number.

Q

Quote
Non-binding offer to a customer that can later be converted into an invoice.
Quotes have no tax relevance until they are accepted.

R

Retention Obligation
Legal obligation to keep business documents for at least 10 years (§ 147
Abs. 3 AO). Start: End of the calendar year in which the document was
created.

Replica
Local copy of the host database stored on a client machine. The replica is
synchronized automatically when the client is connected to the host. It is
read/write locally but the host is always the source of truth. See Chapter
12.6 (Client Mode: What to Expect).

Reverse Charge
Whenyou invoice a business customer in another EUcountry, you typically
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do not charge VAT — instead, the customer self-reports the VAT in their
own country. This is called the reverse charge procedure. Both parties
must have valid VAT IDs. In AGYNAMIX Invoicer, reverse charge is handled
automatically when the customer has a foreign VAT ID and the correct tax
rule is applied. (Legal basis: § 13b UStG.)

S

Sequence Number
Sequential number in audit log (0, 1, 2, 3, …). Guarantees gap-free chain.

SQLite
Embedded database engine. Stores all data in a single Æle
(invoicer_db.db).
Standalone
The traditional single-computer operating mode. All data is stored locally
and nothing is shared over the network. Standalone is the default and the
mode all existing users are already in. See Chapter 12.1 (Overview: Stan-
dalone, Host, and Client).

Synchronization
The automatic process of keeping a client’s local replica up to date with
the host database. Synchronization runs in the background whenever the
client is connected. See Chapter 12.6.1 (Data and Synchronization).

T

Tenant
Legally independent company or business unit. Enables multi-company
management in one application. Each tenant has its own invoice number
ranges.

Text Block
Reusable text section for invoices (e.g., introduction, closing phrase, pay-
ment terms). Supports Markdown.

Timesheet
Recording of worked hours for billing. Can be converted into invoice.

Transaction
Tax-relevant event (e.g., publish invoice, record payment). Documented in
audit log.

V

VAT ID (Value Added Tax IdentiÆcation Number)
Europe-wide unique number for companies (e.g., DE123456789). Re-
quired for reverse charge procedure (§ 13b UStG).

302



VeriÆcation
Check of hash chain in audit log to detect manipulation. See Chapter 10.6
(Verify audit log).

X

XRechnung
A structured e-invoice format required for invoices to German public-
sector clients (Bund, Länder, large municipalities). Unlike ZUGFeRD,
XRechnung is XMLonly— it hasnohuman-readable PDFcomponent, but it
can be processed entirely by machine. Mandatory from 2025 for invoices
to public clients, with B2Bmandates following from 2027/2028. See Chap-
ter 6.8 (E-Invoices (ZUGFeRD & XRechnung)).

Z

Z1, Z2, Z3 (Data Access)
Three access levels for tax audits. Z1 = direct access to database, Z2 = Æl-
tered export, Z3 = complete export. See Chapter 10.10 (Data access for tax
auditors).

ZUGFeRD (Central User Guide of the Forum for Electronic Invoicing
Germany)
A practical e-invoice format that combines a normal PDF invoice with
machine-readable XML data embedded inside the same Æle. Your cus-
tomer can open it as a regular PDF and read it, while their accounting soft-
ware can also import the data automatically without manual entry. Think
of it as a PDF that is also a data Æle. See Chapter 6.8 (E-Invoices (ZUGFeRD
& XRechnung)).

11.2 Keyboard Shortcuts
Global Keyboard Shortcuts

Keyboard Shortcut Action Available in

Ctrl+, (Windows/Linux)Cmd+,
(macOS)

Open
settings

Everywhere

Ctrl+N
(Windows/Linux)Cmd+N
(macOS)

Create new
document

Document list

Ctrl+S (Windows/Linux)Cmd+S
(macOS)

Save
document

Document editor
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Keyboard Shortcut Action Available in

Ctrl+W
(Windows/Linux)Cmd+W
(macOS)

Close
current
window

Dialog/window

Ctrl+Q
(Windows/Linux)Cmd+Q
(macOS)

Exit
application

Everywhere

Esc Close dialog Dialogs

Menu Keyboard Shortcuts

Keyboard Shortcut Action Menu

Ctrl+B (Windows/Linux)Cmd+B
(macOS)

Create backup File

Ctrl+R (Windows/Linux)Cmd+R
(macOS)

Restore from
backup

File

F1 Open
documentation

Help

Ctrl+U (Windows/Linux)Cmd+U
(macOS)

Check for
updates

Help

Document Editor

Keyboard Shortcut Action Context

Tab Jump to next
Æeld

Form

Shift+Tab Jump to
previous Æeld

Form

Ctrl+Enter
(Windows/Linux)Cmd+Enter
(macOS)

Save
document

Form

Ctrl+P (Windows/Linux)Cmd+P
(macOS)

Open PDF
preview

Document

Markdown Editor (Text Blocks)

Keyboard Shortcut Action Result

Ctrl+B (Windows/Linux)Cmd+B
(macOS)

Format bold **Text**
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Keyboard Shortcut Action Result

Ctrl+I (Windows/Linux)Cmd+I
(macOS)

Format italic *Text*

Ctrl+K (Windows/Linux)Cmd+K
(macOS)

Insert link [Text](URL)

[i] Pro Tip: Hover over buttons to see tooltips with keyboard shortcuts.

11.3 Troubleshooting
Problem 1: ApplicationWon’t Start

Symptoms: - Application doesn’t open on double-click - Error message:
“Java not found”

Possible Causes: 1. Corrupted or incomplete installation (bundled run-
timemissing) 2. Running a JAR build without Java 21 or higher installed 3.
Wrong Java version (e.g., Java 17)

Solution:

1. If you installed the native app (Windows installer / macOS DMG /
Linux package):

• Reinstall the application (a Java runtime is included)

2. Check Java version (only relevant when running from source/JAR):

java -version
Expected output: openjdk version "21.x.x"

3. Install Java 21 (only if you run from source/JAR):

• Download a Java 21 JDK (e.g., from https://adoptium.net/)
• Make sure your java points to that installation

4. Restart application

Problem 2: Database Locked

Symptoms: - Error message: “Database is locked” - Application freezes
when saving

PossibleCauses: 1. Application is already running inbackground2. Crash
without clean exit (lock Æle remains)
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Solution:

1. Check if application is running:

# Linux/macOS
ps aux | grep -i invoicer | grep -v grep

# Windows (PowerShell)
Get-Process | Where-Object {$_.ProcessName -like "*invoicer*"}

2. Terminate process:

# Linux/macOS
pkill -f "com.agynamix.invoicer.LauncherKt"

# Windows (PowerShell)
Stop-Process -Name "AGYNAMIX Invoicer" -Force

3. Manually delete lock Æle (if process is not running):

# Linux/macOS
rm ~/.local/share/agynamix-invoicer/invoicer_db.db-journal
rm ~/.local/share/agynamix-invoicer/invoicer_db.db-wal
rm ~/.local/share/agynamix-invoicer/invoicer_db.db-shm

# Windows
del %LOCALAPPDATA%\agynamix-invoicer\invoicer_db.db-journal
del %LOCALAPPDATA%\agynamix-invoicer\invoicer_db.db-wal
del %LOCALAPPDATA%\agynamix-invoicer\invoicer_db.db-shm

4. Restart application

[!] Important: Only delete lock Æles if the application is really not running
– otherwise you risk data loss.

Problem 3: PDF Export Fails

Symptoms: - Error message: “Document folder not conÆgured” - PDF is
not created

Possible Causes: 1. Document folder is not conÆgured in settings 2. Doc-
ument folder doesn’t exist (was deleted) 3. No write permissions on docu-
ment folder

Solution:

1. ConÆgure document folder:

• Open Settings (Ctrl+, / Cmd+,)
• Scroll to Documents

306



• Click Choose directory next to Document folder
• Select a folder (e.g., ~/Documents/Invoices/)
• Click Select folder

2. Check write permissions:

# Linux/macOS
ls -ld ~/Documents/Invoices/
# Expected output: drwxr-xr-x (first 10 characters)

# If no write permissions:
chmod +w ~/Documents/Invoices/

3. Export again

Problem 4: XRechnung Validation Fails

Symptoms: - Error message: “XRechnung validation failed” - Customer
cannot process XML

Possible Causes: 1. Required Æelds missing (e.g., customer VAT ID) 2.
IBAN/BIC invalid 3. Tax rate not speciÆed

Solution:

1. Check customer data:
• Open Customers→ Select customer
• Check Billing data:

– VAT ID: Must be Ælled (e.g., DE123456789)
– Currency: Must be valid (EUR, USD, CHF)
– Default tax rate: Must be set (19% or 7%)

2. Check tenant bank details:
• Open Tenants→ Select tenant
• Check Bank connection:

– IBAN: Must be valid (e.g., DE89370400440532013000)
– BIC: Must be valid (e.g., COBADEFFXXX)

3. Export invoice againwith XRechnung option

[i] Pro Tip: Use the KoSIT XRechnung Validator online to check XML Æles.

Problem 5: VeriÆcation Fails (Hash Chain Broken)

Symptoms: - Error message: “Hash chain is broken” - VeriÆcation failed
at sequence number X
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Possible Causes: 1. Database corruption (e.g., from hard drive error) 2.
Manual changes to database (e.g., with SQLite browser) 3. Crash during
audit log write operation

Solution:

1. Restore backup:
• Open File → Restore from backup…
• Select newest intact backup (before the problem)
• Click Restore

2. If no backup available:
• Contact support (see Section 10.5)
• Send the following information:

– Error message (screenshot)
– Sequence number where error occurred
– Database Æle (if possible)

[!] Important: A broken hash chain is a serious problem – it indicates
database corruption or manipulation.

Problem 6: Payment Reminder Cannot Be Created

Symptoms: - Button Create reminder is grayed out - Error message: “In-
voice must be published and overdue”

Possible Causes: 1. Invoice is still draft (not published) 2. Invoice is not
yet due (payment term not expired) 3. Invoice is already fully paid

Solution:

1. Check invoice status:
• Open the invoice
• Check status: Must be Published or Sent

2. Check due date:
• Check Payment term: E.g., 14 days after invoice date
• Check current date: Must be after payment term

3. Check payment status:
• Check Payment status: Must be Unpaid or Partially paid
• If fully paid: Reminder not possible

Example: - Invoice from 11/01/2025, payment term 14 days - Due date:
11/15/2025 - Reminder possible from 11/16/2025
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Problem 7: Demo Data Cannot Be Deleted

Symptoms: - Error message: “Demo data could not be deleted” - Menu
item Edit → Delete Demo Data is grayed out

Possible Causes: 1. No demo data available (database was created manu-
ally) 2. Database contains production data

Solution:

1. Check if demo database is loaded:
• OpenHelp → About
• If demo database: Notice appears

2. Manual deletion (if necessary):
• Close the application
• Delete the sandbox database Æle:
# Linux
rm ~/.local/share/agynamix-invoicer/sandbox.db

# macOS
rm ~/Library/Application\ Support/agynamix-invoicer/sandbox.db

# Windows
del %LOCALAPPDATA%\agynamix-invoicer\sandbox.db
• Restart the application

[!] Important: Manual deletion removes all data – only use it if you’re sure.

Problem 8: Application Is Very Slow

Symptoms: - Document list loads slowly - Search takes several seconds -
UI freezes

Possible Causes: 1. Database is very large (>100,000 documents) 2.
Database is on slow hard drive (network drive, USB) 3. Too little RAM (<
4 GB)

Solution:

1. Check database size:

# Linux/macOS
ls -lh ~/.local/share/agynamix-invoicer/invoicer_db.db

# Windows (PowerShell)
Get-Item $env:LOCALAPPDATA\agynamix-invoicer\invoicer_db.db | Select-Object Length

2. Move database to local SSD (if on network drive):

309



• Close the application
• Copy invoicer_db.db to local SSD
• Restart the application

3. Archive old documents:

• Create GoBD export for old years (see Chapter 10.5)
• Delete old documents (if retention period expired)

4. Allocate more RAM (if possible):

• Close other applications
• Upgrade to at least 8 GB RAM

11.4 Technical Information
System Requirements

Minimum: - Operating System: Windows 10, macOS 11 Big Sur, Linux
(Ubuntu 20.04 or newer) - Java: OpenJDK 21 or higher -RAM: 4 GB -Hard
Drive: 500 MB free space - Screen Resolution: 1280x720 pixels

Recommended: - Operating System: Windows 11, macOS 13 Ventura,
Linux (Ubuntu 22.04 or newer) - Java: OpenJDK 21 - RAM: 8 GB or more -
Hard Drive: 2 GB free space (incl. backups and exports) - Screen Resolu-
tion: 1920x1080 pixels or higher

Database Storage Location

The SQLite database is automatically created in the user directory:

Linux:

$HOME/.local/share/agynamix-invoicer/invoicer_db.db
macOS:

~/Library/Application Support/agynamix-
invoicer/invoicer_db.db
Windows:

%LOCALAPPDATA%\agynamix-invoicer\invoicer_db.db
Additional Æles (temporary): - invoicer_db.db-journal: Transaction
journal (only during write operations) - invoicer_db.db-wal: Write-
Ahead Log (performance optimization) - invoicer_db.db-shm: Shared
Memory (performance optimization)

[i] Pro Tip: To back up the database, only copy invoicer_db.db – tempo-
rary Æles are automatically recreated.
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Open Database Folder

Via the application: 1. Click Help in the menu bar 2. Select Open
database folder 3. The folder opens in Æle manager

Manually:

Linux/macOS:

cd ~/.local/share/agynamix-invoicer/
# or for macOS:
cd ~/Library/Application\ Support/agynamix-invoicer/
Windows (PowerShell):

cd $env:LOCALAPPDATA\agynamix-invoicer\

Log File (Debug Information)

The log Æle can be helpful in case of problems:

Display log Æle: 1. Click Help in the menu bar 2. Select Show log 3. The
log Æle opens in a text editor

Log storage location:

Linux:

$HOME/.config/agynamix-invoicer/logs/app.log
macOS:

~/Library/Application Support/agynamix-
invoicer/logs/app.log
Windows:

%LOCALAPPDATA%\agynamix-invoicer\logs\app.log
Example log entry:

2026-01-12 10:15:22 INFO [main] c.a.i.MainKt -
Starting Agynamix Invoicer v1.2.0
2026-01-12 10:15:23 INFO [main] c.a.i.db.DatabaseManager -
Database initialized successfully
2026-01-12 10:15:25 ERROR [main] c.a.i.ui.MainScreen -
Failed to load tenants: Database locked
[i] Pro Tip: Include the log Æle with support requests – it helps with error
diagnosis.
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Technologies Used

The application uses the following open-source libraries:

Library Version License Purpose

Apache
PDFBox

3.0.6 Apache License
2.0

PDF creation
and
manipulation

Flexmark 0.64.8 BSD 2-Clause Markdown
processing

FlatLaf 3.6.2 Apache License
2.0

Modern Swing
look-and-feel

Flying Saucer 10.0.0 LGPL 2.1+ HTML-to-PDF
rendering

Jetpack
Compose

1.9.0 Apache License
2.0

UI framework

Koin 4.1.1 Apache License
2.0

Dependency
injection

Kotlin 2.1.0 Apache License
2.0

Programming
language

Kotlinx
Serialization

1.8.0 Apache License
2.0

JSON
serialization

Logback 1.5.16 EPL 1.0 / LGPL
2.1

Logging
framework

Mustangproject 3.3.3 Apache License
2.0

ZUGFeRD/XRechnung
creation

Pebble
Templates

3.2.4 BSD 3-Clause Template
engine

SQLDelight 2.1.0 Apache License
2.0

Type-safe
Kotlin SQL

SQLite JDBC 3.50.3.0 Apache License
2.0

SQLite driver

unDraw 2025 unDraw License Open-source
illustrations

Complete licenses: - Open Help → About in the application - Click Show
licenses

Version Information

Version: 1.2.0
Build Date: January 12, 2026
Git Commit: [Commit hash]
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Display version information: 1. Click Help in the menu bar 2. Select
About 3. Version information appears in dialog

11.5 License and Copyright
License

AGYNAMIX Invoicer is proprietary software.

Copyright © 2025 AGYNAMIX Torsten Uhlmann
Buchenweg 5
09380 Thalheim
Germany

All rights reserved.

License Grant

AGYNAMIX Torsten Uhlmann (“Licensor”) grants you a limited, non-
exclusive, non-transferable, revocable license to use this software (“Soft-
ware”) exclusively for your personal or internal business purposes.

Restrictions

You may not: - Copy, modify, adapt, translate, or create derivative works
of the Software - Reverse engineer, decompile, disassemble, or attempt to
derive the source code of the Software - Rent, lease, lend, sell, sublicense,
distribute, or otherwise transfer the Software to third parties - Remove, al-
ter, or obscure any proprietary notices on the Software - Use the Software
for illegal purposes or in violation of applicable laws

Full License

The complete license agreement can be found at: - German:
https://invoicer.agynamix.de/manual/de/v1.4/license.pdf - English:
https://invoicer.agynamix.de/manual/en/v1.4/license.pdf

Or in the application: 1. ClickHelp in themenubar 2. SelectAbout3. Click
Show license

11.6 Support and Contact
Online Documentation

Website: https://invoicer.agynamix.de
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On the website you will Ænd: - Complete user manual (PDF download)
- Video tutorials (planned) - FAQ (frequently asked questions) - Release
notes (version notes)

Support Contact

Email: support@agynamix.de

Response Time: Weekdays within 24 hours

Whencontactingsupport, pleaseprovide: -Versionnumber (seeHelp→
About) -Operating system (Windows, macOS, Linux with version) - Error
description (step-by-step, what you did) - Error message (screenshot or
exact wording) - Log Æle (if relevant, see Section 10.4)

Updates

Automatic update check: - Open Settings (Ctrl+, / Cmd+,) - Enable Auto-
matically check for updates under Updates

Manual update check: 1. Click Help in the menu bar 2. Select Check for
updates 3. If update available: Dialog with download link appears

Update interval: New versions are released approximately every 2–4
weeks (beta phase), later quarterly.

Community

Planned (in the future): - Forum: Community forum for questions and
exchange - Blog: Tips, tricks, and best practices - Newsletter: Monthly
newsletter with new features

11.7 About This Documentation
Version

Documentation version: 1.2.0
Date: January 12, 2026
Application version: 1.2.0

Authors

This documentation was created by: - AGYNAMIX Torsten Uhlmann
(Main author)
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Feedback

If you Ænd errors in this documentation or have suggestions for improve-
ment, please contact us:

Email: documentation@agynamix.de

Subject: “User Manual Feedback v1.2.0”

Please specify: - Chapter: Which chapter does your feedback concern?
(e.g., “Chapter 3.7”) - Page/Section: Where exactly is the problem? (e.g.,
“WorkÇow2: Create invoice”) -Error type: Spelling error, unclearwording,
missing information,wrong screenshot? - Improvement suggestion: How
should it be better worded?

[i] Pro Tip: Screenshots with markings help us understand your feedback
faster.

Change History

Version 1.0 (November 16, 2025): - First complete release - All 11 chap-
ters completed - 316 Ægures (placeholders for screenshots) - Glossary with
40+ terms - 8 common problems with solutions

Version 1.2.0 (January 12, 2026): - Updated Settings chapter with Email,
Document Emails, and User Management - Added a dedicated “Send doc-
ument via email” section in Documents - Expanded customer/tenant doc-
umentation with new contact and business Æelds

11.8 Frequently Asked Questions (FAQ)
General

I published an invoice bymistake — what do I do?
You cannot unpublish an invoice (this is a GoBD requirement — all pub-
lished business documents must remain in the audit log). However, you
can issue a correction invoice that negates the incorrect invoice. Go to
the invoice, click Correction Invoice, and conÆrm. This creates a new in-
voice with all items negated (effectively cancelling the original), and you
can then create a correct invoice from scratch.

My invoice number skipped a number — is that a problem?
A gap may be suspicious to tax auditors but is not automatically a le-
gal violation (German courts have conÆrmed this). However, you should
document the reason (e.g., “test invoice deleted” or “numbering scheme
changed”). AGYNAMIX Invoicer’s audit log records all actions, which helps
explain gaps.
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How do I changemy company logo or address on published invoices?
Published invoices cannot be changed (immutability principle). To change
your company details for future invoices, go to Tenants and update the
tenant’s data. Previously published invoices will retain the data that was
current at the time they were published.

Can I delete an invoice?
You can only delete drafts. Published invoices must Ærst be transitioned
to “Deletable” status via the normal workÇow (correction → cancel). Even
then, the audit log entry remains. This is required by GoBD.

How do I send an invoice by email?
Open the invoice, click Send by Email. The email dialog opens pre-Ælled
with the customer’s email address and a subject based on the document
number. You can edit the message before sending. SMTP must be conÆg-
ured in Settings → Email.

What is the difference between a backup and an audit log export?
A backup is a copy of your entire database — it lets you restore all your
data if something goes wrong (hardware failure, accidental deletion). An
audit log export is a compliance export speciÆcally for tax purposes — it
is a structured, tamper-evident record of all business transactions that tax
auditors can examine. You need both: backups for disaster recovery, audit
log exports for GoBD compliance.

I forgot my password —what do I do?
UseHelp→PasswordReset in the application (if available), or contact sup-
port at support@agynamix.de with your account details and the operating
system you’re using.

Is my data safe? Where is it stored?
All your data is stored locally on your computer — nothing is sent to the
cloud unless you explicitly conÆgure a cloud folder for backups or archive.
The database Æle is located at: -Windows: %LOCALAPPDATA%\agynamix-
invoicer\invoicer_db.db - macOS: ~/Library/Application
Support/agynamix-invoicer/invoicer_db.db - Linux:
~/.local/share/agynamix-invoicer/invoicer_db.db

Client-Server Mode

My client can’t connect to the host — what do I check?
Work through this checklist: 1. Is the host computer running and the ap-
plication open (or running in headless mode)? 2. Are the host address,
port, username, and API token correct on the client? 3. Is there a Ærewall
on the host computer blocking the port? (Check Windows Defender Fire-
wall / macOS Firewall / ufw on Linux) 4. Can you ping the host from the
client computer? (ping <host-ip>) 5. Can you reach the host directly via
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a browser? (http://<host-ip>:<port>/health should return a 200 re-
sponse) 6. If the host is behind a router, is port forwarding conÆgured?

If all else fails, contact support at support@agynamix.de with details of
your network conÆguration.

11.9 Migrating to a New Computer
If you’removing AGYNAMIX Invoicer to a new computer (e.g., buying a new
laptop or upgrading your workstation), follow this guide to transfer your
data without losing anything.

Step 1: Create a Backup on the Old Computer

1. On the old computer, open AGYNAMIX Invoicer
2. Go to File → Create Backup (or Settings→Backup→Create Backup

Now)
3. Choose a location you can easily access from the new computer (e.g.,

a USB drive, a cloud folder, or a shared network drive)
4. Click Create— a .zip backup Æle is created
5. Note the location of this backup Æle — you’ll need it in Step 3

[i] Tip: You can also simply copy the database
Æle directly if you prefer. The database is at
~/.local/share/agynamix-invoicer/invoicer_db.db
(Linux), ~/Library/Application Support/agynamix-
invoicer/invoicer_db.db (macOS), or
%LOCALAPPDATA%\agynamix-invoicer\invoicer_db.db
(Windows). However, using the built-in backup is safer as it
ensures a consistent state.

Step 2: Install AGYNAMIX Invoicer on the New Computer

1. Download the installer for your new operating system from https://
invoicer.agynamix.de

2. Install and start the application once to ensure it runs correctly
3. Close the application before restoring your data

Step 3: Restore Your Backup on the New Computer

1. On the new computer, open AGYNAMIX Invoicer
2. Go to File → Restore Backup
3. Navigate to your backup Æle and select it
4. If the backup is encrypted, enter the passphrase when prompted
5. ConÆrm the restore — the application will restart with your data
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Step 4: ReconÆgure Local Settings

Some settings are local to each computer and not included in the backup.
After restoring, check and reconÆgure:

Setting Where Notes

Document folder Settings →
Documents

Re-select or create a
folder on the new
machine

Backup directory Settings → Backup Point to a location
on the newmachine

Archive location Settings →
Documents →
Archive

Re-select the
archive folder

SMTP settings Settings → Email Re-enter email
server credentials

Theme Settings →
Appearance

Re-select your
preferred theme

Step 5: Verify Your Data

After restoring, quickly verify that your data transferred correctly: - [ ] Ten-
ant(s) listed correctly - [ ] Customer list intact - [ ] Recent invoices visible - [
] Documents folder accessible and PDFs present (if you copied that too) - [
] Draft a test invoice to conÆrm everything works

Notes on License Transfer

If your license is tied to a speciÆc computer, you may need to deactivate
it on the old machine before activating it on the new one. Check Help →
License in the application, or contact support at support@agynamix.de.

End of Documentation

Thank you for using AGYNAMIX Invoicer! We hope this documentation
helps youwith your daily work. If you have questions, don’t hesitate to con-
tact us.

Good luck with your invoicing! [>]
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